Bug 470314 - Xorg freezes at GDM when Virtual flag is added to xorg.conf
Xorg freezes at GDM when Virtual flag is added to xorg.conf
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 470361
  Show dependency treegraph
 
Reported: 2008-11-06 12:05 EST by Bryan Christ
Modified: 2009-06-17 16:50 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 16:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Failing xorg configuration (538 bytes, text/plain)
2008-11-10 10:28 EST, Bryan Christ
no flags Details
Log file from failing configuration (92.37 KB, text/plain)
2008-11-10 10:39 EST, Bryan Christ
no flags Details
broken xorg.conf for Intel Corporation Mobile 945GM (1.87 KB, text/plain)
2008-11-17 10:43 EST, Brenton Leanhardt
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 18903 None None None Never

  None (edit)
Description Bryan Christ 2008-11-06 12:05:20 EST
Description of problem:

In order for xrandr to support extended desktops on dual-head configurations it is necessary to add the Virtual flag to the Display SubSection.  When this flag is added Xorg freezes at greeter screen (GDM) and the keyboard becomes unresponsive.

Version-Release number of selected component (if applicable):

xorg-x11-server-common-1.5.2-12.fc10.x86_64

How reproducible: 100%

Steps to Reproduce:
1.  Install Fedora 10 Preview for x86-64
2.  Make sure that your default dual-head (cloned) configuration works.
3.  Switch to runlevel 3
4.  Create a default xorg.conf for the system with X -configure
5.  Copy the output file to /etc/X11
6.  Edit the appropriate Display SubSection adding the Virtual flag.
7.  Save configuration and switch to runlevel 5
  
Actual results:

Xorg freezes at GDM greeter screen


Expected results:

Login to Xorg with a Virtual size that is usable for xrandr


Additional info:

System is a HP Compaq dc7800 with integrated Intel graphics and ADD2 extender card (2nd port).

Fedora 10 Preview is updated with the latest packages from rawhide.
Comment 1 Matěj Cepl 2008-11-07 18:15:45 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Bryan Christ 2008-11-10 10:24:46 EST
The working/original configuration has no xorg.conf file.  I used X -configure to create one that I could modify and add the Virtual flag to.  I will post that file.
Comment 3 Bryan Christ 2008-11-10 10:28:56 EST
Created attachment 323079 [details]
Failing xorg configuration
Comment 4 Bryan Christ 2008-11-10 10:39:36 EST
Created attachment 323082 [details]
Log file from failing configuration
Comment 5 Bryan Christ 2008-11-11 12:15:47 EST
Retested today with update package from rawhide and xorg still freezes at GDM greeter screen.

Package update is:
xorg-x11-drv-i810-2.5.0-3.fc10.x86_64
Comment 6 Rafal Kwasny 2008-11-13 16:53:01 EST
maybe it would be possible to change hardcoded default Virtual screen size?

3840x1920 should be enough for typical 2*FullHD setup and 30" monitors
Comment 7 Bryan Christ 2008-11-13 17:06:06 EST
To be quite honest, I'm not even sure why there has to be a minimum.  Nevertheless, the default is way to low to be useful with modern displays and graphic cards.
Comment 8 Brenton Leanhardt 2008-11-17 10:43:34 EST
Created attachment 323776 [details]
broken xorg.conf for Intel Corporation Mobile 945GM
Comment 9 Brenton Leanhardt 2008-11-17 10:44:15 EST
fqiw, I'm appear to be hitting this same problem.  I ran into this following the same almost the exact same steps:

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Steps to Reproduce:
1.  Install Fedora 10 Preview for i386
2.  Make sure that your default dual-head (cloned) configuration works.
3.  Switch to runlevel 3
4.  Create a default xorg.conf for the system with X -configure
5.  Copy the output file to /etc/X11
6.  Edit the appropriate Display SubSection adding the Virtual flag.
7.  Save configuration and switch to runlevel 5

The virtual flag I used is "Virtual   3360 1050".
Comment 10 Bryan Christ 2008-11-19 14:44:32 EST
Retested with updated package xorg-x11-server-Xorg-1.5.3-5.fc10.x86_64 and the problem still exists.
Comment 11 Bryan Christ 2008-11-24 12:19:06 EST
Tomorrow is launch day for F10... any chance of a fix being released today?
Comment 12 Bug Zapper 2008-11-25 23:53:56 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Giacomo Montagner 2008-11-28 02:34:32 EST
Hi, 
another occurrence here, my hardware (Toshiba Satellite A100): 

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

and my packages: 

xorg-x11-server-Xorg-1.5.3-5.fc10.i386
xorg-x11-drv-i810-2.5.0-3.fc10.i386

Same steps to reproduce, too. To be strict I generated my configuration as follows: 

a) Log on as normal user
b) launch system-config-display as root
c) save configuration
d) edit xorg.conf as root, add 
    virtual   2304 800
e) log out (X gets restarted and "freezes": mouse is working but nothing else is)

Cheers. 
Giacomo
Comment 14 Michael E Brown 2008-12-01 12:24:18 EST
Same problem on Dell D620 with Intel 945GM:
  00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Running with no config file works ok. Running system-config-display and adding 'Virtual ...' to the xorg.conf results in hard crash/machine lockup.
Comment 15 Michael E Brown 2008-12-01 18:02:29 EST
Additionally, I have tried both XAA and EXA, both crash. Disabling DRI also doesnt seem to fix this.
Comment 16 Michael E Brown 2008-12-01 18:25:32 EST
Adding Option "NoAccel" "true" fixes the crash at the cost of disabling acceleration... :(
Comment 17 Bryan Christ 2008-12-05 12:28:30 EST
All,

I pulled this out of the README file in the git repository for the intel driver.  It looks like prior to the 965 chipset dual-head might just not be possible--in other words, don't expect it to work if your chipset isn't ICH8 or newer.  However this doesn't seem to apply in my case since my system is infact ICH8.

From the README file:
"No support for X Screens larger than 2048 pixels in either direction
before the 965. This reflects hardware limitations in the x direction on
those older chips, and limits dualhead functionality. It may be possible to
extend the limit vertically on these older chips."
Comment 18 Brenton Leanhardt 2008-12-05 13:18:53 EST
Interesting.  Though I'm not sure I understand the hardware limitation part.  I had dual head working with my same hardware on Fedora 8.  All I had to do was set the Virtual screen size and then use xrandr.

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 19 Michael E Brown 2008-12-05 14:18:27 EST
Regardless of the fact that it isnt supposed to work, I can definitively tell you that this did, in fact, work on this very laptop (see comment #14) with Fedora 6, 7, and 8, using i180 driver on earlier versions and migrating to the intel driver on later versions. I skipped F9 on this particular machine, and the problems started with the F10 upgrade.

Now... 3D features were definitely disabled when I ran multihead. But I run multihead for productivity, not for running games, so I dont really care about that limitation.

What it does now it a hard lockup, and that is unacceptable under any standard.
Comment 20 Bryan Christ 2008-12-05 14:31:12 EST
Michael,

I agree.  I would rather have multi-head over 3D any day of the week.  Also, a hard-lock is unacceptable.  My expectation was that by submitting this Fedora BZ the report would trickle up to the developer (Eric Anholt) but it has not (as I personally contacted him).

Adam,

How do we make sure this gets attention/on the radar of the right person?  I believe there are probably lots of folks who would appreciate having this fixed.

Bryan
Comment 21 Bryan Christ 2008-12-05 14:37:47 EST
All,

I have created a nearly duplicate BZ over at Freedesktop.org (18903)
Comment 22 Brenton Leanhardt 2008-12-18 13:29:50 EST
I updated to xorg-x11-server-Xorg-1.5.3-6.fc10 and no longer experience the freeze.  I was not able to get dual head working by setting the Virtual size in Xorg (which had previously worked on this hardware with F8).
Comment 23 Felix Möller 2009-04-09 16:44:20 EDT
I have the same problem on my early 2006 MacBook.

btw. I used openSUSE 11.1 before where the problem did not occur...

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 24 Bryan Christ 2009-05-27 14:12:18 EDT
I don't have this problem on F11 because there is no need to add configuration flags--xrandr just works (on the same system).
Comment 25 Thiago Coutinho 2009-06-16 15:08:53 EDT
I confirm this in fedora 10 x86.
Comment 26 Michael E Brown 2009-06-17 11:35:32 EDT
I can confirm that the original problem is now fixed in F11 on my Dell D620 with Intel 945GM:
  00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)

I upgraded from F10 -> F11 and removed my xorg.conf.

I'll file a separate bug for the system crash I get when I run glxgears and expand it across monitors.
Comment 27 Matěj Cepl 2009-06-17 16:49:44 EDT
Wonderful. Closing then.

Note You need to log in before you can comment on or make changes to this bug.