Bug 470361 - Monitor Resolution Settings cannot configure independent dual-head screens
Monitor Resolution Settings cannot configure independent dual-head screens
Status: CLOSED DUPLICATE of bug 450394
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On: 470314
  Show dependency treegraph
Reported: 2008-11-06 16:10 EST by Bryan Christ
Modified: 2013-01-09 23:54 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-27 15:42:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bryan Christ 2008-11-06 16:10:26 EST
Description of problem:

In a dual-head configuration, Monitor Resolution Settings will only setup Mirrored mode.  If you uncheck "Mirror Screens" and apply settings, nothing happens.

Version-Release number of selected component (if applicable):

How reproducible: 100%

Steps to Reproduce:
1.  System -> Preferences -> Hardware -> Screen Resolution
2.  Uncheck "Mirror Screens"
3.  Click "Apply"
Actual results:

Nothing happens

Expected results:

Independent dual-head screens (extended desktop)

Additional info:

System is HP Compaq dc7800 with integrated Intel graphics and ADD2 extender card (for 2nd port).

Latest updates for Fedora 10 Preview from rawhide.

Two identical HP L2045 monitors
Comment 1 Florent Le Coz 2008-11-07 06:24:38 EST
I confirm this bug, I have exactly the same problem.
Comment 2 aepalea 2008-11-13 13:28:08 EST
I double confirm.  

I'm also running x86_64, FC10 rawhide, with latest patches.  In my case I have an ATI Sapphire RV370 graphics card, a 1680x1050 LCD on the left and a 19" CRT on the right, which I run at 1280x1024.

It comes up the first time with "Mirror Screens" ticked.  There is a single pink box displayed inside the panel with the truncated text "rror Scree" displayed.  

At the top left corner of each display, there is a wide pink box overprinted by narrower lime green box.  The green box says 'Samsung 21"'.  The visible part of the overprinted box displays '18"'  

If I unclick "Mirror Screens" I get two boxes.  It begins with the lime box right on top of the pink box.  I can drag the lime box to the left, then configure each display with the desired parameters.  

When I click "apply" nothing much happens.  My refresh rate on my CRT does not change.  The mouse moves sluggishly for about 3s, then returns to normal.  

If I leave this panel now, when I return, it comes back up in initial conditions.  It also fails to save the changes it failed to enact.
Comment 3 Florent Le Coz 2008-11-25 07:30:35 EST
Any news about this bug ?
A patch to test, an idea of the problem, something else ?
Comment 4 Ray Strode [halfline] 2008-11-25 09:40:09 EST
If you start the computer with both heads attached, does the problem happen?

Or is it only when plugging the additional monitor in after boot up?
Comment 5 Matěj Cepl 2008-11-25 09:52:39 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 Bryan Christ 2008-11-25 10:04:38 EST
This happens even when monitors are connected at the time X starts.
Comment 7 Bryan Christ 2008-11-25 10:07:00 EST

The log files you requested in comment #5 would be exactly the same as the ones listed on the "depends on" bug 470314 (of which I am the author).  Do you need me to copy them over or is it sufficient to know that you can find them there?

Comment 8 Matěj Cepl 2008-11-25 10:33:28 EST
no, thanks, attachment 323082 [details] is more than enough for me.
Comment 9 Bug Zapper 2008-11-25 23:54:55 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 10 Matěj Cepl 2009-06-27 15:40:37 EDT
*** Bug 450394 has been marked as a duplicate of this bug. ***
Comment 11 Matěj Cepl 2009-06-27 15:42:37 EDT

*** This bug has been marked as a duplicate of bug 450394 ***

Note You need to log in before you can comment on or make changes to this bug.