Bug 470322 - kernel oops with netinst.iso on PowerPC Apple Macintosh
kernel oops with netinst.iso on PowerPC Apple Macintosh
Status: CLOSED DUPLICATE of bug 468492
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10AnacondaBlocker
  Show dependency treegraph
 
Reported: 2008-11-06 12:55 EST by John Reiser
Modified: 2008-11-12 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 17:07:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hand transcription of final console (2.44 KB, text/plain)
2008-11-06 13:55 EST, John Reiser
no flags Details

  None (edit)
Description John Reiser 2008-11-06 12:55:48 EST
Description of problem: The console shows several kernel oops when booting the netinst.iso network install CD-ROM for Fedora 10 Preview on PowerPC Apple Macintosh.  The same problem occurred on two PowerPC G3 iBooks (boot rom 4.5.2f2 and 4.5.4f1) and one PowerPC G4 Mini (boot rom 4.8.9f1).


Version-Release number of selected component (if applicable):
kernel-2.6.27.4-68.fc10.ppc


How reproducible: always


Steps to Reproduce:
1. boot netinst.iso from Fedora 10 Preview
2.
3.
  
Actual results: kernel starts, console shows a penguin for each CPU, messages start scolling on video display, kernel seems to get through detecting USB2.0 controllers, but "soon" oopses.  There seem to be several oops.  anaconda gets error status 4; only choice is to reboot; no shell console on vty2.


Expected results: No kernel oops; proceed with install.


Additional info:  No serial console is available, so how can I preserve the messages, particularly the first one?  First attempts at taking a digital photo of video display screen were not particularly satisfactory: it was difficult to read the messages in the photo, and the first set of messages had already scrolled off the screen.  I might be able to manually transcribe the last screen onto a different laptop.
Comment 1 Jeremy Katz 2008-11-06 13:32:25 EST
Does selinux=0 help?  I know I saw discussion of a bug with selinux and ppc a few days ago
Comment 2 John Reiser 2008-11-06 13:55:28 EST
Created attachment 322773 [details]
hand transcription of final console

Booting "linux selinux=0" still gets the oopses; the messages look the same except for the long "hash" value that identifies the oops.  I re-typed the screen onto another machine, and proof-read it once (including down the columns of numbers); but it surely would be nice to do this by machine instead of by hand.
Comment 3 Will Woods 2008-11-12 12:48:33 EST
This is probably fixed in post-Preview images - specifically by yaboot-1.3.14-6.fc10.ppc, which fixed bug 468492.

Could you burn a rawhide boot.iso and see if that works?
Comment 4 John Reiser 2008-11-12 16:11:22 EST
The good news is that I boot successfully using:
   http://mirrors.cat.pdx.edu/fedora/linux/development/ppc/os/images/boot.iso
     12-Nov-2008 11:53           225746944
which says it has
   anaconda-11.4.1.57
   kernel-2.6.27.5-94.fc10.ppc
but the version of yaboot is not evident to me.

The bad news is that there are graphics problems.  The graphical splash screen first appears badly staggered and sheared, as if the pitch [memory address difference between adjacent lines] was bad by 64 pixels once every 8 scan lines.  Cycling through <Ctrl>+<Alt>+F{1,2,3,4,5,6} eventually gives the correct graphical display on vty6, shell on text vty2, anaconda output on vty1, etc.  Hardware is PCI 1002:4c57 ATI Radeon Mobility M7 LW [Radeon Mobility 7500].  I'll try the other boxes, then look for an existing BZ for this "new" problem.
Comment 5 Will Woods 2008-11-12 17:07:46 EST
Glad to see the boot problem is fixed.

As for the graphics stuff - radeon is known to be tricky; try 'nomodeset' and see if that helps.

*** This bug has been marked as a duplicate of bug 468492 ***

Note You need to log in before you can comment on or make changes to this bug.