Bug 468492 - F10 Snap3 ppc DVD fails to boot - numerous kernel oops messages
F10 Snap3 ppc DVD fails to boot - numerous kernel oops messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yaboot (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
: 469502 470141 470322 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 04:19 EDT by Alex Kanavin
Modified: 2014-01-12 19:07 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 13:51:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel errors during boot (869.04 KB, image/jpeg)
2008-10-25 04:19 EDT, Alex Kanavin
no flags Details
patch that fixes the problem (866 bytes, patch)
2008-10-29 13:00 EDT, Alex Kanavin
no flags Details | Diff

  None (edit)
Description Alex Kanavin 2008-10-25 04:19:14 EDT
Created attachment 321492 [details]
kernel errors during boot

Fedora 10 Snapshot 3 DVD poweprc DVD fails to boot on my Powerbook G4 12" machine. There's a number of kernel oops messages - see attachment for a sample.
Comment 1 Alex Kanavin 2008-10-25 04:19:58 EDT
Forgot to add, F10 Beta DVD works fine on the same machine.
Comment 2 Alex Kanavin 2008-10-29 07:40:03 EDT
Ok, the same problem has appeared when I updated my rawhide installation from yaboot-1.3.13-12 to yaboot-1.3.14-5. So it's clearly a yaboot regression.
Comment 3 Roman Rakus 2008-10-29 09:55:23 EDT
On my iBook G4 with F9 kernel (2.6.26.6-79.fc9.ppc) and yaboot 1.3.14-5 works well. What is the size of kernel and initrd images?
Comment 4 Alex Kanavin 2008-10-29 11:50:08 EDT
I'm not sure if the kernel/initrd size is the problem - as I said, latest iso images from rawhide fail to boot in the same way. But anyway:

-rw------- 1 root root 3893219 Окт 28 21:49 initrd-2.6.27.4-58.fc10.ppc.img
-rwxr-xr-x 1 root root 5928752 Окт 28 00:49 vmlinuz-2.6.27.4-58.fc10.ppc
Comment 5 Alex Kanavin 2008-10-29 13:00:41 EDT
Created attachment 321822 [details]
patch that fixes the problem

I've done some testing and can confirm that reverting the following commit (the patch is attached) fixes the problem:
==============
commit c8b04c614770870d75825c19bcd4729cc779b84a
Author: Paul Nasrat <pauln@enki.eridu>
Date:   Mon Dec 3 13:04:19 2007 +0000

    Let prom_claim_chunk do the work for tftp images to support larger images.
    
    Patch from: Leonardo Rangel <lrangel@linux.vnet.ibm.com>
==============

Please review.
Comment 6 Paul Nasrat 2008-10-29 13:21:27 EDT
Hmm, what version of OF are both you and Roman using?

Also in linux can you see what load-base is set to using nvram

nvram load-base
Comment 7 Alex Kanavin 2008-10-29 13:46:50 EDT
Apple PowerBook6,8 4.9.0f0 BootROM built on 01/10/05 at 10:39:14

load-base=0x800000
Comment 8 Alex Kanavin 2008-10-29 13:51:41 EDT
oh, and
[ak@localhost yaboot]$ cat /proc/device-tree/openprom/model 
OpenFirmware 3

if that helps.
Comment 9 Roman Rakus 2008-10-30 06:56:21 EDT
Apple PowerBook6,7 4.9.3f0 BootROM built on 07/05/05 at 11:14:11

load-base=0x800000

OpenFirmware 3
Comment 10 Roman Rakus 2008-11-03 10:36:30 EST
yaboot1-1.3.14-5.fc10.ppc
kernel-2.6.27-0.352.rc7.git1.fc10.ppc
works well.
No I try to update kernel...
Comment 11 Roman Rakus 2008-11-03 10:45:17 EST
updated kernel -> oops and kernel panic
Comment 12 Alex Kanavin 2008-11-03 11:08:18 EST
Yeah, I too noticed that panics behaviour depends on the kernel version - with somewhat older kernels the panic can happen much later in the boot process, or it might make it through to graphical anaconda, and hang there (in F10 snapshot 2). 

Roman, can you get the latest

http://download.fedora.redhat.com/pub/fedora/linux/development/ppc/os/images/boot.iso

and try booting it?
Comment 13 Roman Rakus 2008-11-04 05:37:19 EST
oops and hang.
F10-alpha was similar, F10-beta boots and install well and this one is worse then alpha.
Comment 14 Roman Rakus 2008-11-04 05:48:11 EST
And if I try to restart I get:
Keyboard interrupt
Vector: 501 (Hardware Interrupt) at [c058dee0]
    pc: c000a230: cpu_idle+0x9c/0xe0
    lr: c000a230: cpu_idle+0x9c/0xe0
    sp: c058df90
   msr: 209032
  current = 0xc055d580
    pid   = 0, comm = swapper
enter ? for help
[c058df90] c000a1ec cpu_idle+0x58/0xe0 (unreliable)
[c058dfb0] c03c5644 __got2_end+0x58/0x68
[c058dfc0] c0513798 start_kernel+0x2cc/0x2e0
[c058dff0] 0000380c
mon>
Comment 15 Alex Kanavin 2008-11-04 08:40:03 EST
I think F10-Alpha and Beta used yaboot 1.3.13, so the problems in Alpha are unrelated.

Roman, can you try the patch from comment 5? If you confirm that it fixes the problem as well, then it's probably best to release F10 with it, and resolve the problem later. Fedora release that doesn't boot on a major class of machines is no good.
Comment 16 Roman Rakus 2008-11-04 08:47:06 EST
OK I can try it, but what is better? Release with kernel bug and workaround in yaboot or fixed kernel? Yes, this can be kernel bug as well as yaboot. I'm working on it. But OK, now I will try your patch now.
Comment 17 W. Michael Petullo 2008-11-04 16:39:25 EST
*** Bug 469502 has been marked as a duplicate of this bug. ***
Comment 18 Paul Nasrat 2008-11-05 00:41:02 EST
Revert the change in yaboot by patching it out in the rpm, it'll be reverted upstream too.

Thanks for the leg work in tracking this down Alex.
Comment 19 Roman Rakus 2008-11-05 08:12:41 EST
yaboot-1.3.14-6.fc10 build, but with tag dist-f10-updates-candidate and I'm not sure, if this is the right tag.
Comment 20 Alex Kanavin 2008-11-06 10:45:56 EST
Updated yaboot package showed up in rawhide and the latest boot.iso works fine as well.
Comment 21 Jesse Keating 2008-11-06 13:51:53 EST
Tested here too, worksforme.
Comment 22 Chris Lumens 2008-11-06 14:45:45 EST
*** Bug 470141 has been marked as a duplicate of this bug. ***
Comment 23 Will Woods 2008-11-12 17:07:46 EST
*** Bug 470322 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.