Bug 470336 - user.setDefaultSystemGroup only accepts groups that the user is subscribed to
user.setDefaultSystemGroup only accepts groups that the user is subscribed to
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
John Matthews
:
: 465094 (view as bug list)
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2008-11-06 14:26 EST by Justin Sherrill
Modified: 2009-09-10 15:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:54:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-11-06 14:26:22 EST
In the two api calls user.setDefaultSystemGroup(s) if you pass in a system group to be the default and include a group that the target user is not an admin of, you get an error saying "Unable to locate or access server group".  

As soon as you set that user to be the admin of the group then the error goes away.

This behaviour is different from the WebUI which allows you to select groups to be the default for a user regardless of if that user is an admin of the group or not.


This is tested in the api automated unit tests.
Comment 1 Justin Sherrill 2008-11-06 15:00:32 EST
Also the case with removeDefaultSystemGroup(s)
Comment 2 Justin Sherrill 2008-11-06 15:16:54 EST
fixed in  b3f2cb7..2f70890
Comment 3 John Matthews 2009-01-23 15:42:48 EST
Looking at commit:
http://git.fedorahosted.org/git/?p=spacewalk.git;a=commit;h=2f70890dca848899a6b5055a22df67a71082d72a

I'm assuming the API calls are 
user.addDefaultSystemGroup(s)  and not "setDefaultSystemGroup(s)".



Verified against: Satellite-5.3.0-RHEL5-re20081223.1-i386-embedded-oracle.iso
Comment 4 Brad Buckingham 2009-02-17 11:58:54 EST
*** Bug 465094 has been marked as a duplicate of this bug. ***
Comment 5 Brandon Perkins 2009-09-10 15:54:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.