Bug 470364 - invalid netmask for static ip
invalid netmask for static ip
Status: CLOSED DUPLICATE of bug 470068
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 16:20 EST by Glenn Simpson
Modified: 2008-11-07 01:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 01:49:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glenn Simpson 2008-11-06 16:20:43 EST
Description of problem:
When setting a static ip using edit of the 'network' menu, you set an ip address, a netmask and a default ip address.  When this is saved in /etc/sysconfig/ifcfg-eth1, the netmask is wrongly set to value of the default gateway.

Version-Release number of selected component (if applicable):


How reproducible:
using 'root' System->administration->network to edit the network device.

Steps to Reproduce:
1. select system->administration->network
2. highlight which device. In my case it is eth1
3. press edit
4. change from dynamic addressing to static addressing
5. set the ip address (ex: 192.168.5.27)
6. set the netmask (255.255.255.0)
7. set the default gateway address (ex: 192.168.5.1)
8. save the configuration

Actual results:
if you reopen the above display, you will see the netmask has been changed
to the value of 'default gateway address'
if you check /etc/sysconfig/ifcfg-eth1, you will see the netmask has been
altered to the value reported in the gui display.

Expected results:
setting the netmask should cause the config to accept the value supplied.
ex: 255.255.255.0

Additional info:
Comment 1 Harald Hoyer 2008-11-07 01:49:59 EST

*** This bug has been marked as a duplicate of bug 470068 ***

Note You need to log in before you can comment on or make changes to this bug.