Bug 470068 - system-config_network screws up netmask
system-config_network screws up netmask
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 470364 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 11:08 EST by Alan M. Evans
Modified: 2008-11-07 01:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 13:35:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan M. Evans 2008-11-05 11:08:16 EST
Description of problem:

Using system-config-network to adjust static IP settings for eth0. If I change the settings for "Address", "Subnet mask", or "Default gateway address", the netmask is set equal to the gateway.

Version-Release number of selected component (if applicable):

system-config-network 1.5.93

Steps to Reproduce:
1. start system_config_network
2. select eth0 (probably others also) connection and click "Edit" button
3. on "Ethernet Device" dialog, select "Statically set IP addresses" and enter appropriate values for "Address", "Subnet mask", and "Default gateway address".
4. click "Ok" to accept changes.
  
Actual results:

/etc/sysconfig/network-scripts/ifcfg-eth0 contains "NETMASK=192.168.0.3", which is my default gateway.

Expected results:

/etc/sysconfig/network-scripts/ifcfg-eth0 contains "NETMASK=255.255.255.0", which is what I entered in the appropriate box.
Comment 1 Jiri Moskovcak 2008-11-05 13:35:56 EST

*** This bug has been marked as a duplicate of bug 469434 ***
Comment 2 Harald Hoyer 2008-11-07 01:49:59 EST
*** Bug 470364 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.