Bug 470386 - virt-manager uses virtio disks where they won't necessarily work
virt-manager uses virtio disks where they won't necessarily work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 17:41 EST by Bill Nottingham
Modified: 2014-03-16 23:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 10:26:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-11-06 17:41:15 EST
Description of problem:

virt-manager seems to default to using virtio disks.

Unfortunately, if you're installing Fedora 9 GA (or earlier), /dev/vd* aren't properly labelled by policy, so you can't mount them outside of the initrd unless you:

1) turn off SELinux
2) update to the policy from updates

Version-Release number of selected component (if applicable):

virt-manager-0.6.0-3.fc10.x86_64
Comment 1 Bug Zapper 2008-11-25 23:55:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Cole Robinson 2008-12-06 23:10:23 EST
Fix now upstream:

http://hg.et.redhat.com/virt/applications/virtinst--devel?cs=82957a280825

Moving to POST.
Comment 3 Mark McLoughlin 2009-01-06 13:32:50 EST
Okay, I've done some testing and there are a couple of issues with F9 virtio support:

  1) Once you've installed to /dev/vda and rebooted, /boot fails to mount
     with this:

       Mounting local filesystems:  mount: special device UUID=fc08d54b-47e3-4ff1-8000-d49766b38a41 does not exist [FAILED]

     So, e.g. if you then do a yum update the kernel doesn't get installed
     in the /boot partition

     This is because the selinux-policy fix for labelling /dev/vd* just
     missed GA. See bug #444468

  2) With very recent KVM (i.e. kvm-80 or later) and with GSO support enabled
     on a virtio NIC (which libvirt currently doesn't do), then the F9 guest
     will say that it supports the "mergeable receive buffers" feature when,
     in fact, it doesn't support it; the guest then crashes when it tries
     to use the NIC

so, yeah - better not to use virtio when installing F-9 - it *almost* works, so if you know what you're doing it's fine to just tell virt-install that you're installing F-10 and fixup problems manually post-install
Comment 4 Cole Robinson 2009-03-04 12:02:43 EST
virtinst-0.400.2 is queued up for updates-testing.
Comment 5 Mark McLoughlin 2009-05-13 08:20:32 EDT
(In reply to comment #3)

>   2) With very recent KVM (i.e. kvm-80 or later) and with GSO support enabled
>      on a virtio NIC (which libvirt currently doesn't do), then the F9 guest
>      will say that it supports the "mergeable receive buffers" feature when,
>      in fact, it doesn't support it; the guest then crashes when it tries
>      to use the NIC

On a side note, latest qemu can handle guests with this bug because of this patch:

  http://lists.gnu.org/archive/html/qemu-devel/2009-04/msg00190.html

qemu-kvm-0.10.4-2.fc11 in F11 has workaround
Comment 6 Cole Robinson 2009-10-05 10:26:31 EDT
This is in virtinst-0.400.3 which is in F-10 stable. Closing.

Note You need to log in before you can comment on or make changes to this bug.