Bug 470445 - Dual-monitor via sisusb fails to initialize on OLPC XO hardware
Dual-monitor via sisusb fails to initialize on OLPC XO hardware
Status: CLOSED DUPLICATE of bug 510059
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-sisusb (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
Reported: 2008-11-07 03:33 EST by Terry Stewart
Modified: 2009-07-12 09:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-12 09:12:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg.conf attempting to use both screens (1.41 KB, text/plain)
2008-11-07 03:34 EST, Terry Stewart
no flags Details
log file produced with failed initialization (24.89 KB, text/plain)
2008-11-07 03:50 EST, Terry Stewart
no flags Details

  None (edit)
Description Terry Stewart 2008-11-07 03:33:21 EST
Description of problem:

If a USB VGA adapter is used, the XO laptop can drive an external monitor.  This can be done by modifying xorg.conf and works fine if only the external monitor is used.  However, if xorg.conf is set up to drive both the external monitor and the built-in Geode-based internal LCD display, X fails to start.  Instead, it repeatedly tries to initialize the graphics mode on both screens, then falls back to text mode, and repeats the process.  This cycle can be interrupted by unplugging the USB VGA adapter.

This testing was done with a UVA200 sisusb adapter: <http://www.futureshop.ca/catalog/proddetail.asp?logon=&langid=EN&sku_id=0665000FS10091172&catid=256>

How reproducible:


Steps to Reproduce:
1. Replace xorg.conf with the attached file
2. Plug in the USB VGA adaptor
3. Reset X (Ctrl-Alt-Backspace)
Actual results:

Both screens repeatedly flicker as if they are switching graphics modes.

Expected results:

X should start using both screens.

Additional info:

The attached xorg.conf works fine if either of the Screen settings in the ServerLayout are removed.
Comment 1 Terry Stewart 2008-11-07 03:34:50 EST
Created attachment 322822 [details]
xorg.conf attempting to use both screens
Comment 2 Terry Stewart 2008-11-07 03:50:57 EST
Created attachment 322825 [details]
log file produced with failed initialization
Comment 3 Matěj Cepl 2008-11-07 13:16:40 EST
Are you able to do some magic with xrandr(1) or gnome-display-properties? If yes, then if you read http://udrepper.livejournal.com/20187.html can you make it work following his steps?
Comment 4 Terry Stewart 2008-11-07 18:04:23 EST
I'm not quite sure how to adapt the steps given at http://udrepper.livejournal.com/20187.html to this situation, since there are two separate Devices being used (the AMD Geode and the sisusb).  However, I wasn't very familiar with xrandr (I'd previously used Xinerama for this sort of thing), so I did some digging around and found this page http://wiki.debian.org/XStrikeForce/HowToRandR12 which notes that:

"RandR 1.2 does not support multiple boards yet (it's planned for RandR 1.3). It means that any RandR 1.2 aware driver will crash the server if you have 2 boards. Even one board with a RandR 1.2 driver and another board with a classic driver does not work. It just crashes the X server."

That sounds like exactly what I am seeing here, so there may not be a fix for this....
Comment 5 Matěj Cepl 2008-11-19 05:35:48 EST
Adam, is this correct? Is there any hope for this bug or is this WONTFIX (anytime soon, that is)?
Comment 6 Bug Zapper 2008-11-25 23:56:56 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 7 Peter Robinson 2009-07-12 09:12:46 EDT
This is the same as bug 510059 which is part of Fedora 'fit and finish'

*** This bug has been marked as a duplicate of bug 510059 ***

Note You need to log in before you can comment on or make changes to this bug.