Bug 470449 - (Tylersburg-Sound) system-config-soundcard is not working on RHEL5.3 GA-snapshot1
system-config-soundcard is not working on RHEL5.3 GA-snapshot1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
i386 Linux
medium Severity high
: rc
: ---
Assigned To: Jaroslav Kysela
Martin Jenner
: Regression
Depends On:
Blocks: 432380
  Show dependency treegraph
 
Reported: 2008-11-07 04:00 EST by Rainer Koenig
Modified: 2009-01-30 11:44 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 483268 (view as bug list)
Environment:
Last Closed: 2009-01-20 15:14:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sysreport from RHEL5.2 (1.49 MB, application/octet-stream)
2008-11-07 04:00 EST, Rainer Koenig
no flags Details
Sysreport from RHEL5.3 GA-snapshot1 (1.65 MB, application/octet-stream)
2008-11-07 04:01 EST, Rainer Koenig
no flags Details
logfile from system-config-soundcard (92.32 KB, text/plain)
2008-11-07 08:31 EST, Rainer Koenig
no flags Details
output of alsa-info.sh (14.43 KB, text/plain)
2008-12-01 09:00 EST, Rainer Koenig
no flags Details
Todays log messages. (54.39 KB, text/plain)
2008-12-02 07:06 EST, Rainer Koenig
no flags Details

  None (edit)
Description Rainer Koenig 2008-11-07 04:00:37 EST
Created attachment 322827 [details]
Sysreport from RHEL5.2

Description of problem:
system-config-soundcard is not detecting any soundcard in RHEL5.3-GAsnapshot1. 

Version-Release number of selected component (if applicable):
2.0.6-1.el5 as it comes with RHEL5.3 GA-snapshot1

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL5.3 GA-snapshot1 
2. Firstboot doesn't configure soundcard
3. call system-config-soundcard from a command shell
  
Actual results:
When calling system-config-soundcard no dialog appears and the utility exits without any message.

Expected results:
Dialog to config soundcard and soundcard working.

Additional info:
A. system-config-soundcard on RHEL5.2 with exactly the same hardware works. I can select "HDA intel" and I can hear the sample sound.

B. Installing RHEL5.3 partner beta from 2008-10-20 makes at least the system-config-soundcard dialog appear with optens to switch between an "ALC663 (analog)" and "ALC663 (digital)" codec, but playback of the sound sample works with neither option.

C. Installing REHL5.3 GA-snapshot1 makes system-config-soundcard not working at all. 

D: So far I just tested the i386 branch. Can do x86_64 too if necessary.

E: I will attach sysreport files from RHEL5.2 and RHEL5.3 GA-snapshot 1 that might be helpful to analyze this bug.

F: Affected Hardware: FSC CELSIUS R670 workstation (prototype) with Tylersburg Chipset and in this case ICH10 and ALC663 codec.
Comment 1 Rainer Koenig 2008-11-07 04:01:58 EST
Created attachment 322828 [details]
Sysreport from RHEL5.3 GA-snapshot1
Comment 2 Martin Stransky 2008-11-07 04:11:15 EST
Hm, I don't understand how is that possible...we haven't updated that package in rhel-5.

Please run "python /usr/share/system-config-soundcard/system-config-soundcard.py" on console as root and attach output here. Thanks.
Comment 3 Rainer Koenig 2008-11-07 04:31:56 EST
Martin,

I'm not yet sure, if system-config-soundcard is broken or if there was a patch in the ALSA modules that render the sound unusable. Looking at the python output:

-------------------------8<-snip-----------------------------------
[root@r670 ~]# python /usr/share/system-config-soundcard/system-config-soundcard.py
Introspect error: The name org.freedesktop.Hal was not provided by any .service files
Traceback (most recent call last):
  File "/usr/share/system-config-soundcard/system-config-soundcard.py", line 46, in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 95, in __init__
    self.soundcardBackend = soundcardBackend.soundcardBackend()
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 397, in __init__
    self.detectCards()
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 411, in detectCards
    self.cardArray = self.mergeCards(self.probeCards(DETECTION_HAL),\
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 444, in probeCards
    default_device, card_list, card_max)
  File "/usr/share/system-config-soundcard/soundcardBackendHal.py", line 163, in probeCards
    udiList = self.halManager.FindDeviceByCapability("alsa")
  File "/usr/lib/python2.4/site-packages/dbus/proxies.py", line 25, in __call__
    ret = self._proxy_method (*args, **keywords)
  File "/usr/lib/python2.4/site-packages/dbus/proxies.py", line 102, in __call__
    reply_message = self._connection.send_with_reply_and_block(message, timeout)
  File "dbus_bindings.pyx", line 455, in dbus_bindings.Connection.send_with_reply_and_block
dbus_bindings.DBusException: The name org.freedesktop.Hal was not provided by any .service files
-------------------------8<-snip-----------------------------------

Hope this helps.

Thanks
Rainer
Comment 4 Martin Stransky 2008-11-07 08:04:25 EST
Is the service "haldaemon" running and configured properly?
Comment 5 Rainer Koenig 2008-11-07 08:30:14 EST
Hi Martin,

yes, it was running. But I experienced a very strange behaviour: 

After executing hald again from a root shell I was able to run system-config-soundcard. But even then the sound is not working.

The strange thing is: Rebooting the machine again and having the same entries for "hal" in the process list as before makes system-config-sound start, but still with no sound. So the experience is:

1. Install DVD and pass though firstboot.
2. Login as root and start system-config-soundcard doesn't work
3. Reboot, login and start system-config-soundcard works this time.

Anyway, even having the complete GUI doesn't make the sound work. :-( 

I tried to see the mixter settings with alsamixer and got the following line:

alsamixer: function snd_mixer_load failed: Invalid argument

I will attaach scsconfig.log to this bug.

Regards
Rainer
Comment 6 Rainer Koenig 2008-11-07 08:31:29 EST
Created attachment 322855 [details]
logfile from system-config-soundcard

Generated on RHEL5.3 GA snapshot 1
Comment 7 Larry Troan 2008-11-07 15:52:53 EST
Per the above comment....
> A. system-config-soundcard on RHEL5.2 with exactly the same hardware works. I
> can select "HDA intel" and I can hear the sample sound.
this appears to be a regression from 5.2.
Comment 8 RHEL Product and Program Management 2008-11-07 15:55:30 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 Martin Stransky 2008-11-10 03:27:09 EST
It's a problem in hal daemon...

[komat@localhost hardware]$ cat lshal 
error: libhal_ctx_init: (null): (null)
Could not initialise connection to hald. 
 Normally this mean the HAL daemon (hald) is not running or not ready.
lshal.c 689 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was not set.
Comment 10 Richard Hughes 2008-11-11 05:55:49 EST
Martin, is hal running? If not, please can you get the output of:

/usr/sbin/hald --verbose=yes --daemon=no

Thanks.
Comment 11 Martin Stransky 2008-11-11 09:33:15 EST
I suppose you want to ask reporter for it...
Comment 12 Rainer Koenig 2008-11-25 08:42:02 EST
Here are some more findings:

When I try to open alsamixer on the konsole I get the following messages:

[root@r670 ~]# alsamixer
hda_codec: num_steps = 0 for NID=0x5 (ctl = Speaker Playback Volume)

alsamixer: function snd_mixer_load failed: Invalid argument

The first line with hda_codec is a kernel log message. So I wonder if there is an issue with ALSA in this case.
Comment 14 Jaroslav Kysela 2008-12-01 08:05:34 EST
Please, attach output from 'alsa-info.sh --no-upload' (script can be downloaded at http://www.alsa-project.org/alsa-info.sh).
Comment 15 Rainer Koenig 2008-12-01 09:00:40 EST
Created attachment 325234 [details]
output of alsa-info.sh
Comment 18 Rainer Koenig 2008-12-02 00:45:04 EST
Needinfo? What Info is still needed? 

Regards
Rainer (confused)
Comment 19 Issue Tracker 2008-12-02 04:13:21 EST
Hi Rainer


I believe the engineer wants to know if this exact same problem is still
occurring with the latest released betas, ie, snapshot #3 and snapshot
#4?


Regards, Gary


This event sent from IssueTracker by gasmith 
 issue 237751
Comment 20 Jaroslav Kysela 2008-12-02 04:20:56 EST
Could you try to add 'options snd-hda-intel index=0 model=fujitsu' to /etc/modprobe.conf and reboot? Check alsamixer again. Please, also attach all sound related messages from log - /var/log/messages.
Comment 21 Rainer Koenig 2008-12-02 07:05:38 EST
Ok, tried that out. Adding the option to modprobe.conf doesn't help, still no sound to hear. 
I' will attach a file messages with all the messages from today.

Invoking alsamixer still complains about the Speaker Playback Volume steps in the log and alsamixer exits with "invalid agrument".

If I compile the latest ALSA drivers (1.0.18a) from the ALSA site then sound works fine. But not with the drivers that RHEL 5.3 is providing, actually I'm on GA snapshot 4 and the problem is still there.
Comment 22 Rainer Koenig 2008-12-02 07:06:45 EST
Created attachment 325362 [details]
Todays log messages. 

See the last lines for the messsage that is logged when I start "alsamixer" or even "system-config-soundcard".
Comment 23 Jaroslav Kysela 2008-12-02 09:27:26 EST
Please, attach output from alsa-info.sh also for 1.0.18a driver with kernel log messages..
Comment 26 Jaroslav Kysela 2008-12-03 04:19:17 EST
Also, please test with models: 3stack-dig , 3stack-6ch-dig, 3stack-6ch, 6stack-dig . See comment#20 for details. Attach relevant log from dmesg or /var/log/messages.
Comment 27 Rainer Koenig 2008-12-03 07:10:06 EST
Hello Jaroslav,

bingo!!! setting model=3stack-dig makes the thing work. No errors when starting alsamixer and system-config-sound is able to playback the sound as expected.

Thanks a lot for this.

Regards
Rainer
Comment 28 Jaroslav Kysela 2008-12-03 10:01:31 EST
I posted a patch for auto model selection for this platform to rh-kernel mailing list.
Comment 30 Don Zickus 2008-12-09 16:04:47 EST
in kernel-2.6.18-126.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 32 Rainer Koenig 2008-12-17 07:15:14 EST
Don,

I tested now with RHEL 5.3 GA snapshot 6. The gap between this bits and the ALSA 1.0.18a driver is that with the RHEL bits only the backpanel output works, not the phones jack on the frontpanel. With the ALSA driver both outputs work.

Regards
Rainer
Comment 33 Matthias Strelow 2008-12-19 08:57:44 EST
It's not only the front jack that's not working but also the builtin speaker.
Regards
 Matthias
Comment 35 Rainer Koenig 2009-01-13 07:38:22 EST
Just for the records: All sound outputs work fine with Fedora 10. Fedora 10 says it has ALSA driver version 1.0.17.

Regards
Rainer
Comment 36 errata-xmlrpc 2009-01-20 15:14:06 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2009-0225.html

Note You need to log in before you can comment on or make changes to this bug.