Bug 470476 - incorrect NETMASK save in network-scripts/ifcfg-ethX
incorrect NETMASK save in network-scripts/ifcfg-ethX
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 06:32 EST by Dean Mander
Modified: 2008-11-07 07:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 07:23:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Mander 2008-11-07 06:32:20 EST
Description of problem:

system-config-network saves gateway value instead of netmask value in NETMASK=
/etc/sysconfig/network-scripts/ifcfg-ethX
when using static IP.

Version-Release number of selected component (if applicable):
system-config-network-tui-1.5.93-2.fc10.noarch

How reproducible:

run system-config-network and set static IP address for eth0, for example:

IP: 10.0.0.2
NETMASK: 255.255.255.0
GATEWAY: 10.0.0.1

then the tool will write in /etc/sysconfig/network-scripts/ifcfg-eth0:

NETMASK=10.0.0.1  <----
IPADDR=10.0.0.2
NM_CONTROLLED=no
GATEWAY=10.0.0.1
TYPE=Ethernet

which should be:
NETMASK=255.255.255.0

Result: no default route set --> no network
Comment 1 Harald Hoyer 2008-11-07 07:23:00 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.