Bug 469434 - subnetmask not saved
subnetmask not saved
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 470068 470476 471621 473001 473145 473322 473354 473545 473884 474505 474762 475059 476079 476353 476805 477318 477678 478618 478776 478797 (view as bug list)
Depends On:
Blocks: 475134
  Show dependency treegraph
 
Reported: 2008-10-31 16:19 EDT by Edwin Schepers
Modified: 2009-01-30 06:15 EST (History)
31 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-30 06:15:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edwin Schepers 2008-10-31 16:19:45 EDT
Description of problem:
subnetmask settings are not saved.

Version-Release number of selected component (if applicable):


How reproducible:
When I select static ip address, and I fill adres, subnetmask and gateway and then OK, and then Edit again, I see the gateway address filled in at the subnetmask field.
Comment 2 Edwin Schepers 2008-11-03 13:55:46 EST
the bug seems to be fixed in that version
Comment 3 Jiri Moskovcak 2008-11-05 13:35:56 EST
*** Bug 470068 has been marked as a duplicate of this bug. ***
Comment 4 Alan M. Evans 2008-11-05 16:13:13 EST
(In reply to comment #1)

FWIW, these appear to have fixed the issue for me.
Comment 5 Harald Hoyer 2008-11-07 07:23:00 EST
*** Bug 470476 has been marked as a duplicate of this bug. ***
Comment 6 Bug Zapper 2008-11-25 23:35:19 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Stephen Smalley 2008-11-26 11:09:51 EST
This is still broken in Fedora 10 final release.
I had to manually edit the config file to get a sane subnet and broadcast mask.
Comment 8 Didier G 2008-11-27 03:40:31 EST
I confirm same problem here with Fedora 10 final release.
Comment 9 Jiri Moskovcak 2008-11-27 07:45:21 EST
*** Bug 473001 has been marked as a duplicate of this bug. ***
Comment 10 Lorenzo 2008-11-27 08:37:38 EST
Just the same in my F10 final release.

I edit manually config files and when I use again s-c-n the save process record
gateway data insteed in netmask data field "NETMASK=192.168.1.254" insteed of
wanted "NETMASK=255.255.255.0".

Invocation of scripts to dow and up the network let the net work with a wrong
broadcast (a.b.c.13 insteed of a.b.c.255).

I feel sad, I was OS-programmer for long years and my feeling is that we are
stepping back about check/quality before releases.
Comment 11 Jiri Moskovcak 2008-11-27 09:28:10 EST
I'm about to push the updated package to repository.
Comment 12 Fedora Update System 2008-11-27 11:36:15 EST
system-config-network-1.5.94-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/system-config-network-1.5.94-2.fc10
Comment 13 Jiri Moskovcak 2008-11-28 04:09:20 EST
*** Bug 473354 has been marked as a duplicate of this bug. ***
Comment 14 Jiri Moskovcak 2008-11-28 06:40:46 EST
*** Bug 473322 has been marked as a duplicate of this bug. ***
Comment 15 Jiri Moskovcak 2008-11-28 06:42:03 EST
*** Bug 473145 has been marked as a duplicate of this bug. ***
Comment 16 Jiri Moskovcak 2008-11-28 06:43:20 EST
*** Bug 471621 has been marked as a duplicate of this bug. ***
Comment 17 Christophe Lambin 2008-11-29 04:59:10 EST
*** Bug 473545 has been marked as a duplicate of this bug. ***
Comment 18 Jiri Moskovcak 2008-12-01 05:44:18 EST
*** Bug 473884 has been marked as a duplicate of this bug. ***
Comment 19 Roger L. Olson 2008-12-02 18:18:29 EST
I had the same issue with the netmask entry being overwritten with the gateway ip upon saving ifcfg-eth0 via s-c-n gui setup necessitating a manual edit of the config file to achieve internet connection.  Updating the older s-c-n with the newly submitted package s-c-n-1.5.94-2.fc10 referenced in comment #12 above resolved the issue for me on my Centrino based Toshiba Satellite :).  Thanks.
Comment 20 Fedora Update System 2008-12-02 20:25:07 EST
system-config-network-1.5.94-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10641
Comment 21 Jiri Moskovcak 2008-12-04 06:29:52 EST
*** Bug 474505 has been marked as a duplicate of this bug. ***
Comment 22 Trevin Beattie 2008-12-04 17:03:31 EST
1.5.94-2.fc10 fixes the problem on my box.
Comment 23 Scott Dowdle 2008-12-07 13:54:06 EST
I updated to the testing package (system-config-network-1.5.94-2.fc10) and it fixed the issue with unsaved netmask data... but I still have a related problem that I believe should be reported against this package.  Please tell me if I'm wrong.

I use system-config-network (and the network service rather than the NetworkManager service) on a desktop computer.  On a laptop I prefer NetworkManager but network manager can't edit the wired interface (eth0) even though I have put checkmarks by:

[x] Controlled by NetworkManager
and
[x[ Allow all users to enable and disable the device

I restarted NetworkManager after making those changes but I still can't edit the settings for the wired interface.

Is this a bug in system-config-network or in NetworkManager?
Comment 24 Scott Dowdle 2008-12-07 13:55:32 EST
*** Bug 475059 has been marked as a duplicate of this bug. ***
Comment 25 Jiri Moskovcak 2008-12-11 17:38:11 EST
*** Bug 476079 has been marked as a duplicate of this bug. ***
Comment 26 Jiri Moskovcak 2008-12-13 13:32:59 EST
*** Bug 476353 has been marked as a duplicate of this bug. ***
Comment 27 Ray Todd Stevens 2008-12-14 21:25:43 EST
I have been getting this bug.   It appears that the problem is that when you enter a router value the router value then replaces the net mask.   I would suspect there is something in the field names in this data entry screen.
Comment 28 Jiri Moskovcak 2008-12-15 05:40:40 EST
*** Bug 474762 has been marked as a duplicate of this bug. ***
Comment 29 Jiri Moskovcak 2008-12-17 07:58:52 EST
*** Bug 476805 has been marked as a duplicate of this bug. ***
Comment 30 Jiri Moskovcak 2008-12-22 06:26:02 EST
*** Bug 477318 has been marked as a duplicate of this bug. ***
Comment 31 Jiri Moskovcak 2008-12-24 05:55:11 EST
*** Bug 477678 has been marked as a duplicate of this bug. ***
Comment 32 Ray Todd Stevens 2008-12-27 16:40:46 EST
Looks like this is getting to be a really "popular" bug.  Every couple of days we have someone else report it.
Comment 33 Ray Todd Stevens 2008-12-27 16:52:22 EST
Interesting.   A little research says that this is actually fixed by system-config-network-1.5.95-1.fc10.   It seems by the web site that this should be the current release in the updates directory, but my fully updated system has 1.5.93 as the most up-to-date version.   Do I have something not working right?
Comment 34 Ray Todd Stevens 2008-12-28 14:43:30 EST
OK I found out how to run the version of network-system-config from the test repo.   Version 95 as it were.

This works as far as this problem is concerned.  I have a pretty complex set of static ips with multiple cards each with multiple ips.   Everything worked great.

Don't know if this breaks anything else.  It certainly doesn't seem to.   But this probably needs to be a pretty high priority to get out as an actual released update.
Comment 35 Daniel Morante 2009-01-02 14:12:05 EST
I also see this happening on a freshly installed Fedora 10 system with the latest updates.

I have version
1.5.93-2.fc10
Comment 36 Ray Todd Stevens 2009-01-02 18:58:37 EST
The problem is that this is fixed in 1.5.94 which was superseded by 1.5.95 before it was released, and we are still waiting on this ones release.   Given the nature of this problem someone should work really hard on getting this one released.

In the mean time if you run yum --enablerepo=updates-testing update network-system-config   You should be able to download the corrected version and get right to work.
Comment 37 Jiri Moskovcak 2009-01-05 04:11:32 EST
*** Bug 478776 has been marked as a duplicate of this bug. ***
Comment 38 Jiri Moskovcak 2009-01-05 04:11:56 EST
*** Bug 478797 has been marked as a duplicate of this bug. ***
Comment 39 Jiri Moskovcak 2009-01-05 04:23:34 EST
*** Bug 478618 has been marked as a duplicate of this bug. ***
Comment 40 Ray Todd Stevens 2009-01-22 15:02:58 EST
It looks like the fix has been released to stable on this one.   Is it not time to close this one?
Comment 41 Sami Siren 2009-01-23 02:28:17 EST
Works for me now on FC10 (1.5.95-1). Thanks.
Comment 42 David Tonhofer 2009-01-23 02:33:09 EST
This needs to be in the Live CD and DVD distros. Is it? (Just my 2c)

Note You need to log in before you can comment on or make changes to this bug.