Bug 470541 - F10 Preview release hard hangs once UI starts up
F10 Preview release hard hangs once UI starts up
Status: CLOSED DUPLICATE of bug 461205
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 11:16 EST by Glen Gray
Modified: 2018-04-11 04:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 11:49:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file for F10 Preview X lockup on Intel 865G (62.62 KB, text/plain)
2008-11-10 10:47 EST, Glen Gray
no flags Details
dmesg output (29.52 KB, text/plain)
2008-11-10 10:49 EST, Glen Gray
no flags Details

  None (edit)
Description Glen Gray 2008-11-07 11:16:42 EST
Description of problem:Booting into GUI on F10 Hangs, booting to runlevel 3 ok, X on it's own ok, GDM or startx from runlevel 3 shows the Desktop but freezes


Version-Release number of selected component (if applicable):F10 Preview release


How reproducible:Every time


Steps to Reproduce:
1.Using the livecd-iso-to-disk tools on an upto date F9 install I copied the F10Preview Live (Gnome) iso to a USB key. 
2.Boot with default settings from USB key on the hardware
3.Hang
  
Actual results:System appears to have started as expected, mouse cursor movies but system is unresponsive. Caps/Scroll lock LEDs fail to activate and unable to switch VT's 


Expected results:Normal boot into live desktop


Additional info:System in question is an Intel P4 HT enabled at 3.0Ghz with 1.5Gb RAM and Intel 82865G graphics chip.
Booting into runlevel 3 and logging in as root gives an active console and the system can be used
From runlevel 3 you can launch the x server by running 'X'. This loads the Xserver without issues, ctrl+alt+backspace kills it as expected.
Running startx from runlevel 3 gives you the following sequence
X pattern background
Then the cursor appears
Then a warning dialog about the update applet running as a privileged user. 
 Then nautilus appears to start, i.e. the background image gets loaded and I see the desktop icons for Computer, root's home and Trash (the fonts appear to be clipped slightly). Nothing else loads after that point and the system becomes unusable though the mouse cursor still moves. Only way out is to reboot

Simialr when booting with default options. X loads, you seed the login dialog appear with the automatic login user but the fonts appear clipped and there's occasionally graphical issues in the gdm panel at the bottom of the screen (not every time)

If I act fast enough, I can click the Login button which allows the desktop session to partially load. Similar results though, I see the background image load and the nautilus desktop icons. On the attempt I've just made, the gnome-panel applets appear to have partially animated onto the top and bottom of the screen, about half of them is still off screen. Although the mouse moves, I can see that the animated cursor is frozen mid animation (the spiral that goes around the arrow is still there and not changing)
Comment 1 Matthias Clasen 2008-11-07 11:40:14 EST
> Caps/Scroll lock LEDs fail to activate and unable
> to switch VT's 

This usually indicates some problem between X and the kernel.

Moving to X for now
Comment 2 Will Woods 2008-11-07 11:41:46 EST
This might be the same problem as bug 461205 - black screens on i855GM. 

Could you please attach /var/log/Xorg.0.log or log.old - preferably one that
shows the crash/backtrace happening? Also, check the output of 'dmesg' for
errors relating to intel/i915.
Comment 3 Glen Gray 2008-11-07 13:01:00 EST
I can provide the details pre-crash if that's any use.
Any suggestions on how to get such data when the machine is hung ?
The test machine in question is in my office so it'll be Monday morning (GMT) before I can get that data.
Comment 4 Matěj Cepl 2008-11-07 19:34:00 EST
(In reply to comment #3)
> I can provide the details pre-crash if that's any use.
> Any suggestions on how to get such data when the machine is hung ?

OK, from your description, I guess, the only hope is to ssh to your computer from somewhere else and then copy the files from down there. Is it possible?
Comment 5 John Cox 2008-11-08 10:59:06 EST
I'm having the same problem. Locks up with the swirling cursor frozen.
My mouse cursor moves with very long delays so seems it is not frozen, just occupied.
For me this stared happening after updates to a Release install. Sorry but I don't know which one.

THis is with my ATI video Desktop. My Intel laptop is not having any problems.
This morning when I tried, I was able to open a VT to YUM update. If I can do that again, I will investigate further.
Comment 6 Glen Gray 2008-11-10 10:47:37 EST
Created attachment 323084 [details]
Xorg log file for F10 Preview X lockup on Intel 865G
Comment 7 Glen Gray 2008-11-10 10:49:50 EST
Created attachment 323085 [details]
dmesg output
Comment 8 Glen Gray 2008-11-10 10:58:14 EST
Ok, I've attached the Xorg.0.log and the output from dmesg. I boot the key to run level 3, stopped the firewall and started sshd, logged in tailed both Xorg.0.log and /var/log/messages. After the crash, the ssh sessions where still active

The only interesting thing I could see was there was some error messages about drm
[drm] Initialized drm 1.1.0 20060810
pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
pci 0000:00:02.0: setting latency timer to 64
[drm:i915_driver_load] *ERROR* failed to enable MSI
[drm] Initialized i915 1.6.0 20080730 on minor 0
fuse init (API version 7.9)
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts

top shows no load on the system

ps auwwx shows the following
root      3121  0.0  0.0   4804  1228 tty1     S+   15:36   0:00 /bin/sh /usr/bin/startx
root      3137  0.0  0.0   3076   800 tty1     S+   15:36   0:00 xinit /etc/X11/xinit/xinitrc -- /usr/bin/X :0 -auth /root/.serverauth.3121
root      3138  0.1  0.4  15956  7620 tty7     S<s+ 15:36   0:02 /usr/bin/X :0 -auth /root/.serverauth.3121
root      3164  0.0  0.0   3960   552 pts/1    S+   15:36   0:00 tail -f /var/log/Xorg.0.log
root      3185  0.0  0.0   2152   648 ?        Ss   15:36   0:00 /usr/bin/ck-xinit-session /usr/bin/ssh-agent /etc/X11/xinit/Xclients
root      3194  0.0  0.0   3156   668 ?        S    15:36   0:00 dbus-launch --sh-syntax --exit-with-session
root      3195  0.0  0.0  13264  1224 ?        Ssl  15:36   0:00 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
root      3238  0.0  0.1   5520  2240 ?        S    15:36   0:00 /usr/libexec/im-settings-daemon
root      3240  0.0  0.1   4776  2624 ?        S    15:36   0:00 /usr/libexec/im-info-daemon
root      3242  0.0  0.1   6464  1980 ?        S    15:36   0:00 /usr/libexec/gvfsd
root      3311  0.0  0.1  35640  2128 ?        Ssl  15:36   0:00 /usr/libexec//gvfs-fuse-daemon /root/.gvfs
root      3369  0.0  0.1   4948  2260 ?        S    15:36   0:00 /usr/libexec/gconf-im-settings-daemon
root      3371  0.0  0.2   8592  4428 ?        S    15:36   0:00 /usr/libexec/gconfd-2
root      3372  0.0  0.0      0     0 ?        Z    15:36   0:00 [xinitrc] <defunct>
root      3382  0.0  0.5  36920  7920 ?        Sl   15:36   0:00 /usr/bin/gnome-session
root      3427  0.0  0.0   6744   616 ?        Ss   15:36   0:00 /usr/bin/ssh-agent /etc/X11/xinit/Xclients
root      3475  0.0  0.2  15404  3360 ?        S    15:36   0:00 /usr/lib/gnome-session/helpers/gnome-keyring-daemon-wrapper
root      3480  0.0  0.6  48668  9868 ?        Ssl  15:36   0:00 /usr/libexec/gnome-settings-daemon
root      3481  0.0  0.1  17816  2000 ?        S    15:36   0:00 /usr/bin/gnome-keyring-daemon
root      3483  0.0  0.6  22952 10436 ?        S    15:36   0:00 metacity
root      3484  0.0  0.7  27452 11584 ?        S    15:36   0:00 gnome-panel
root      3485  0.0  0.0      0     0 ?        Z    15:36   0:00 [xrdb] <defunct>
root      3488  0.0  2.0  85888 31780 ?        S    15:36   0:00 nautilus --no-desktop --browser
root      3490  0.0  0.2  40768  3308 ?        Ssl  15:36   0:00 /usr/libexec/bonobo-activation-server --ac-activate --ior-output-fd=17
root      3495  0.0  0.0      0     0 ?        Z    15:36   0:00 [xrdb] <defunct>
root      3506  0.0  0.1   6964  2620 ?        S    15:36   0:00 /usr/libexec/gvfs-hal-volume-monitor
root      3508  0.0  0.1   6752  2128 ?        S    15:36   0:00 /usr/libexec/gvfs-gphoto2-volume-monitor
root      3510  0.0  0.1  17880  2500 ?        S    15:36   0:00 /usr/libexec/gvfsd-trash --spawner :1.4 /org/gtk/gvfs/exec_spaw/0
root      3518  0.0  0.1   6492  2048 ?        S    15:36   0:00 /usr/libexec/gvfsd-burn --spawner :1.4 /org/gtk/gvfs/exec_spaw/1
root      3519  0.0  0.4  20260  6968 ?        S    15:36   0:00 imsettings-applet --disable-xsettings
root      3520  0.0  0.0   4804  1164 ?        S    15:36   0:00 /bin/sh /usr/bin/start-pulseaudio-x11
root      3521  0.0  0.7  27112 11432 ?        S    15:36   0:00 python /usr/share/system-config-printer/applet.py
root      3524  0.0  0.5  23552  8148 ?        S    15:36   0:00 nm-applet --sm-disable
root      3526  0.0  0.9  38732 15108 ?        S    15:36   0:00 gpk-update-icon
root      3528  0.0  0.3  18724  5884 ?        S    15:36   0:00 kerneloops-applet
root      3536  0.0  0.4  19364  6444 ?        S    15:36   0:00 bluetooth-applet
root      3538  0.0  0.2  28360  4540 ?        Ss   15:36   0:00 gnome-power-manager
root      3541  0.0  0.2  96484  3524 ?        S<sl 15:36   0:00 /usr/bin/pulseaudio --start
root      3545  0.0  0.1   7912  2452 ?        S    15:36   0:00 /usr/libexec/pulse/gconf-helper
root      3546  0.0  0.0   7020  1312 ?        S    15:36   0:00 /usr/bin/pactl load-module module-x11-publish display=:0.0
root      3576  1.0  0.0   4660   964 pts/0    R+   15:57   0:00 ps auwwx


Hope this info helps, if there's anything else I can do please let me know.
Comment 9 Will Woods 2008-11-10 11:49:26 EST
Confirming my suspicions, I see the same error message as in bug 461205:
  [drm:i915_driver_load] *ERROR* failed to enable MSI

i855 and i865 are, broadly, the same class of chip. I'm going to mark this as a duplicate of that bug so we can focus our efforts there.

*** This bug has been marked as a duplicate of bug 461205 ***

Note You need to log in before you can comment on or make changes to this bug.