Bug 470559 - F10 anaconda failed to start vnc server
F10 anaconda failed to start vnc server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 470877 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 12:30 EST by Mark McLoughlin
Modified: 2009-02-16 15:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:32:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2008-11-07 12:30:41 EST
anaconda-11.4.1.55

I tried installing a KVM guest by passing "vnc" on the anaconda command line and when it tried to start the vnc server I got a traceback:

Running anaconda 11.4.1.55, the Fedora system installer - please wait...       
18:26:05 Starting VNC...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 859, in <module>
    runVNC()
  File "/usr/bin/anaconda", line 432, in runVNC
    vncS.startServer()
  File "/usr/lib/anaconda/vnc.py", line 206, in startServer
    self.initialize()
  File "/usr/lib/anaconda/vnc.py", line 122, in initialize
    self.name = network.getDefaultHostname(self.anaconda)
  File "/usr/lib/anaconda/network.py", line 115, in getDefaultHostname
    hn = anaconda.id.network.hostname
AttributeError: 'NoneType' object has no attribute 'network'
Comment 1 David Cantrell 2008-11-07 20:38:34 EST
Interesting problem.  Can't reproduce it on anything but a kvm guest.  Installing on one of my test boxes here, it works fine.  Here's the patch:

diff --git a/network.py b/network.py
index c986cda..45dc408 100644
--- a/network.py
+++ b/network.py
@@ -112,7 +112,10 @@ def getDefaultHostname(anaconda):
     if hn and hn != 'localhost' and hn != 'localhost.localdomain':
         return hn
 
-    hn = anaconda.id.network.hostname
+    try:
+        hn = anaconda.id.network.hostname
+    except:
+        hn = None
 
     if not hn or hn == '(none)' or hn == 'localhost' or hn == 'localhost.localdomain':
         hn = socket.gethostname()
Comment 2 David Cantrell 2008-11-07 21:36:14 EST
BTW, 'patch-review' in the devel whiteboard is for my own purposes.  I've submitted the patch to the rest of the anaconda team for review.  If I can merge it in to repository, I'll move the bug to MODIFIED.
Comment 3 David Cantrell 2008-11-08 14:21:10 EST
Fix will be in anaconda-11.4.1.57-1.
Comment 4 Chris Lumens 2008-11-10 13:37:37 EST
*** Bug 470877 has been marked as a duplicate of this bug. ***
Comment 5 Bug Zapper 2008-11-25 23:59:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.