Bug 47079 - sndconfig seg faults with PCI sound cards
Summary: sndconfig seg faults with PCI sound cards
Status: CLOSED DUPLICATE of bug 41394
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-03 02:58 UTC by Need Real Name
Modified: 2014-03-17 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 04:04:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-07-03 02:58:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.5 i686)

Description of problem:
sndconfig gets segmentation fault when trying to test the soundcard. Two
different sound cards exhibited this problem, both PCI cards. One is a
SB128 the other is an es1898 (Allegro) based card. Both cards worked when
the module for the card was loaded manually, es1371.o and maestro3.o Both
cards were detected successfully. In addition, sndconfig fails to detect an
opl3sa2 card which is currently in the system and working. The
configuration for the opl3sa2 card was done when the system was running
6.2. The kernel is 2.4.5

How reproducible:
Always

Steps to Reproduce:
1. shutdown system
2. install sound card
3. reboot
4. run sndconfig
	

Actual Results:  depends on the card. After detecting the PCI cards it seg
faults. It fails to detect the ISA pnp card.

Additional info:

System is Athlon, kernel 2.4.5 installed from source from
kernel.org.Updates using ximian redcarpet.

Comment 1 Bill Nottingham 2001-07-06 03:25:51 UTC
Hm, I don't see the segfault here. Are you running in any particular locale?

Comment 2 Bill Nottingham 2001-07-06 03:29:05 UTC
Are you running it with the LANG environment variable unset?

Comment 3 Need Real Name 2001-07-06 04:04:40 UTC
Yes, I believe that is correct , LANG is not set to any value.

Comment 4 Bill Nottingham 2001-07-06 04:09:34 UTC
OK, that bug has since been fixed.

*** This bug has been marked as a duplicate of 41394 ***


Note You need to log in before you can comment on or make changes to this bug.