Bug 470816 - Need note on vt7 -> vt1 change for default X
Need note on vt7 -> vt1 change for default X
Status: CLOSED UPSTREAM
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2008-11-10 08:37 EST by Paul W. Frields
Modified: 2008-11-20 22:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 22:50:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2008-11-10 08:37:35 EST
After a default F10 graphical install, which should result in a runlevel 5 installation, X starts on vt1 instead of vt7.  Text installs or systems that default to runlevel 3 where the user runs 'startx' will use vt7.  I believe this is an artifact of Plymouth.
Comment 1 Adam Pribyl 2008-11-11 03:58:30 EST
Thanks for filling this Paul. As this is inteded change, brief description of the reasoning (smooth boot, hide confusing text login) would be fine. Maybe some link that it is possible to return to old behaviour, for those feeling this change to be a big problem.
Comment 2 Karsten Wade 2008-11-11 12:20:46 EST
(In reply to comment #1)
> Thanks for filling this Paul. As this is inteded change, brief description of
> the reasoning (smooth boot, hide confusing text login) would be fine. Maybe
> some link that it is possible to return to old behaviour, for those feeling
> this change to be a big problem.

Is there a page that explains that already?  If not, can someone help by filling in the details in a new page, such as:

https://fedoraproject.org/wiki/Changing_virtual_terminal_numbering_under_Plymouth

Adam -- your reasoning seems to explain why we are switching to Plymouth, but not why we are switching the VT numbering scheme.  From what I read on f-devel-l, it sounds as if there is disagreement that changing the VT numbering actually reduces flickers, etc.  Is that true?  If so, what is the actual reason for the renumbering?
Comment 3 Adam Pribyl 2008-11-12 03:57:44 EST
I am just a user, that tries to push a note about this change into release notes. I have no detailed knowledge about reasoning...

Note You need to log in before you can comment on or make changes to this bug.