Bug 470866 - new install stopped while installing bootloader
new install stopped while installing bootloader
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
: 499794 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 12:42 EST by eric magaoay
Modified: 2009-09-11 09:17 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-11 09:17:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric magaoay 2008-11-10 12:42:47 EST
Description of problem:
While performing new install the process stopped while installing bootloader (near the end of downloading/installing packages. The last it was installing was the kernel-26.27.4-79.fc10.i686

Version-Release number of selected component (if applicable):
anaconda 11.4.1.5601.i386.rpm
kernel 26.27.4.-49.fc10.i686

How reproducible:
persistent

Steps to Reproduce:
1. command line used:
/usr/bin/qemu-kvm -drive file=/a/m/sf/dev/i386/os/images/boot.iso,media=cdrom -drive file=/a/i/fda0,if=virtio  -net nic,vlan=7740,macaddr=52:55:00:03:18:40,model=virtio -net user,vlan=7740,hostname=fda0-37740 -name fda0-37740 -localtime -usbdevice tablet -vnc :1840 -monitor stdio -m 512  

Actual results:
installation process just stopped at near the end.
Comment 1 eric magaoay 2008-11-10 17:35:00 EST
Just an added note: I was able to complete the installation when I use the option to boot from local kernel instead boot.iso. Below is the complete command I used:

/usr/bin/qemu-kvm -kernel /a/m/sf/dev/x86_64/os/isolinux/vmlinuz -initrd /a/m/sf/dev/x86_64/os/isolinux/initrd.img -append "ksdevice=52:55:00:03:28:40 ks=http://192.168.5.103/a/ks/fdb0-38740" -drive file=/a/i/fdb0,boot=on  -net nic,vlan=8740,macaddr=52:55:00:03:28:40 -net user,vlan=8740,hostname=fdb0-38740 -name fdb0-38740 -localtime -usbdevice tablet -vnc :2840 -monitor stdio -m 512

kickstart file:
# (fda0-37740)/a/ks/fda0-37740
# Mon Nov 10 13:49:45 EST 2008
keyboard us
lang en_US.UTF-8
timezone  America/New_York
rootpw install
user --name=adm0 --uid=500 --password=install
network --bootproto dhcp --hostname fda0-37740
url --url http://192.168.5.103/a/m/sf/dev/i386/os/


command executed from local console( as a viewer):
vncviewer :7740 -name fda0-37740
Comment 2 Bug Zapper 2008-11-26 00:08:32 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora Admin XMLRPC Client 2009-05-07 08:12:41 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2009-05-07 12:38:17 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Catalin BOIE 2009-05-08 04:25:30 EDT
*** Bug 499794 has been marked as a duplicate of this bug. ***
Comment 6 Catalin BOIE 2009-05-08 04:30:54 EDT
*** Bug 499794 has been marked as a duplicate of this bug. ***
Comment 7 Catalin BOIE 2009-05-08 04:37:31 EDT
I have the same problem with Fedora 11 Preview.
Text installation works.
Comment 8 Mark McLoughlin 2009-05-11 06:23:17 EDT
Catalin: could you include the full command line you used for qemu-kvm? Also, include the version of qemu you tested with and any messages printed by qemu or any messages logged to syslog during the install

Moving the bug to Fedora 11 - we've more chance of getting this debugged and fixed in F11
Comment 9 Catalin BOIE 2009-05-11 07:36:44 EDT
Mark, sorry about not providing all information.
I am using Fedora 10, up-to-date.
qemu-kvm: QEMU PC emulator version 0.9.1 (kvm-74).
Note, please, that the same thing I get also without using KVM!

Kernel: 2.6.27.21-170.2.56.fc10.i686 #1 SMP Mon Mar 23 23:37:54 EDT 2009 i686 i686 i386 GNU/Linux

Command line (without KVM):  qemu -m 512 -hda F11preview2.qcow2 -cdrom Fedora-11-Preview-i386-DVD.iso -net nic,macaddr=00:11:11:11:11:78 -net tap,script=run.net -boot d -usbdevice tablet

Command line (with kvm):  qemu-kvm -m 512 -drive file=F11preview2.qcow2,if=virtio,boot=on,cache=on -cdrom Fedora-11-Preview-i386-DVD.iso -net nic,macaddr=00:11:11:11:11:78,model=virtio -net tap,script=run.net -boot d -usbdevice tablet

Hope it helps!

If you need more info, let me know.

If you give me some hints on how to debug this thing, let me know.
Comment 10 Mark McLoughlin 2009-05-11 07:53:43 EDT
Ah, okay - this is a Fedora 10 bug. I don't think we've seen reports of this on a Fedora 11 host
Comment 11 Catalin BOIE 2009-05-11 10:10:30 EDT
Image was created like this: qemu-img create -f qcow2 F11preview2.qcow2 10G
Host:
May 11 14:45:11 cboie kernel: kvm: guest NX capability removed
May 11 14:45:11 cboie kernel: kvm: guest NX capability removed
(yes, two times)

Guest:
Seems that the system gets stuck. I cannot issue any command on it. Is dead.
Comment 12 Mark McLoughlin 2009-05-11 13:30:20 EDT
Hmm, I wonder is it in any way related to bug #499596?

Try running with qemu-kvm -cpu qemu32 ?
Comment 13 eric magaoay 2009-05-11 13:41:34 EDT
due to space/time limitation I can no longer test i386, but I know for sure that I'm able to install x86_64 w/ no problem as of the latest build (5/1/09) pulled from source. 

Not sure if this bug should closed or not.
Comment 14 Catalin BOIE 2009-05-12 06:02:47 EDT
Mark, it doesn't work with "-cpu qemu32".
Comment 15 Marc Sauton 2009-06-10 16:20:59 EDT
I seem to experience the same behavior on F11, using virt-manager and mostly default options, if this can help:

Host is a T61 with the following from yesterday:
Fedora release 11 (Leonidas)
Linux localhost.localdomain 2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27 17:27:08 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

libvirt-0.6.2-11.fc11.x86_64
qemu-img-0.10.4-4.fc11.x86_64
qemu-kvm-0.10.4-4.fc11.x86_64
qemu-common-0.10.4-4.fc11.x86_64
qemu-system-x86-0.10.4-4.fc11.x86_64

selinux enforcing, iptables on

And trying to create a F11 x86_64 guest, using tree from dvd on laptop:

it created a /var/lib/libvirt/images/f11ms.img with the expected size, and target device vda, all good until near the end with an apparent never ending "Installing bootloader..."
The VM details are available just fine, but the guest does not seem to respond to for example a "send keys" to access another tty.

the process is like this on the host:

/usr/bin/qemu-kvm -S -M pc -m 512 -smp 1 -name f11ms -uuid e8068481-7e01-8d8f-48af-0df4d3a3abf2 -monitor pty -pidfile /var/run/libvirt/qemu//f11ms.pid -no-reboot -boot d -drive file=/dev/sr0,if=ide,media=cdrom,index=2 -drive file=/var/lib/libvirt/images/f11ms.img,if=virtio,index=0 -net nic,macaddr=54:52:00:4c:de:d6,vlan=0,model=virtio -net tap,fd=18,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0
Comment 16 Marc Sauton 2009-06-10 16:26:04 EDT
but the F11 guest did reboot properly after a forced shutdown, and install completed with a success (figured out after submitting previous comment, sorry)
Comment 17 Mark McLoughlin 2009-06-19 06:34:51 EDT
Can anyone confirm this is a duplicate of bug #501412? Should be fixed with qemu-0.10.5-2.fc11 or later
Comment 18 Catalin BOIE 2009-09-08 03:29:31 EDT
I installed F12 Alpha on a F11 host and no stuck happened.
I think the bug can be closed.
Comment 19 Mark McLoughlin 2009-09-11 09:17:33 EDT
Thanks

Note You need to log in before you can comment on or make changes to this bug.