Bug 470982 - Can't install / update software
Can't install / update software
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 03:54 EST by Amit Shah
Modified: 2014-01-21 18:06 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 00:03:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Shah 2008-11-11 03:54:49 EST
I'm trying out Fedora 10 PR KDE Live spin. I typed 'yum install make', it asks me if I should proceed and I hit 'y'. It then tries several mirrors and fails:

---
Last few lines of the output:
http://ftp.kddilabs.jp/Linux/packages/fedora/development/x86_64/os/Packages/make-3.81-14.fc10.i386.rpm: [Errno 14] HTTP Error 404: Not Found                    
Trying other mirror.                                                            
http://ftp.chg.ru/pub/Linux/fedora/linux/development/x86_64/os/Packages/make-3.81-14.fc10.i386.rpm: [Errno 14] HTTP Error 404: Not Found                        
Trying other mirror.      

Error Downloading Packages:
  1:make-3.81-14.fc10.i386: failure: Packages/make-3.81-14.fc10.i386.rpm from rawhide: [Errno 256] No more mirrors to try.

---

I also got this in a dialog box on the desktop:

failure: repodata/6ea752d82fcadbe9c5f132e36594d32e3526dd9a-filelists.sqlite.bz2 from rawhide: [Errno 256] No more mirrors to try.

Also, how do I solve this manually?
Comment 1 Amit Shah 2008-11-11 04:38:17 EST
OK, I have an i686 install, why is it looking at the x86_64 directory for the file?
Comment 2 Panu Matilainen 2008-11-11 04:42:45 EST
Looks a bit funny if you indeed have i686.. but rpm isn't involved here, reassigning to yum.
Comment 3 Amit Shah 2008-11-11 04:47:01 EST
I'm running a 64-bit kernel on a 32-bit userspace. Maybe that's the reason. For now, I've manually installed the make rpm from the mirror's i386 directory.
Comment 4 Bug Zapper 2008-11-26 00:10:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 seth vidal 2009-01-21 12:59:19 EST
If you're still having problems like this please reopen this bug. I'm going to close it as insufficient data.
Comment 6 Amit Shah 2009-01-21 23:18:10 EST
I'm not sure what more data is  needed. It's fairly easy to reproduce:

In an i686 install, boot with a 64-bit kernel (compiled on a x86_64 install machine) and then try any of the rpm / yum update commands.
Comment 7 seth vidal 2009-01-22 00:03:27 EST
Okay, if that is the only way of triggering it then we can probably close this notabug. Running the 64bit kernel on an i686 install is, at least afaik, not supported.

If you want a 64bit install, run the 64bit install.
Comment 8 Amit Shah 2009-02-09 01:40:15 EST
I guess running a 64-bit kernel on a 32-bit OS is now going to be a supported setting since the F11 release.

Would you still consider this isn't a bug?

Also, developers do test such scenarios.
Comment 9 James Antill 2009-02-09 09:58:19 EST
 AFAIK the current solution is to change the configuration so that it look for x86_64 URLs on the 32bit live CD, etc. ... but, yeh, however we get there it'll work. For Fedora 11.

Note You need to log in before you can comment on or make changes to this bug.