Bug 471133 - CONFIG_CRASH should not be set for s390x
CONFIG_CRASH should not be set for s390x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 485144 (view as bug list)
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2008-11-11 17:00 EST by Brad Hinson
Modified: 2009-03-13 12:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 12:57:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
unset CONFIG_CRASH (647 bytes, patch)
2008-11-11 17:00 EST, Brad Hinson
no flags Details | Diff
Compile error during rpmbuild (1.65 KB, text/plain)
2008-11-12 12:47 EST, Brad Hinson
no flags Details

  None (edit)
Description Brad Hinson 2008-11-11 17:00:03 EST
Description of problem:
Compilation error with CONFIG_CRASH set on s390x.  Shouldn't be set on this arch anyway.

I don't fully grasp how this value makes its way into .config, but attaching my hack/patch for reference.

Version-Release number of selected component (if applicable):
kernel-2.6.27.5-32.fc9
Comment 1 Brad Hinson 2008-11-11 17:00:48 EST
Created attachment 323265 [details]
unset CONFIG_CRASH
Comment 2 Dave Jones 2008-11-11 19:23:52 EST
what's the compilation error ?
afaik, there's no reason that this shouldn't work on s390. It's just a feature subset of /dev/mem
Comment 3 Brad Hinson 2008-11-12 12:47:17 EST
Created attachment 323361 [details]
Compile error during rpmbuild
Comment 4 Dave Jones 2008-11-12 13:10:11 EST
huh, I thought we used to build this on earlier RHELs. Looks like I was mistaken.

I committed a similar patch to yours (it goes in config-s390x instead, which overrides the setting in config-generic)
Comment 5 Karsten Hopp 2009-02-11 16:28:48 EST
*** Bug 485144 has been marked as a duplicate of this bug. ***
Comment 6 Karsten Hopp 2009-02-11 16:32:13 EST
this issue isn't fixed in kernel-2.6.29-0.99.rc4.git1.fc11.src.rpm, can you take
a look at it again, please ? We need to build a s390x kernel for F-11 when we branch for RHEL6. Bonus points if the kernel even boots ;-)
Comment 7 Chuck Ebbert 2009-02-28 14:22:13 EST
$ grep CRASH configs/*s390*
# CONFIG_CRASH is not set

???
Comment 8 Dave Jones 2009-03-13 12:57:31 EDT
I killed this driver completely. Crash should be able to use the generic upstream drivers in current Fedora.

Note You need to log in before you can comment on or make changes to this bug.