Bug 471232 - support specifying partition to upgrade via kickstart
support specifying partition to upgrade via kickstart
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
: Reopened
: 473271 474304 477509 (view as bug list)
Depends On:
Blocks: F11Target 473016
  Show dependency treegraph
 
Reported: 2008-11-12 10:40 EST by Jeremy Katz
Modified: 2010-02-17 14:35 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 14:35:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
git formatted patch (773 bytes, patch)
2009-03-16 12:33 EDT, Will Woods
no flags Details | Diff

  None (edit)
Description Jeremy Katz 2008-11-12 10:40:31 EST
We need to add support to the 'upgrade' keyword for specifying what the rootfs to upgrade is rather than just blindly assuming "first in the list".  This can then get used by preupgrade so that the right rootfs gets upgraded.
Comment 1 Bug Zapper 2008-11-26 00:15:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jon Stanley 2008-11-26 14:13:41 EST
Fixing version to align with rawhide again.  Sorry for the noise.
Comment 3 Will Woods 2008-12-05 13:05:11 EST
*** Bug 474304 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2008-12-11 17:44:36 EST
*** Bug 473271 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2008-12-22 10:15:46 EST
*** Bug 477509 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2009-01-07 11:57:01 EST
This support will be included in the next build of anaconda and pykickstart.
Comment 7 Will Woods 2009-03-13 17:07:26 EDT
This isn't working in anaconda-11.5.0.28; error dialog claims "Kickstart command upgrade does not take any arguments".

Moving to pykickstart; I'm pretty sure that's where this message comes from.
Comment 8 Will Woods 2009-03-16 12:33:30 EDT
Created attachment 335372 [details]
git formatted patch

anaconda's kickstart.py is still using the FC3_Upgrade.parse() method to parse the 'upgrade' command. Attached patch should fix that.
Comment 9 Chris Lumens 2009-03-16 12:45:18 EDT
Well that was stupid of me.

Thanks for the patch.  I've pushed this to master and storage, so we'll make sure to have it regardless of what we do with the storage stuff.
Comment 10 Stefan Becker 2009-03-22 04:06:31 EDT
Any idea when preupgrade will add support to generate --root-device to ks.cfg? I just checked trac and in preugprade/__init__.py@dev,286 generate_kickstart() still hard codes a simple "upgrade".
Comment 11 Radek Vykydal 2009-06-10 09:28:27 EDT
I noticed that the feature seem to be removed with anaconda storage rewrite (commit e1a7fe9887886044b07587b3ec2caa2ff53ebfb2).
Comment 12 Alexander Todorov 2009-06-10 10:37:07 EDT
Radek,
QE is also planning to make use of this feature. Can you add it back to the code please.
Comment 13 Radek Vykydal 2009-07-20 07:56:26 EDT
Should appear in version 12.0-1 of anaconda.

Supports partition name (e.g. 'sda1', or 'Volgroup00-LogVol00') and
UUID specified via 'UUID=<uuid>' (as obtained by blkid command).
Comment 15 Tom "spot" Callaway 2009-09-14 12:22:08 EDT
Can someone confirm that this is present and functional in rawhide? And if so, please close this bug out.
Comment 16 Bug Zapper 2009-11-16 04:35:54 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.