Bug 474304 - preupgrade mounts wrong partition as /mnt/sysimage
preupgrade mounts wrong partition as /mnt/sysimage
Status: CLOSED DUPLICATE of bug 471232
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 03:16 EST by Stig Hackvan
Modified: 2014-01-21 18:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 13:05:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stig Hackvan 2008-12-03 03:16:10 EST
Description of problem:

running preupgrade (f8 to f10) has been a chore.  here are the things i've had to tweak...

1. hang at boot time on nvidia 6800 card, so edit grub.conf to boot in text mode.  I *STRONGLY* recommend this for all preupgrade-based upgrades because it's mostly unattended at boot time.

2. preupgrade mounted the wrong partition to upgrade...
i have several potential root partitions on my disk.  sda1,2,6 and they have variably-old fedora installs.  sda1 was "active" and also first, but I'd been using sda2 as the root partition with grub installed to the MBR and (hd0,1) as the boot partition.  for some reason, /dev/sda1 was mounted as /mnt/sysimage instead of sda2.  I moved all the files in that partition to a subdirectory so it didn't look like a fedora install and set sda2 to be the only active/bootable partition and that fixed the problem.
Comment 1 Will Woods 2008-12-05 13:05:11 EST
I'm guessing you've got multiple Fedora installations on your machine. Anaconda in F10 does not have a way to specify *which* filesystem to upgrade in a kickstart, so it just chooses the first one it finds.

Remove 'upgrade' from /boot/upgrade/ks.cfg and it will prompt you to choose which one to upgrade.

Future versions of preupgrade/anaconda will use an 'upgrade --root=XXX' command to pick the correct root filesystem, rather than just using the first one it finds.

*** This bug has been marked as a duplicate of bug 471232 ***

Note You need to log in before you can comment on or make changes to this bug.