This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 471288 - Upgrade from F9 encrypted LV rootfs (not VG) fails
Upgrade from F9 encrypted LV rootfs (not VG) fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 471599 (view as bug list)
Depends On:
Blocks: F10AnacondaBlocker
  Show dependency treegraph
 
Reported: 2008-11-12 15:37 EST by Warren Togami
Modified: 2008-11-14 11:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 15:23:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (11.17 KB, text/plain)
2008-11-12 15:58 EST, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2008-11-12 15:37:25 EST
1. Install F9 with unencrypted VG, but encrypted LV as root partition.

/etc/fstab:
/dev/mapper/luks-vg0-system /                       ext3    defaults        1 1

2. preupgrade-0.9.9 into anaconda-11.4.1.57-1.
3. Reboot into anaconda.
4. Enter passphrase for root filesystem.

Error mounting device mapper/luks-vg0-system as /: mount: special device /dev/mapper/luks-vg0-system does not exist

Press OK to exit the installer.

ALT-F3 shows that it mounted /dev/mapper/luks-UUID on /mnt/sysimage, then it tried to mount the /etc/fstab listed /dev/mapper/luks-vg0-system on /, which fails because /dev/mapper/luks-vg0-system does not exist.  F10 only luks-UUID exists in /dev/mapper.

5. Edit /etc/fstab so it has UUID= of the encrypted lv, reboot into anaconda again.

Error mounting device vg0/system as /: mount: /dev/mapper/vg0-system already mounted or /mnt/sysimage busy

Press OK to exit the installer.
Comment 1 Warren Togami 2008-11-12 15:58:44 EST
Created attachment 323388 [details]
anaconda.log

anaconda.log at the failure described in step 4.
Comment 2 David Lehman 2008-11-12 20:33:07 EST
Fixed in anaconda-11.4.1.58-1.
Comment 3 David Lehman 2008-11-14 11:42:40 EST
*** Bug 471599 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.