Bug 471599 - F9's anaconda-created /etc/fstab can't upgrade to F10
F9's anaconda-created /etc/fstab can't upgrade to F10
Status: CLOSED DUPLICATE of bug 471288
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 10:35 EST by Andrew Overholt
Modified: 2008-11-14 11:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 11:42:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Phone camera snapshot of error (202.14 KB, image/jpeg)
2008-11-14 10:35 EST, Andrew Overholt
no flags Details

  None (edit)
Description Andrew Overholt 2008-11-14 10:35:21 EST
Created attachment 323589 [details]
Phone camera snapshot of error

I installed F9 and luks-encrypted my /home.  It wrote /etc/fstab to have entries like this:

/dev/VolGroup00/LogVol00              /      ext3  defaults  1 1
/dev/mapper/luks-VolGroup00-LogVol01  /home  ext3  defaults  1 2

I then booted from the F10 preview DVD and attempted to upgrade.  It prompted me for the luks password for the encrypted /home volume but then couldn't mount it, saying "Devices in /etc/fstab should be specified by lable or UUID, not by device name."  Why did it write an /etc/fstab with device names, then?

I'm re-trying with UUIDs which will hopefully work.
Comment 1 David Lehman 2008-11-14 11:42:40 EST

*** This bug has been marked as a duplicate of bug 471288 ***

Note You need to log in before you can comment on or make changes to this bug.