Bug 471357 - SIGSEGV from installer when given install URL with ftp password embedded
SIGSEGV from installer when given install URL with ftp password embedded
Status: CLOSED DUPLICATE of bug 483818
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 03:06 EST by aepalea
Modified: 2009-02-25 11:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 05:11:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aepalea 2008-11-13 03:06:02 EST
Description of problem:

Fedora Core 10 Preview installer crashes when entering a URL to an FTP location with password.  

Version-Release number of selected component (if applicable):

How reproducible:

Four times in a row.  

Steps to Reproduce:
1. English / US / URL / config network / URL Setup
2. type ftp://username@server/pub (will fail, but crash anyway) 

Actual results:

kernel crash "install exited abnormally" with backtrace: 

SIGSEGV! 
...
libc.so
convertUItoURL 
...

Expected results:

That it would crash later on when I typed my ftp password, which contains characters that choke OpenBSD.  

Additional info:

I was initially using a valid URL of the form: 

ftp://username@server/pub/.../netboot.iso 

This crashes without the error first. 

(My patience for picking the component out of 200 entries displayed in a five line gun turret is extremely limited.)
Comment 1 David Woodhouse 2008-11-13 05:11:47 EST
Not a bug with the 0xFFFF package; closing. Please reopen against correct package if you wish this to be dealt with.
Comment 2 Chris Lumens 2009-02-25 11:07:26 EST

*** This bug has been marked as a duplicate of bug 483818 ***

Note You need to log in before you can comment on or make changes to this bug.