Bug 471577 - kernel output some warnings during booting
kernel output some warnings during booting
Status: CLOSED DUPLICATE of bug 470421
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 08:22 EST by Peng Huang
Modified: 2008-11-17 12:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 12:50:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg (41.83 KB, text/plain)
2008-11-14 08:22 EST, Peng Huang
no flags Details

  None (edit)
Description Peng Huang 2008-11-14 08:22:02 EST
Created attachment 323568 [details]
output of dmesg

Description of problem:
kernel output some warnings during booting

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mads Kiilerich 2008-11-14 09:48:30 EST
Adding some info I find missing from the report:

It seems like ACPI detection fails and the kernel thus tries to create duplicate entries in /proc ...

input: Sleep Button (CM) as /devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input2
ACPI: Sleep Button (CM) [SLPB]
------------[ cut here ]------------
WARNING: at fs/sysfs/dir.c:463 sysfs_add_one+0x2a/0x36()
sysfs: duplicate filename '1' can not be created
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.27.5-109.fc10.i686 #1
 [<c042bb3a>] warn_slowpath+0x4b/0x6c
 [<c051cc00>] ? vsnprintf+0x2af/0x54e
 [<c05185b9>] ? idr_get_empty_slot+0x12a/0x1d9
 [<c0518738>] ? ida_get_new_above+0xd0/0x171
 [<c04cbedc>] ? sysfs_ilookup_test+0x0/0x11
 [<c04a0867>] ? ifind+0x55/0x60
 [<c04cc0cf>] ? sysfs_find_dirent+0x16/0x27
 [<c04cc221>] sysfs_add_one+0x2a/0x36
 [<c04cc6be>] create_dir+0x43/0x68
 [<c04cc710>] sysfs_create_dir+0x2d/0x41
 [<c05190b0>] kobject_add_internal+0xb2/0x153
 [<c05191fc>] kobject_add_varg+0x35/0x41
 [<c0519228>] kobject_init_and_add+0x20/0x22
 [<c052706e>] pci_create_slot+0x93/0xe1
 [<c056220c>] register_slot+0x14f/0x1e7
 [<c044042c>] ? up+0x2b/0x2f
 [<c055384e>] acpi_ns_walk_namespace+0x9a/0x110
 [<c0552131>] acpi_walk_namespace+0x46/0x66
Comment 2 Dave Jones 2008-11-17 12:50:07 EST

*** This bug has been marked as a duplicate of bug 470421 ***

Note You need to log in before you can comment on or make changes to this bug.