Bug 471621 - system-config-network - invalid static IP settings saved - router saved as netmask
system-config-network - invalid static IP settings saved - router saved as ne...
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 12:52 EST by Jeremy Huddleston
Modified: 2008-11-28 06:43 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-28 06:43:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Huddleston 2008-11-14 12:52:16 EST
Description of problem:

Open 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. system-config-network
2. edit eth0
3. in general tab, select 'staticly assigned ip'
4. enter:
ip:       10.0.10.4
netmask: 255.255.255.0
router:   10.0.10.254
5. click ok
6. click edit again to reopen the window you just closed

Actual results:

netmask is 10.0.10.254

Expected results:

netmask is the value you entered: 255.255.255.0

Additional info:

This is probably trivial to fix...
Comment 1 Pavel Lisý 2008-11-17 04:17:01 EST
I can confirm it. It impossible set network configuration correctly.
Comment 2 Ronald Warsow 2008-11-18 11:30:43 EST
additional (F10 on a i386 box) if I set MTU AND save this setting I see this:

Component: system-config-network
Version: 1.5.93
Summary: TB334155f4 ConfShellVar.py:66:__setitem__:TypeError: expected string or buffer

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 829, in on_applyButton_clicked
    self.save()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 411, in save
    self.saveDevices()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 431, in saveDevices
    devicelist.save()
  File "/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 238, in save
    dev.save()
  File "/usr/share/system-config-network/netconfpkg/NCDevice.py", line 413, in save
    conf[confkey] = getattr(self, selfkey)
  File "/usr/share/system-config-network/netconfpkg/conf/ConfShellVar.py", line 66, in __setitem__
    if self.quotereg.search(value):
TypeError: expected string or buffer

Local variables in innermost frame:
varname: MTU
self: <netconfpkg.NCDevice.ConfDevice instance at 0x8d5d4ac>
place: 15
value: 1460
missing: 1
Comment 3 Deependra Singh Shekhawat 2008-11-19 09:56:11 EST
Hi,

I am also seeing this weird behaviour. I have to use NetworkManager because of this bug.

Thanks and any inputs if needed please ask and will be provided.
Comment 4 Trevin Beattie 2008-11-19 23:26:26 EST
Looks like a duplicate of bug #469434.
Comment 5 Bug Zapper 2008-11-26 00:23:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Jiri Moskovcak 2008-11-28 06:43:20 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.