Bug 471653 - ACPI_PCI_SLOT driver is loud and obnoxious on boot
ACPI_PCI_SLOT driver is loud and obnoxious on boot
Status: CLOSED DUPLICATE of bug 470637
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-11-14 16:08 EST by Bill Nottingham
Modified: 2014-03-16 23:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 09:11:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-11-14 16:08:48 EST
Description of problem:

acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
decode_hpp: Could not get hotplug parameters. Use defaults
acpiphp: Slot [1] registered
input: Power Button (FF) as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
ACPI: Power Button (FF) [PWRF]
input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input1
ACPI: Lid Switch [LID]
input: Sleep Button (CM) as /devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input2
ACPI: Sleep Button (CM) [SLPB]
------------[ cut here ]------------
WARNING: at fs/sysfs/dir.c:463 sysfs_add_one+0x35/0x3d()
sysfs: duplicate filename '1' can not be created
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.27.5-109.fc10.x86_64 #1

Call Trace:
 [<ffffffff81041623>] warn_slowpath+0x8c/0xb5
 [<ffffffff81166e9a>] ? idr_get_empty_slot+0x153/0x22a
 [<ffffffff8116706e>] ? ida_get_new_above+0xfd/0x1ae
 [<ffffffff8110c7c8>] ? sysfs_ilookup_test+0x0/0x14
 [<ffffffff8110cb8a>] sysfs_add_one+0x35/0x3d
 [<ffffffff8110d13e>] create_dir+0x58/0x87
 [<ffffffff8110d1a5>] sysfs_create_dir+0x38/0x4f
 [<ffffffff81167cf0>] kobject_add_internal+0xd2/0x18f
 [<ffffffff81167e79>] kobject_add_varg+0x41/0x4e
 [<ffffffff81167ed2>] kobject_init_and_add+0x4c/0x57
 [<ffffffff8117893f>] pci_create_slot+0xb1/0x10a
 [<ffffffff811b9825>] register_slot+0x189/0x250
 [<ffffffff810b8bc1>] ? virt_to_head_page+0x31/0x41
 [<ffffffff811aa6d4>] acpi_ns_walk_namespace+0xb6/0x13a
 [<ffffffff811b969c>] ? register_slot+0x0/0x250
 [<ffffffff811b969c>] ? register_slot+0x0/0x250
 [<ffffffff811a8bda>] acpi_walk_namespace+0x60/0x84
 [<ffffffff811b969c>] ? register_slot+0x0/0x250
 [<ffffffff811b9662>] walk_p2p_bridge+0xdc/0x116
 [<ffffffff811b969c>] ? register_slot+0x0/0x250
 [<ffffffff81058a1c>] ? up+0x34/0x39
 [<ffffffff811aa6d4>] acpi_ns_walk_namespace+0xb6/0x13a
 [<ffffffff811b9586>] ? walk_p2p_bridge+0x0/0x116
 [<ffffffff811b9586>] ? walk_p2p_bridge+0x0/0x116
 [<ffffffff811a8bda>] acpi_walk_namespace+0x60/0x84
 [<ffffffff8159d140>] ? early_idt_handler+0x0/0x72
 [<ffffffff811b952d>] acpi_pci_slot_add+0x131/0x18a
 [<ffffffff811b969c>] ? register_slot+0x0/0x250
 [<ffffffff811b79f0>] acpi_pci_register_driver+0x52/0x6f
 [<ffffffff815c3d36>] ? acpi_pci_slot_init+0x0/0x20
 [<ffffffff815c3d52>] acpi_pci_slot_init+0x1c/0x20
 [<ffffffff8100a047>] do_one_initcall+0x47/0x12e
 [<ffffffff8159d140>] ? early_idt_handler+0x0/0x72
 [<ffffffff81100000>] ? smaps_pte_range+0xc1/0x1e1
 [<ffffffff8159d70f>] kernel_init+0x1c0/0x214
 [<ffffffff8133223e>] ? trace_hardirqs_on_thunk+0x3a/0x3c
 [<ffffffff810116e9>] child_rip+0xa/0x11
 [<ffffffff81010a07>] ? restore_args+0x0/0x30
 [<ffffffff8159d54f>] ? kernel_init+0x0/0x214
 [<ffffffff810116df>] ? child_rip+0x0/0x11

---[ end trace a7919e7f17c0a725 ]---
kobject_add_internal failed for 1 with -EEXIST, don't try to register things with the same name in the same directory.
Pid: 1, comm: swapper Tainted: G        W 2.6.27.5-109.fc10.x86_64 #1

Call Trace:
 [<ffffffff81167d95>] kobject_add_internal+0x177/0x18f
 [<ffffffff81167e79>] kobject_add_varg+0x41/0x4e
 [<ffffffff81167ed2>] kobject_init_and_add+0x4c/0x57
 [<ffffffff8117893f>] pci_create_slot+0xb1/0x10a
 [<ffffffff811b9825>] register_slot+0x189/0x250
 [<ffffffff810b8bc1>] ? virt_to_head_page+0x31/0x41
 [<ffffffff811aa6d4>] acpi_ns_walk_namespace+0xb6/0x13a
 [<ffffffff811b969c>] ? register_slot+0x0/0x250
 [<ffffffff811b969c>] ? register_slot+0x0/0x250
 [<ffffffff811a8bda>] acpi_walk_namespace+0x60/0x84
 [<ffffffff811b969c>] ? register_slot+0x0/0x250
 [<ffffffff811b9662>] walk_p2p_bridge+0xdc/0x116
 [<ffffffff811b969c>] ? register_slot+0x0/0x250
 [<ffffffff81058a1c>] ? up+0x34/0x39
 [<ffffffff811aa6d4>] acpi_ns_walk_namespace+0xb6/0x13a
 [<ffffffff811b9586>] ? walk_p2p_bridge+0x0/0x116
 [<ffffffff811b9586>] ? walk_p2p_bridge+0x0/0x116
 [<ffffffff811a8bda>] acpi_walk_namespace+0x60/0x84
 [<ffffffff8159d140>] ? early_idt_handler+0x0/0x72
 [<ffffffff811b952d>] acpi_pci_slot_add+0x131/0x18a
 [<ffffffff811b969c>] ? register_slot+0x0/0x250
 [<ffffffff811b79f0>] acpi_pci_register_driver+0x52/0x6f
 [<ffffffff815c3d36>] ? acpi_pci_slot_init+0x0/0x20
 [<ffffffff815c3d52>] acpi_pci_slot_init+0x1c/0x20
 [<ffffffff8100a047>] do_one_initcall+0x47/0x12e
 [<ffffffff8159d140>] ? early_idt_handler+0x0/0x72
 [<ffffffff81100000>] ? smaps_pte_range+0xc1/0x1e1
 [<ffffffff8159d70f>] kernel_init+0x1c0/0x214
 [<ffffffff8133223e>] ? trace_hardirqs_on_thunk+0x3a/0x3c
 [<ffffffff810116e9>] child_rip+0xa/0x11
 [<ffffffff81010a07>] ? restore_args+0x0/0x30
 [<ffffffff8159d54f>] ? kernel_init+0x0/0x214
 [<ffffffff810116df>] ? child_rip+0x0/0x11

Unable to register kobject 1
pci_slot: pci_create_slot returned -17
ACPI: SSDT BF6F1D36, 0282 (r1  PmRef  Cpu0Ist      100 INTL 20050513)
ACPI: SSDT BF6F203D, 065A (r1  PmRef  Cpu0Cst      100 INTL 20050513)

Version-Release number of selected component (if applicable):

kernel-2.6.27.5-109.fc10.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. Boot.
  
Actual results:

Spew.

Expected results:

No spew.

Additional info:

Lenovo Thinkpad T60. Presumably the slot in question is the expresscard slot?
Comment 1 Matthew Garrett 2008-11-17 09:11:12 EST

*** This bug has been marked as a duplicate of bug 470637 ***

Note You need to log in before you can comment on or make changes to this bug.