Bug 470637 - "Unable to register kobject 1" when system booting after upgrade to 2.6.27.4-79.fc10.i686
"Unable to register kobject 1" when system booting after upgrade to 2.6.27.4-...
Status: CLOSED DUPLICATE of bug 470421
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
: 471653 (view as bug list)
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-11-07 23:30 EST by Yolkfull Chow
Modified: 2013-01-10 02:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 10:52:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2008-11-07 23:30:23 EST
Description of problem:
After yum upgrade to 2.6.27.4-79.fc10.i686 and reboot system, get following error messages when kernel booting:
------
Unable to register kobject 1
pci_slot pci_create_slot  return -17

Version-Release number of selected component (if applicable):
2.6.27.4-79.fc10.i686

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yolkfull Chow 2008-11-11 22:03:40 EST
Still have this problem after upgrade to kernel-2.6.27.5-94.fc10.i686

# rpm -qa|grep kernel |grep 5-94
kernel-PAEdebug-devel-2.6.27.5-94.fc10.i686
kernel-headers-2.6.27.5-94.fc10.i386
kernel-devel-2.6.27.5-94.fc10.i686
kernel-2.6.27.5-94.fc10.i686
kernel-firmware-2.6.27.5-94.fc10.noarch
kernel-debug-devel-2.6.27.5-94.fc10.i686
kernel-PAE-devel-2.6.27.5-94.fc10.i686
Comment 2 Yolkfull Chow 2008-11-11 22:15:59 EST
# dmesg |grep pci_create
 [<c05270ee>] pci_create_slot+0x93/0xe1
 [<c05270ee>] pci_create_slot+0x93/0xe1
pci_slot: pci_create_slot returned -17
Comment 3 Matthias Haase 2008-11-15 11:44:03 EST
I can confirm the error message on kernel-2.6.27.5-37.fc9.i686, updated today on an IBM Thinkpad T40. The Thinkpad does his work without notifiable problems...

------------[ cut here ]------------
WARNING: at fs/sysfs/dir.c:463 sysfs_add_one+0x2a/0x36()
sysfs: duplicate filename '1' can not be created
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.27.5-37.fc9.i686 #1
 [<c042a052>] warn_slowpath+0x4b/0x6c
 [<c0402707>] ? __switch_to+0xd3/0x153
 [<c0500684>] ? idr_get_empty_slot+0x12a/0x1d9
 [<c0500803>] ? ida_get_new_above+0xd0/0x171
 [<c04c9ef4>] ? sysfs_ilookup_test+0x0/0x11
 [<c049f0ee>] ? ifind+0x55/0x60
 [<c04ca0e7>] ? sysfs_find_dirent+0x16/0x27
 [<c04ca239>] sysfs_add_one+0x2a/0x36
 [<c04ca6d6>] create_dir+0x43/0x68
 [<c04ca728>] sysfs_create_dir+0x2d/0x41
 [<c0501185>] kobject_add_internal+0xb2/0x153
 [<c05012d1>] kobject_add_varg+0x35/0x41
 [<c05012fd>] kobject_init_and_add+0x20/0x22
 [<c050f172>] pci_create_slot+0x93/0xe1
 [<c054a3a8>] register_slot+0x14f/0x1e7
 [<c043e958>] ? up+0x2b/0x2f
 [<c053b99e>] acpi_ns_walk_namespace+0x9a/0x110
 [<c053a271>] acpi_walk_namespace+0x46/0x66
 [<c054a259>] ? register_slot+0x0/0x1e7
 [<c054a228>] walk_p2p_bridge+0xb7/0xe8
 [<c054a259>] ? register_slot+0x0/0x1e7
 [<c054a259>] ? register_slot+0x0/0x1e7
 [<c054a259>] ? register_slot+0x0/0x1e7
 [<c053b99e>] acpi_ns_walk_namespace+0x9a/0x110
 [<c053a271>] acpi_walk_namespace+0x46/0x66
 [<c054a171>] ? walk_p2p_bridge+0x0/0xe8
 [<c054a124>] acpi_pci_slot_add+0x10d/0x15a
 [<c054a171>] ? walk_p2p_bridge+0x0/0xe8
 [<c054a259>] ? register_slot+0x0/0x1e7
 [<c0548901>] acpi_pci_register_driver+0x39/0x50
 [<c079f5f6>] acpi_pci_slot_init+0x17/0x1b
 [<c0401125>] _stext+0x3d/0x115
 [<c079f5df>] ? acpi_pci_slot_init+0x0/0x1b
 [<c0463028>] ? register_irq_proc+0x92/0xae
 [<c0463081>] ? init_irq_proc+0x3d/0x4a
 [<c077e362>] kernel_init+0x177/0x1c5
 [<c077e1eb>] ? kernel_init+0x0/0x1c5
 [<c040494b>] kernel_thread_helper+0x7/0x10
 =======================
---[ end trace a7919e7f17c0a725 ]---
kobject_add_internal failed for 1 with -EEXIST, don't try to register things with the same name in the same directory.
Pid: 1, comm: swapper Tainted: G        W 2.6.27.5-37.fc9.i686 #1
 [<c0501214>] kobject_add_internal+0x141/0x153
 [<c05012d1>] kobject_add_varg+0x35/0x41
 [<c05012fd>] kobject_init_and_add+0x20/0x22
 [<c050f172>] pci_create_slot+0x93/0xe1
 [<c054a3a8>] register_slot+0x14f/0x1e7
 [<c043e958>] ? up+0x2b/0x2f
 [<c053b99e>] acpi_ns_walk_namespace+0x9a/0x110
 [<c053a271>] acpi_walk_namespace+0x46/0x66
 [<c054a259>] ? register_slot+0x0/0x1e7
 [<c054a228>] walk_p2p_bridge+0xb7/0xe8
 [<c054a259>] ? register_slot+0x0/0x1e7
 [<c054a259>] ? register_slot+0x0/0x1e7
 [<c054a259>] ? register_slot+0x0/0x1e7
 [<c053b99e>] acpi_ns_walk_namespace+0x9a/0x110
 [<c053a271>] acpi_walk_namespace+0x46/0x66
 [<c054a171>] ? walk_p2p_bridge+0x0/0xe8
 [<c054a124>] acpi_pci_slot_add+0x10d/0x15a
 [<c054a171>] ? walk_p2p_bridge+0x0/0xe8
 [<c054a259>] ? register_slot+0x0/0x1e7
 [<c0548901>] acpi_pci_register_driver+0x39/0x50
 [<c079f5f6>] acpi_pci_slot_init+0x17/0x1b
 [<c0401125>] _stext+0x3d/0x115
 [<c079f5df>] ? acpi_pci_slot_init+0x0/0x1b
 [<c0463028>] ? register_irq_proc+0x92/0xae
 [<c0463081>] ? init_irq_proc+0x3d/0x4a
 [<c077e362>] kernel_init+0x177/0x1c5
 [<c077e1eb>] ? kernel_init+0x0/0x1c5
 [<c040494b>] kernel_thread_helper+0x7/0x10
 =======================
Unable to register kobject 1
pci_slot: pci_create_slot returned -17
==============================================

I can't reproduce this with same kernel on our server, using x86_64...
Comment 4 Matthew Garrett 2008-11-17 09:11:13 EST
*** Bug 471653 has been marked as a duplicate of this bug. ***
Comment 5 Jeffrey Moyer 2008-11-17 10:52:30 EST

*** This bug has been marked as a duplicate of bug 470421 ***

Note You need to log in before you can comment on or make changes to this bug.