Bug 471793 - Description of Flash plug-in has room for improvement
Description of Flash plug-in has room for improvement
Status: CLOSED UPSTREAM
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2008-11-16 08:06 EST by Mads Kiilerich
Modified: 2008-11-21 00:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 00:03:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2008-11-16 08:06:09 EST
The description on http://docs.fedoraproject.org/release-notes/f10preview/en_US/What_is_the_Latest_on_the_Desktop.html#sn-Web_browsers is correct but is hard to read.

* Flash 10 is common now, and the documentation should reflect and have flash 9 as the special case.

* There two primary but different cases: i386 and x86_64


I suggest the following structure (not necessarily this wording/spelling):


The Adobe Flash Player plug-in version 10 on Fedora i386 has no special requirements.

The Adobe Flash Player plug-in version 10 on Fedora x86_64 requires the nspluginwrapper.i386 package to enable the 32-bit Adobe Flash Player plug-in in Firefox, and the libflashsupport.i386 package to enable sound from the plug-in:

	su -c 'yum install nspluginwrapper.i386 nspluginwrapper.x86_64 libflashsupport.i386'

The Adobe Flash Player plugin version 9 used the legacy sound framework ALSA and requires additional support from libflashsupport to work correctly, also on i386:

      su -c 'yum install libflashsupport'
      
If you install nspluginwrapper then it will install wrappers for all existing plug-ins at that time. To install wrappers for plug-ins installed after nspluginwrapper run:

	su -c 'mozilla-plugin-config -i -g -v'

Close all Firefox windows, and then relaunch Firefox. Type about:plugins in the URL bar to ensure the plugin is loaded.
Comment 1 drago01 2008-11-16 12:51:31 EST
libflashsupport isn't required/needed on x86_64 too.
Comment 2 Scott Robbins 2008-11-16 14:07:32 EST
As per discussion with Mads on the testing list, I did the following on an X86_64 system.

Uninstalled firefox, opera, nspluginwrapper, libflashsupport and flash-plugin and removed my ~/.mozilla and ~/.opera directories.

Reinstall opera and firefox, 64 bit versions.  As expected, no plugins shown.

Reinstalled flash-plugin.  At this point, opera shows flash installed and works, including sound.  Firefox shows nothing.

Reinstalled nspluginwrapper, both i386 and x86_64.  At this point, with no further user intervention, Firefox also shows plugin and works with sound. 

(Out of curiosity, did a yum search for libflashsupport and got the message that there are no matching package.) 

So, the documentation should be updated to reflect that a) libflashsupport is no longer necessary and b) that it is also no longer necessary to run mozilla-plugin-config.  (As the section is called browsers, it might be worthwhile adding that opera doesn't require nspluginwrapper.)
Comment 3 Ignacio Vazquez-Abrams 2008-11-16 20:15:12 EST
The issue is that the release notes need to direct the user to install alsa-lib.i386 and alsa-plugins-pulseaudio.i386 instead.
Comment 4 Mads Kiilerich 2008-11-16 20:31:03 EST
And libflashsupport has just been removed completely.

So apparently flash 9 isn't supported in F10 at all and the lines about it can be removed.

And other references to it should be removed too.
Comment 5 Scott Robbins 2008-11-16 21:34:32 EST
Just to further confuse the issue, I've uninstalled alsa-plugins-pulseaudio (on both x86 and x86_64) as it tends to break sound for me.  So I'm not positive that one is a good idea.  

The important thing, I think, is to take out the libflashsupport section.  Otherwise, the new user will try to download it as per the official instructions, and find it doesn't exist.
Comment 6 Scott Robbins 2008-11-17 10:34:44 EST
Ok, to further obfuscate the issue, Adobe has released a 64 bit flash player.  This works without problem for myself and, as noted on Fedora forums, for many others.  It's only in alpha stage at present, but is working perfectly. 

(It's a tarball that can be downloaded at 

http://labs.adobe.com/downloads/flashplayer10.html

When untarred, it's just a libflashplayer.so
After removing flash-plugin and nspluginwrapper,
copying it into /usr/lib64/mozilla/plugins worked perfectly. 

Perhaps the release notes should reflect this possibility as well.

The main issue, in my opinion, are the newcomers.  The experienced user will probably be familiar with the various resources that give specific instructions to install Flash on 64 bit Fedora.
Comment 7 Scott Robbins 2008-11-17 12:03:26 EST
Further comments on Fedora forums show that removing nspluginwrapper can interefere with SELinux.  However, leaving nspluginwrapper (both 32 and 64 bit versions) seem to cause no problems with the 64 bit flash plugin.)

So, my post above should have said, rather than removing flash-plugin and nswrapper, just 
remove flash-plugin

Thanks
Comment 8 Paul W. Frields 2008-11-17 13:01:36 EST
The nspluginwrapper issues with SELinux can be "resolved" by changing the appropriate SELinux boolean:

# setsebool -P allow_unconfined_nsplugin_transition=0

I don't know if this is really a behavior to recommend since it essentially opens the user to all sorts of mischief via nspluginwrapped code.  But certainly it's preferable to setting SELinux to disabled or permissive globally, which is one of the "solutions" I've seen in the forums.

Do we really want to recommend alpha software?  I suppose we could note its existence regardless.
Comment 9 drago01 2008-11-17 13:14:37 EST
(In reply to comment #8)
> The nspluginwrapper issues with SELinux can be "resolved" by changing the
> appropriate SELinux boolean:
> 
> # setsebool -P allow_unconfined_nsplugin_transition=0
> 
> I don't know if this is really a behavior to recommend since it essentially
> opens the user to all sorts of mischief via nspluginwrapped code.  But
> certainly it's preferable to setting SELinux to disabled or permissive
> globally, which is one of the "solutions" I've seen in the forums.
> 
> Do we really want to recommend alpha software?  I suppose we could note its
> existence regardless.

It's easier to just prevent it from being wrapped by editing /etc/sysconfig/nspluginwrapper
Comment 10 Ignacio Vazquez-Abrams 2008-11-17 13:31:21 EST
(In reply to comment #8)
> Do we really want to recommend alpha software?  I suppose we could note its
> existence regardless.

I do think it deserves a footnote (or perhaps we should change the notes to read "32-bit version of the Flash plugin"), but recommending it is probably not the best idea.
Comment 11 John J. McDonough 2008-11-18 10:48:39 EST
I thought I would walk through the process before writing about it, so I installed a fresh i686 preview, typed about:plugins and found nspluginwrapper already installed.  I thought from the earlier comments that this needed to be manually installed and only on X86_64.

Went to YouTube, and clicked on the Install the latest flash link.  After selecting "YUM" for the "version to install", I got the message 'Method "InstallFiles" with signature "bas" on interface "org.freedesktop.PackageKit.Transaction" doesn't exist'

I was able to install the RPM for the Adobe repo manually, then when attempting to install Adobe Flash Player 10 with PackageKit I got the following message: 'Method "InstallSignature" with signature "sss" on interface "org.freedesktop.PackageKit.Transaction" doesn't exist'

A second attempt to install the player with PackageKit succeeded.

Once installed the player worked fine.  Note that the preview had not been updated when I did all this.  After a yum update the player continued to work correctly.
Comment 12 John J. McDonough 2008-11-18 14:05:37 EST
Duplicated Scott Robbins sequence on X86_64 except for Opera.  No sound.  I noticed my logon sound was a lot quieter than 32 bit, and this isn't a fresh install, so I'll try a fresh install after the meeting.
Comment 13 Paul W. Frields 2008-11-18 21:40:13 EST
If I remember correctly, you need alsa-plugins-pulseaudio.i386 installed on x86_64 if you're using the 32-bit plugin on Fedora x86_64.  If you're using the 64-bit plugin?  I'm not sure, but you could make sure alsa-plugins-pulseaudio.x86_64 is installed first, and if that doesn't work try the i386 package too in case the 64-bit version was compiled against it.
Comment 14 Paul W. Frields 2008-11-18 21:41:36 EST
Sorry, please disregard my comment above -- I got confused about who had done what, when, and to which.  :-)
Comment 15 John J. McDonough 2008-11-19 09:33:48 EST
Paul had the secret!

I have placed some proposed prose at:

https://fedoraproject.org/wiki/User:Jjmcd/Drafts/Flash
Comment 16 Mads Kiilerich 2008-11-19 10:05:40 EST
John, nice!

I think Comment #3 still applies: alsa-plugins-pulseaudio.i386 (and thus alsa-lib.i386) is required on i386 too.

(The current nspluginwrapper with flash 10 sometimes gives troubles on i386 - uninstalling/disabling it sometimes helps. But I don't know if that should be mentioned here. Perhaps as a known issue. If it is considered known...)

The comment about X86_64 yum and firefox restart (and checking plugin) applies just as much to i386. Better make a general description convering both.

As I understand it nspluginwrapper.x86_64 is needed too (but perhaps usually already installed). Hopefully someone who _know_ will correct me?

And better say explicit that the X86 description is for using the 32 bit plugin. (To avoid confusion the 64 bit plugin should be mentioned (but not necessarily recommended) in a comment. See Comment #10)
Comment 17 John J. McDonough 2008-11-19 10:41:57 EST
Good comments.  I apparently had alsa-plugin-pulseaudio already installed.

It appears to me that you can't avoid nspluginwrapper.x86_64. That kind of bothered me.  At one point I uninstalled it and Firefox, then reinstalled Firefox.  Yum did not show the wrapper as a dependency, but after FF was installed it was there.  Makes me wonder whether is it in the FF package, although maybe I just didn't get it installed.
Comment 18 Karsten Wade 2008-11-19 11:31:11 EST
Paul brought McD's page to a few people this morning (Bill Nottingham, Warren Togami).  Warren's concern is that anything we write today may be incorrect in a week, and need regular updates along the way.  The situation is in such flux that we thought instead, let's link to a wiki page that Warren et al can update:

http://fedoraproject.org/wiki/Flash#Fedora_10

(That is, let's create a Flash page and a == Fedora 10 == section.)

Then populate it with what McD has written so far, add [[Category:Documentation]] to it, and let Warren take it from there.

(Warren Cc:'d so he can see the flow from here.)

Warren -- I changed up the page name to be more generically useful.
Comment 19 John J. McDonough 2008-11-19 11:49:51 EST
Sounds like a good plan -- there are several places where we need to do things like that.
Comment 20 Scott Robbins 2008-11-19 19:06:20 EST
The alsa-plugins-pulseaudio.i386 has not been a requirement for me. In fact, I always remove it as it seems to cause problems with sound for those who don't run Gnome.  

(I also don't use pulse audio, which probably has something to do with it.)  :)
Comment 21 Ignacio Vazquez-Abrams 2008-11-19 19:19:49 EST
Nonetheless, the default install uses PulseAudio, therefore the "default" documentation should accommodate it.
Comment 22 Tom Diehl 2008-11-19 21:04:32 EST
+1 to comment 21. If that info was in the docs it would have saved me about 6+ hours of frustration.
Comment 23 Paul W. Frields 2008-11-21 00:03:14 EST
I didn't see any content here:

http://fedoraproject.org/wiki/Flash#Fedora_10

So I moved in the information from the draft into this page, combined it with the small bit of relevant data that was at Multimedia/Flash (redirecting that page to the new one) and created the relevant content in the Release Notes.

http://git.fedorahosted.org/git/docs/release-notes?p=docs/release-notes.git;a=commit;h=8300e2909469284031f62e7c49a146ec69bdf947

Note You need to log in before you can comment on or make changes to this bug.