Bug 471865 - EMU10K1 mixer routing is broken
EMU10K1 mixer routing is broken
Status: CLOSED DUPLICATE of bug 478604
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 05:38 EST by Steve Hill
Modified: 2009-06-20 11:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-20 11:06:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Hill 2008-11-17 05:38:05 EST
Description of problem:
The EMU10K1 mixer routing is rather broken on the SB Live Value - the "Master" mixer channel only controls the front speakers, leaving the rear speakers to be controlled by the "Surround" channel.  Similarly, the PCM channel only controls the front channels - surely this should control *all* the PCM channels?


Version-Release number of selected component (if applicable):
alsa-lib-1.0.18-6.rc3.fc10.i386
alsa-utils-1.0.18-3.rc3.fc10.i386
kernel-2.6.27.4-79.fc10.i686

How reproducible:
Always

Steps to Reproduce:
1. Install rawhide on a machine with a SB Live Value sound card
2. Observe the mixer channels don't control what you expect
  
Actual results:
The "Master" mixer channel only controls the front speakers.
The "PCM" mixer channel only controls the front PCM channels.
There is no mixer channel that controls all the channels.

Expected results:
The "Master" mixer channel should control all the speakers.
The "PCM" mixer channel should control all the PCM channels.
There should be an additional "Front" mixer channel to control the front speakers.

Additional info:
Comment 1 Bug Zapper 2008-11-26 00:30:33 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 John Thacker 2009-06-20 11:06:24 EDT
This is a duplicate of 478604.

*** This bug has been marked as a duplicate of bug 478604 ***

Note You need to log in before you can comment on or make changes to this bug.