Bug 478604 - emu10k1: "Master" slider should be name "Front" because it only controls Front L+R.
emu10k1: "Master" slider should be name "Front" because it only controls Fron...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
: 471865 527134 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-01 18:18 EST by Eddie Lania
Modified: 2011-04-14 04:50 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-12 07:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eddie Lania 2009-01-01 18:18:45 EST
Description of problem: Pulseaudio only sees the front 2 speakers of the emu10k1 - the workaround for this is to add "default-sample-channels = 4" to
/etc/pulse/daemon.conf, but this changes the number of channels seen on
all the other sound cards in the machine too, which may not be what you
want.
"aplay -L" does list a 4 channel "surround40:CARD=Live,DEV=0"
subdevice - if we can't reliably auto-select the right subdevice, how
about at least letting the user select it from the GUI?

The EMU10K1 mixer routing is rather broken - the "Master" mixer channel only controls the front speakers, leaving the rear speakers to be controlled by the "Surround" channel. Thus the "Master" channel should really be renamed to "Front" and a real "Master" channel that controls everything should be added. It is a bit of a pain having to adjust 2 channels at the same time in order to change the volume. Similarly, the PCM channel only controls the front channels - surely this should control *all* the PCM channels? And this also is the same for the wave channels.


Version-Release number of selected component (if applicable):

rpm -qa |grep pulse
pulseaudio-esound-compat-0.9.13-6.fc10.i386
pulseaudio-libs-0.9.13-6.fc10.i386
pulseaudio-libs-glib2-0.9.13-6.fc10.i386
xine-lib-pulseaudio-1.1.15-3.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
pulseaudio-utils-0.9.13-6.fc10.i386
pulseaudio-core-libs-0.9.13-6.fc10.i386
pulseaudio-module-gconf-0.9.13-6.fc10.i386
pulseaudio-module-x11-0.9.13-6.fc10.i386
pulseaudio-libs-zeroconf-0.9.13-6.fc10.i386
akode-pulseaudio-2.0.2-5.fc9.i386
pulseaudio-0.9.13-6.fc10.i386
pulseaudio-module-zeroconf-0.9.13-6.fc10.i386

rpm -qa |grep alsa
alsa-plugins-upmix-1.0.18-2.fc10.i386
alsa-lib-devel-1.0.18-6.rc3.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
alsa-lib-1.0.18-6.rc3.fc10.i386
alsa-utils-1.0.18-6.fc10.i386
python-alsaaudio-0.3-1.fc9.i386


How reproducible:
Install a Creative SB Live 5.1 card with EMU10k1 chip.

Steps to Reproduce:
1. See the explanation above.
2.
3.
  
Actual results:
the "Master" mixer channel only controls the front speakers, the PCM channel only controls the front channels - surely this should control *all* the PCM channels? And this also is the same for the wave channels.

Expected results:

For front and rear speakers, the "master volume" should be able to control all. And "PCM" and "Wave" should control the PCM and Wave levels.


Additional info:
Comment 1 Eddie Lania 2009-01-06 14:40:06 EST
When I right-click the volume icon on the panel and choose "preferences", I get the "Volume Control Preferences" and I can set multiple "tracks" to control with the volume control slider at once by clicking on them while holding down the control button.

So I choose "master", "surround" and "wave surround". After that I click "Close" and it gets saved.

Now, when I single click the volume icon on the panel and move the volume slider up and down with the mouse, all choosen tracks are moved up and down simultaniously.

However, later if I use the volume "up" and "down" buttons on my keyboard they only control the master volume track.

The keyboard shortcuts can be set with the gnome-keybinding-properties utility.

Volume mute: XF86Audiomute
Volume down: XF86AudioLowerVolume
Volume up:   XF86AudioRaiseVolume

It doesn't make much sence to set multiple "tracks" to control with the volume control slider in the "Volume Control Preferences" while this still doesn't enable you to control these tracks with the volume buttons on the keyboard.

Kind regards,

Eddie.
Comment 2 Eddie Lania 2009-01-06 16:28:36 EST
I found out that for the keyboard shortcuts that can be set with the gnome-keybinding-properties utility to use the "mute", "up" and "down" volume keys on the keyboard, the to be controlled tracks can be selected in the same manner in the gnome-sound-properties utility as I described in my previous comment about the "Volume Control Preferences".

In both the utilities it is important to first select the wright mixer device and second to select the various tracks to be controlled. You can choose multiple tracks by right-clicking the tracks while holding down the control key on the keyboard.

Your choices will be automatically saved when closing the utility.


I guess this will solve almost all the issues as I described them when I submitted this bug leaving open only the question why the user cannot select the number of speakers that he/she would like to use on his/her soundcard (if this is not yet covered somewhere alse in some sort of gnome utility).

I am amazed about the poor amount of information I found about all this stuff (after googeling a lot of time) but that doesn't border me as long as its working in the end.

Regards,

Eddie.
Comment 3 Eddie Lania 2009-01-07 03:24:39 EST
The gnome-sound-properties session can set the Default mixer tracks to be controlled for the alsa-mixer device. You can set multiple tracks to be controlled. But if I choose the pulseaudio mixer device it only controls one (the master) track.

So I did some more testing:

When I use the pulseaudio volume control to control volume for an individual application,I can clearly see and hear that the volume levels of the front and rear (surround) speakers are not equally changed.

If I lower the volume for an application using the pulseaudio volume control, the sound level of the front speakers drops more rapidly then that from the rear speakers. And when I raise the volume it is exactly the opposite.


And one more thing: When I use the alsa-mixer to raise or lower the volume of the PCM or Wave track then it only controls the front speakers. One should not want to change the settings anymore once they're set.


So, after all my research and applying all the settings for the volume control that I described in this bug so far, I now come to the conclusion that the perfect volume control is not yet possible.

The bug remains as it is.
Comment 4 Eddie Lania 2009-05-13 13:36:51 EDT
I am on Fedora 11 now and still have the problem that when I use the pulseaudio volume control to control volume for an individual application,I can clearly see and hear that the volume levels of the front and rear (surround) speakers are not equally changed.

If I lower the volume for an application using the pulseaudio volume control,
the sound level of the front speakers drops more rapidly then that from the
rear speakers. And when I raise the volume it is exactly the opposite.

Apart from that, volume control seems to do a nice job now.

Good work.

Regards,

Eddie.
Comment 5 John Thacker 2009-06-20 11:06:24 EDT
*** Bug 471865 has been marked as a duplicate of this bug. ***
Comment 6 Eddie Lania 2009-10-05 13:34:42 EDT
I am still having the same problems with volume control. when I use the pulseaudio
volume control to control volume for an individual application,I can clearly
see and hear that the volume levels of the front and rear (surround) speakers
are not equally changed. Only the master level is changed, which unfortunate does not control surround and wav surround channels on the emu10k1. and like in F10, there is no way to control them all together. In F10 When I right-click the volume icon on the panel and choose "preferences", I get
the "Volume Control Preferences" and I can set multiple "tracks" to control
with the volume control slider at once by clicking on them while holding down
the control button.

So I choose "master", "surround" and "wave surround". After that I click
"Close" and it gets saved.

Now, when I single click the volume icon on the panel and move the volume
slider up and down with the mouse, all chosen tracks are moved up and down
simultaneously.

But this is not possible anymore.

Different sound sources (wave, mp3, avi, mpeg, etc) have different volume gains and so one needs to constantly balance the level from the surround channels against the master level.

This is very inconvenient, I hope that it will be possible to fix it in the future. Or is the EMU10K1 being dropped from the list of supported hardware?
Comment 7 Eddie Lania 2009-10-11 12:32:59 EDT
The silence here is more frustrating to me then an angry developer throwing mud in to my face.

Can somebody give an update on the status of this bug? is there somebody working on it or can we aspect somebody to pick this up and start working on it shortly?

Or is it to complex to solve?

Regards,

Eddie.
Comment 8 Lennart Poettering 2009-10-12 18:32:43 EDT
*** Bug 527134 has been marked as a duplicate of this bug. ***
Comment 9 Lennart Poettering 2009-10-23 14:57:36 EDT
What exactly is this bug about?

That "Master" not actually acts as "Master" but should be named "Front"? That's a bug in the audio driver and should be assigned to the kernel then.

That the multichannel profiles were not autodetected in F10? That's not surprising since they are new in F11.

In anyway, I am not sure where there is actually something wrong in PA?
Comment 10 Eddie Lania 2009-10-23 15:57:27 EDT
Dear Lennart,

I am sorry to have bothered you with this issue but I really don't know where to put this problem elsewhere.

I am just a stupid end-user and most certainly do not know who is responsible for this routing thing with this emu10k1 driver thing. Whether it's related to alsa, pulseaudio or kernel, I really don't know. I wish I did.

I only am the one having this problem and submitted the bug hoping that  can solve it, that's all. That's the only skill I have.

Please don't blame me for doing that. I thought that this bugzilla page was intended to use for such purpose. And, if you don't even know where it should be assigned to, then I most certainly do know it even less.

Now I guess after all I am disappointed about the fact that this bug report has been here since 2009-01-01 and still no-one has cared about it.

Being a developer will probably not always be easy but being an end-user isn't always either.

So, once again, sorry, but I still hope that maybe you ore somebody else might be able to help me. Maybe you can help getting this assigned to the right place or person?

Thank you.

Regards,

Eddie.
Comment 11 Lennart Poettering 2009-10-23 16:13:31 EDT
(In reply to comment #10)

> Now I guess after all I am disappointed about the fact that this bug report has
> been here since 2009-01-01 and still no-one has cared about it.

We are thankful for incoming bug reports. However, we have limited manpower, so we need to priorize things. Now, emu10k1 is a driver that is written without much support from Creative Labs, so a particularly hard one to maintain and fix. In fact, Creative Labs is pretty much an anti-open-source company, so the interest and enthusiasm in fixing things on our side might not be the highest, especially since we are not payed for supporting emu10k1. So please, be patient (or provide the fix yourself!).

Anyway, reassigning to the kernel, since the mislabelling is a kernel driver problem.
Comment 12 Eddie Lania 2009-11-27 13:30:17 EST
I upgraded from F11 to F12.

The weird behavior of volume control is still present and has become even worse.

And now the default volume level also is very VERY loud (compared to F11).

If I lower the volume using the volume slider, the sound level of the front speakers is lowering according to the slider's movement, but the volume of the surround (rear) speakers is not changing any sooner until I almost reach the lowest level (close to silent) with the volume slider.

Also, changing the levels of the "PCM Surround" and "Wave Surround" volume sliders using "alsa-mixer -c0" are not very usable anymore. These levels are constantly automatically moving up to 100% whenever I change the master volume either up or down.

This change in F12 is not very good, sounds become distorted frequently because of the over-modulated volume level and I worry that it might become damaging to my speakers system as well.

I hope this can be changed soon.

With kind regards,

Eddie.
Comment 13 Gerard Barker 2010-03-23 08:48:54 EDT
(In reply to comment #0)
> Description of problem: Pulseaudio only sees the front 2 speakers of the
> emu10k1 - the workaround for this is to add "default-sample-channels = 4" to
> /etc/pulse/daemon.conf, but this changes the number of channels seen on
> all the other sound cards in the machine too, which may not be what you
> want.
> "aplay -L" does list a 4 channel "surround40:CARD=Live,DEV=0"
> subdevice - if we can't reliably auto-select the right subdevice, how
> about at least letting the user select it from the GUI?
> 
> The EMU10K1 mixer routing is rather broken - the "Master" mixer channel only
> controls the front speakers, leaving the rear speakers to be controlled by the
> "Surround" channel. Thus the "Master" channel should really be renamed to
> "Front" and a real "Master" channel that controls everything should be added.
> It is a bit of a pain having to adjust 2 channels at the same time in order to
> change the volume. Similarly, the PCM channel only controls the front channels
> - surely this should control *all* the PCM channels? And this also is the same
> for the wave channels.
> 
> 
> Version-Release number of selected component (if applicable):
> 
> rpm -qa |grep pulse
> pulseaudio-esound-compat-0.9.13-6.fc10.i386
> pulseaudio-libs-0.9.13-6.fc10.i386
> pulseaudio-libs-glib2-0.9.13-6.fc10.i386
> xine-lib-pulseaudio-1.1.15-3.fc10.i386
> alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
> pulseaudio-utils-0.9.13-6.fc10.i386
> pulseaudio-core-libs-0.9.13-6.fc10.i386
> pulseaudio-module-gconf-0.9.13-6.fc10.i386
> pulseaudio-module-x11-0.9.13-6.fc10.i386
> pulseaudio-libs-zeroconf-0.9.13-6.fc10.i386
> akode-pulseaudio-2.0.2-5.fc9.i386
> pulseaudio-0.9.13-6.fc10.i386
> pulseaudio-module-zeroconf-0.9.13-6.fc10.i386
> 
> rpm -qa |grep alsa
> alsa-plugins-upmix-1.0.18-2.fc10.i386
> alsa-lib-devel-1.0.18-6.rc3.fc10.i386
> alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
> alsa-lib-1.0.18-6.rc3.fc10.i386
> alsa-utils-1.0.18-6.fc10.i386
> python-alsaaudio-0.3-1.fc9.i386
> 
> 
> How reproducible:
> Install a Creative SB Live 5.1 card with EMU10k1 chip.
> 
> Steps to Reproduce:
> 1. See the explanation above.
> 2.
> 3.
> 
> Actual results:
> the "Master" mixer channel only controls the front speakers, the PCM channel
> only controls the front channels - surely this should control *all* the PCM
> channels? And this also is the same for the wave channels.
> 
> Expected results:
> 
> For front and rear speakers, the "master volume" should be able to control all.
> And "PCM" and "Wave" should control the PCM and Wave levels.
> 
> 
> Additional info:    

I am finding that the application linking in Sound Preferences is causing the rear speaker front speaker balance slider to in fact, turn down the volume of the application playing / using pulseaudio e.g. Rhythmbox.  This would imply that the volume of the application is being linked incorrectly with the volume of the rear speakers in surround sound circumstances such as mine which is 5.1 (6 channels).

Maybe the developers could look into the Sound Preferences application as the same problem also occurs in pavucontrol, I feel that this needs to be looked at in pavucontrol application as well.  It seems to be something to do with the linking with applications' volume control settings which used to be independent of the master volume or the pcm volume settings.

With thanks,

Gerard.
Comment 14 Eddie Lania 2010-06-15 14:41:21 EDT
I am on F13 now and it still hasn't changed.
Comment 15 Eddie Lania 2010-11-26 14:42:04 EST
This bug has been left open here for almost two years now and I am wondering if there is any use in keeping it open much longer, since no one seems to care much about it.

Can anyone answer on this please?

My best regards,

Eddie.
Comment 16 Steve Hill 2010-11-29 04:43:52 EST
Yes, it should be left open because it is still an unfixed bug.
Comment 17 Eddie Lania 2010-11-29 12:49:54 EST
Lennart,

I would like to try to make a profile for the emu10k1 card in /usr/share/pulseaudio.

But I am not sure how to set this up.

I tried it once before and did have it almost working perfectly but later my custom profile was overwritten by a pulseaudio package update. I think it was because I just edited the existing files there.

Can you give me a hint on where I should start and explain a little about how the files in /usr/share/pulseaudio/alsa-mixer/paths and /usr/share/pulseaudio/alsa-mixer/profiles hang together?

Should I start with a couple of new files there?

Regards,

Eddie.
Comment 18 Eddie Lania 2010-12-01 11:30:57 EST
I created a file called emu10k1.conf in /usr/share/pulseaudio/alsa-mixer/profiles in which i try to make PA read emu10k1-analog-output.conf in the paths directory.

But it doesn't work yet.

What does there need to be done to make PA read the emu10k1.conf instead of the default.conf?
Comment 19 Eddie Lania 2010-12-05 17:35:52 EST
I created a file called emu10k1.conf in
/usr/share/pulseaudio/alsa-mixer/profiles.

But it doesn't work.

What does there need to be done to make PA read the emu10k1.conf instead of the
default.conf in profiles?
Can somebody please tell me?
Comment 20 Kyle McMartin 2010-12-09 15:35:34 EST
Eddie, please file a separate bug about pulseaudio being unable to read your added profile.

regards, Kyle
Comment 21 Eddie Lania 2010-12-10 10:06:55 EST
Okay Kyle, I created https://bugzilla.redhat.com/show_bug.cgi?id=662074 for that issue.

regards,

Eddie.
Comment 22 Eddie Lania 2011-04-07 14:00:34 EDT
I gave up the emu10k1 and bought a new system with intel hd audio onboard. In windows this card does perfectly multichannel audio.

So i thought this would finally solve my multichannel audio problem in linux.

but what do you think? IT DOESN'T WORK EITHER!!!!!!!!!!!

It doesn't even provide me with an option to enable surround

So, now I also can forget about 4.1 surround audio and throw away my surround speakers as well!

I feel pretty much screwed!
Comment 23 Steve Hill 2011-04-12 07:38:12 EDT
You're going to have to explain why this has been WONTFIXed.  The EMU10K1 mixer has been broken since the OSS driver was dropped.
Comment 24 Eddie Lania 2011-04-12 13:54:50 EDT
Because, after waiting for more than two years for a solution, I think it's pretty much clear that it will never be solved.
If you want this bug to be left open for another two years please feel free to do so.
But I don't want to have it on my bug list any longer.

Sorry.
Comment 25 Raymond 2011-04-14 04:50:50 EDT
it would be great if you can confirm  whether your SB Live! 5.1 can play sound 
using front , rear and center_lfe

speaker-test -d -c 2 -t wav -Dfront:0

speaker-test -d -c 2 -t wav -Drear:0

speaker-test -d -c 2 -t wav -Dcenter_lfe:0

speaker-test -d -c 4 -t wav -Dsurround40:0

speaker-test -d -c 6 -t wav -Dsurround51:0



http://thread.gmane.org/gmane.linux.alsa.devel/84025

Note You need to log in before you can comment on or make changes to this bug.