Bug 471872 - tor-lsb post scriplet fails
tor-lsb post scriplet fails
Status: CLOSED DUPLICATE of bug 375361
Product: Fedora
Classification: Fedora
Component: tor (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 07:09 EST by Jonathan Underwood
Modified: 2008-11-17 10:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 10:34:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2008-11-17 07:09:51 EST
Description of problem:
The post scriplet in the subpackage tor-lsb fails - example yum session cut and pasted below.

Aside: the tor version currently packaged is very old, perhaps an update to the 0.2 release is in order.



# yum install tor
Loaded plugins: dellsysidplugin, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * updates-newkey: www.mirrorservice.org
 * livna: rpm.livna.org
 * fedora: www.mirrorservice.org
 * rpmfusion-free-updates: rpmfusion.famillecollet.com
 * rpmfusion-nonfree-updates: rpmfusion.famillecollet.com
 * rpmfusion-free: rpmfusion.famillecollet.com
 * rpmfusion-nonfree: rpmfusion.famillecollet.com
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package tor.x86_64 0:0.1.2.19-1.fc9 set to be updated
--> Processing Dependency: tor-lsb = 0.1.2.19-1.fc9 for package: tor
--> Processing Dependency: tor-core = 0.1.2.19-1.fc9 for package: tor
--> Running transaction check
---> Package tor-lsb.x86_64 0:0.1.2.19-1.fc9 set to be updated
--> Processing Dependency: lsb-core-noarch for package: tor-lsb
---> Package tor-core.x86_64 0:0.1.2.19-1.fc9 set to be updated
--> Running transaction check
---> Package redhat-lsb.x86_64 0:3.1-19.fc8 set to be updated
filelists.sqlite.bz2                                     | 7.0 MB     00:03     
filelists.sqlite.bz2                                     | 128 kB     00:00     
0d8e9f7819378b84d96dc7c4066c97f6eb0d5427-filelists.sqlit | 375 kB     00:00     
556592c2b96fda6389a17b39313899d4c3754d1a-filelists.sqlit |  49 kB     00:00     
--> Processing Dependency: /usr/bin/pax for package: redhat-lsb
--> Processing Dependency: /bin/gettext for package: redhat-lsb
--> Processing Dependency: /usr/bin/msgfmt for package: redhat-lsb
--> Running transaction check
---> Package pax.x86_64 0:3.4-5.fc9 set to be updated
---> Package gettext.x86_64 0:0.17-4.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch           Version                Repository      Size 
================================================================================
Installing:
 tor                x86_64         0.1.2.19-1.fc9         fedora          428 k
Installing for dependencies:
 gettext            x86_64         0.17-4.fc9             fedora          2.3 M
 pax                x86_64         3.4-5.fc9              fedora           64 k
 redhat-lsb         x86_64         3.1-19.fc8             fedora          251 k
 tor-core           x86_64         0.1.2.19-1.fc9         fedora          514 k
 tor-lsb            x86_64         0.1.2.19-1.fc9         fedora          8.8 k

Transaction Summary
================================================================================
Install      6 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 3.5 M
Is this ok [y/N]: y
Downloading Packages:
(1/6): tor-lsb-0.1.2.19-1.fc9.x86_64.rpm                 | 8.8 kB     00:00     
(2/6): pax-3.4-5.fc9.x86_64.rpm                          |  64 kB     00:00     
(3/6): redhat-lsb-3.1-19.fc8.x86_64.rpm                  | 251 kB     00:00     
(4/6): tor-0.1.2.19-1.fc9.x86_64.rpm                     | 428 kB     00:00     
(5/6): tor-core-0.1.2.19-1.fc9.x86_64.rpm                | 514 kB     00:00     
(6/6): gettext-0.17-4.fc9.x86_64.rpm                     | 2.3 MB     00:01     
--------------------------------------------------------------------------------
Total                                           618 kB/s | 3.5 MB     00:05     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : gettext                                           [1/6] 
  Installing     : pax                                               [2/6] 
  Installing     : redhat-lsb                                        [3/6] 
  Installing     : tor-core                                          [4/6] 
  Installing     : tor-lsb                                           [5/6] 
/var/tmp/rpm-tmp.68547: line 1: /usr/lib/lsb/install_initd: No such file or directory
error: %post(tor-lsb-0.1.2.19-1.fc9.x86_64) scriptlet failed, exit status 127
  Installing     : tor                                               [6/6] 

Installed: tor.x86_64 0:0.1.2.19-1.fc9
Dependency Installed: gettext.x86_64 0:0.17-4.fc9 pax.x86_64 0:3.4-5.fc9 redhat-lsb.x86_64 0:3.1-19.fc8 tor-core.x86_64 0:0.1.2.19-1.fc9 tor-lsb.x86_64 0:0.1.2.19-1.fc9
Complete!


Version-Release number of selected component (if applicable):
tor-0.1.2.19-1.fc9.x86_64
tor-lsb-0.1.2.19-1.fc9.x86_64
tor-core-0.1.2.19-1.fc9.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. yum install tor
2.
3.
  
Actual results:
tor-lsb post scriplet fails

Expected results:
tor-lsb post scriplet doesn't fail :)

Additional info:
Comment 1 Jonathan Underwood 2008-11-17 07:22:10 EST
Also:

# yum remove tor-core tor-lsb tor
Loaded plugins: dellsysidplugin, fastestmirror, refresh-packagekit
Setting up Remove Process
Loading mirror speeds from cached hostfile
 * updates-newkey: www.mirrorservice.org
 * livna: rpm.livna.org
 * fedora: www.mirrorservice.org
 * rpmfusion-free-updates: rpmfusion.famillecollet.com
 * rpmfusion-nonfree-updates: rpmfusion.famillecollet.com
 * rpmfusion-free: rpmfusion.famillecollet.com
 * rpmfusion-nonfree: rpmfusion.famillecollet.com
Resolving Dependencies
--> Running transaction check
---> Package tor-core.x86_64 0:0.1.2.19-1.fc9 set to be erased
---> Package tor-lsb.x86_64 0:0.1.2.19-1.fc9 set to be erased
---> Package tor.x86_64 0:0.1.2.19-1.fc9 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package          Arch           Version                Repository        Size 
================================================================================
Removing:
 tor              x86_64         0.1.2.19-1.fc9         installed         974 k
 tor-core         x86_64         0.1.2.19-1.fc9         installed         1.2 M
 tor-lsb          x86_64         0.1.2.19-1.fc9         installed         1.8 k

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       3 Package(s)         

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : tor                                               [1/3] 
  Erasing        : tor-core                                          [2/3] 
/var/tmp/rpm-tmp.43825: line 2: /usr/lib/lsb/remove_initd: No such file or directory

Removed: tor.x86_64 0:0.1.2.19-1.fc9 tor-core.x86_64 0:0.1.2.19-1.fc9 tor-lsb.x86_64 0:0.1.2.19-1.fc9
Complete!
Comment 2 Enrico Scholz 2008-11-17 10:34:14 EST

*** This bug has been marked as a duplicate of bug 375361 ***

Note You need to log in before you can comment on or make changes to this bug.