Bug 471973 - F10 preview boot fails on dell 510m with 855GM graphic card
F10 preview boot fails on dell 510m with 855GM graphic card
Status: CLOSED DUPLICATE of bug 461829
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 17:53 EST by danhouw
Modified: 2008-11-19 13:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-18 14:45:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg for Dell 510m running above F9 (27.75 KB, text/plain)
2008-11-17 17:58 EST, danhouw
no flags Details
Xorg config working for my F8 installation (1.14 KB, application/octet-stream)
2008-11-18 14:35 EST, danhouw
no flags Details
X Log for my F8 installation with X running fine (40.83 KB, application/octet-stream)
2008-11-18 14:36 EST, danhouw
no flags Details
X Log for my F10 in level 3 (14.30 KB, text/x-log)
2008-11-18 14:38 EST, danhouw
no flags Details
X Log for my F10 in level 5 trial (21.15 KB, text/x-log)
2008-11-18 14:38 EST, danhouw
no flags Details

  None (edit)
Description danhouw 2008-11-17 17:53:00 EST
The boot sequence of F10 preview works until it reach the notification of cups service starting. After this, the screen is blinking and no more service starts.
There is no more terminal control and no other solution than an "ctlr+alt+del" (twice).
No improvement with nomodeset parameter, or without rghb (tab dialog inside initial boot menu).

The failing F10 preview was tested as a live version from an usb device (livecd-iso-to-disk installation).
Otherwise, the F10 preview iso works well as a guest with virtualbox running on F8 host (I suppose due to virtual basic hardware from Vbox).
The F9 was also tested as a live usb and worked without any special setting.

My hardware is a Dell Laptop 510m with 855GM Intel graphic card which i suppose makes the trouble.

I deliver in attach a "dmesg" file for a working installation with F9 live usb.
Comment 1 danhouw 2008-11-17 17:58:24 EST
Created attachment 323814 [details]
Dmesg for Dell 510m running above F9
Comment 2 Charlie Brej 2008-11-18 06:27:28 EST
Cups is the last service started before X so this is probably a problem starting X.

Could you:
Boot into level 3 (add " 3 " to the kernel line)
Login and manually run "X"
If it fails then it is X.
They might appreciate a log: "X -verbose 1000000 2> xorg.log"

You can also become root and run "system-config-display --reconfig"
and then "init 5" which could fix the problem for you.
Comment 3 Ray Strode [halfline] 2008-11-18 09:34:51 EST
This sounds sort of like a duplicate of bug 471498

Would you mind updating to the latest version of plymouth and then running:

sudo /usr/libexec/plymouth/plymouth-update-initrd

to see if that fixes your problem?
Comment 4 danhouw 2008-11-18 14:31:57 EST
To Charlie Brej :
----------------
Fedora 10 Preview Live Usb booted fine in level 3.
But level 5 transition didn't work after startx or telinit 5 or init 5.

You can find the following attachments (obtained with command 'X -verbose):

- xorg.level3.log and xorg.level5.log files (for both levels) shows at line 267  
the following failure :
"EE) intel(0): Failed to pin front buffer: Cannot allocate memory Fatal server error: Couldn't bind memory for BO front buffer"
This is the last message during level 5 trial.

- xorg.level5.details.log file (obtained with option -verbose 1000000) shows at lines 445 and 557 the same failure with a more accurate context (GARTMemory):
"(II) intel(0): xf86BindGARTMemory: bind key 0 at 0x03924000 (pgoffset 14628)"
and
"(II) intel(0): xf86UnbindGARTMemory: unbind key 0"

Due to the fact that 'system-config-display' isn't available with F10 Preview Live Usb :
- I tried first the command 'X -configure' but with the same effect as above,
- I tried then to reuse inside my F10 usb the xorg.conf working fine that I copied from my F8 environment. But the 'X -config /root/xorg.conf' gived also the same effect.

For deeper comparison, you can also find in attachments :
- the xorg.conf,
- the (/var/log/)Xorg.0.log,
both from the F8 installation running 'fine' on the same hardware.
To be honnest, I discovered in line 637 of Xorg.0.log an hidden problem :
"intel(0): xf86AllocateGARTMemory: allocation of 10 pages failed (Cannot allocate memory)"

To Ray Strode :
--------------
I will soon answer after update (trial) of my Usb Live. I found no failure around selinux when booting F10 usb as discussed in bug 471498.
Comment 5 danhouw 2008-11-18 14:35:00 EST
Created attachment 323949 [details]
Xorg config working for my F8 installation
Comment 6 danhouw 2008-11-18 14:36:09 EST
Created attachment 323950 [details]
X Log for my F8 installation with X running fine
Comment 7 danhouw 2008-11-18 14:38:05 EST
Created attachment 323951 [details]
X Log for my F10 in level 3
Comment 8 danhouw 2008-11-18 14:38:50 EST
Created attachment 323952 [details]
X Log for my F10 in level 5 trial
Comment 9 Will Woods 2008-11-18 14:45:12 EST
i855GM had known problems in F10Preview.

*** This bug has been marked as a duplicate of bug 461829 ***
Comment 10 danhouw 2008-11-18 15:18:17 EST
To Ray Strode :
--------------
After 'yum update plymouth' in level 3 as you asked, I tried init 5 which gived on the screen :
- starting irqbalance service [on]
- starting portreserve service [on]

The terminal was unreadable because blinking again as before when I booted immediately from F10 live usb (default level 5).

You were also speaking about "portreserve" in bug 471498, so ...
Comment 11 Ray Strode [halfline] 2008-11-18 15:29:10 EST
Hi Dan,

I think if you upgrade your kernel and xorg-x11-drv-i810 packages then all of your issues should go away.
Comment 12 danhouw 2008-11-19 13:52:56 EST
To Ray Strode
-------------

I reinstalled the live usb F10 preview with an overlay (after forcing update of rpm livecd-tools form F9 into my F8 harddrive installation, this because the overlay option doesn't work with livecd-tools rpm delivered by the F8 repository).

Then, I upgraded the kernel and xorg i810 on the live usb F10 running in level 3.

And this time, the transition from level 3 to 5 showed a stable but black terminal screen without any info about service starting or something else. Good point : there is no more blinking effect. Hard shutdown was needed.

Note You need to log in before you can comment on or make changes to this bug.