Bug 472061 - webcollage screen saver displaying pornography
webcollage screen saver displaying pornography
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
: 472899 (view as bug list)
Depends On:
Blocks: 461926
  Show dependency treegraph
 
Reported: 2008-11-18 10:27 EST by Rex Dieter
Modified: 2012-08-04 04:54 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 01:22:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2008-11-18 10:27:32 EST
+++ This bug was initially created as a clone of Bug #461926 +++

Description of problem:
On a development machine I use KDE. I had the screensaver set to random. 

This morning I came back to that machine to find that the screensaver had kicked in and was running web collage. And the images being displayed were pornographic and very explicit. 

I do *not* browse porn sites on that machine, and it does not share any data with other machines and is used solely for testing code. 

Version-Release number of selected component (if applicable):
4.1.0-1.fc9

How reproducible:
Not sure how to get it to redisplay those images, but I would prefer that the app allow the user to decide what sites to visit rather than randomly downloading images.

--- Additional comment from rdieter@math.unl.edu on 2008-09-11 10:51:48 EDT ---

Ugh, this problem existed in kde3 (and we hacked around it), and I thought it was addressed in kde4.

--- Additional comment from smparrish@shallowcreek.net on 2008-09-28 17:12:30 EDT ---

Bumped the priority up.  Need to address this before Fedora gets a NC17 rating.

--- Additional comment from rdieter@math.unl.edu on 2008-09-28 21:49:17 EDT ---

I think the approach we're going to take is
1.  include a temporary hack/workround (as we did with kde3)
2.  bug xscreensaver maintainer to make webcolloage choose a better default for itself, so that xscreensaver users/consumers (like kscreensaver) don't need to add workarounds forever.

--------------------------------------

See item 2.  It is our (kid-sig's) opinion/desire that xscreensaver's webcollage screensaver have sane defaults, and that includes not showing pr0n.
Comment 1 Mamoru TASAKA 2008-11-18 10:49:12 EST
webcollage now accepts --directory option, so please fix it on
KDE side (see /etc/xscreensaver/XScreenSaver.ad.hacks)
Comment 2 Mamoru TASAKA 2008-11-18 10:52:47 EST
Note:
xscreensaver-extras-gss also uses this option (i.e. when webcollage
is called by gnome-screensaver on Fedora, webcollage doesn't
try to access to net by default, see:
/usr/share/applications/screensavers/xscreensaver-webcollage.desktop)
Comment 3 Rex Dieter 2008-11-18 10:55:51 EST
I know that, our continuing argument is that webcollage should be sane *by default* without any additional hacks or workarounds.

If you disagree with that premise, feel free to mark this WONTFIX, and we'll continue to workaround the mild insanity.
Comment 4 Mamoru TASAKA 2008-11-19 04:17:20 EST
Well, would you try 5.07-3.fc11? I
- moved original webcollage to webcollage.original
- created a wrapper script as webcollage to call webcollage.original
  with the option '-directory /usr/share/backgrounds/images'
- modified man pages and XML file
Comment 5 Mamoru TASAKA 2008-11-25 07:47:21 EST
ping?
Comment 6 Rex Dieter 2008-11-25 08:29:57 EST
Sorry, can't personally test atm... our kdeartwork builds dropped support for webcollage until fixed here. ):
Comment 7 Ngo Than 2008-11-25 09:06:08 EST
This workaround seems ok now. Karsten Hopp told me the Fedora Steering Committee  agree with this sane default setting.
Comment 8 Mamoru TASAKA 2008-11-25 09:30:40 EST
(In reply to comment #7)
> This workaround seems ok now. Karsten Hopp told me the Fedora Steering
> Committee  agree with this sane default setting.

Thank you. Then I will also modify F-10/9/8 xscreensaver (webcollage)
and push them.
Comment 9 Mamoru TASAKA 2008-11-25 10:13:35 EST
*** Bug 472899 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2008-11-25 11:05:59 EST
xscreensaver-5.07-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xscreensaver-5.07-3.fc10
Comment 11 Fedora Update System 2008-11-25 11:07:01 EST
xscreensaver-5.07-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xscreensaver-5.07-3.fc9
Comment 12 Fedora Update System 2008-11-25 11:07:38 EST
xscreensaver-5.07-3.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/xscreensaver-5.07-3.fc8
Comment 13 Bug Zapper 2008-11-26 00:33:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Fedora Update System 2008-11-26 01:11:48 EST
xscreensaver-5.07-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2008-11-26 01:22:32 EST
xscreensaver-5.07-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2008-11-26 01:24:02 EST
xscreensaver-5.07-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 joey 2012-08-04 04:54:28 EDT
you can edit the dictionary file it uses, might help it a little
im in ubuntu hit alt f2
then type gksudo nautilus to open a window that will let you edit system files
then go to /usr/share/dict and delete the bad words from the american-english british-english dictionary files it uses to search for pictues. might help a little. thats what i did because i still like the saver.

Note You need to log in before you can comment on or make changes to this bug.