Bug 472145 - MRG Ruby Client packaging is required for oVirt 1.0 Project Release
MRG Ruby Client packaging is required for oVirt 1.0 Project Release
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-sdk (Show other bugs)
All Linux
medium Severity medium
: 1.1.1
: ---
Assigned To: Andrew Stitcher
Kim van der Riet
Depends On:
  Show dependency treegraph
Reported: 2008-11-18 18:21 EST by Chris Pelland
Modified: 2011-08-12 12:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-05 15:22:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2008-11-18 18:21:37 EST
Description of problem:

oVirt Version 1.0 requires the MRG Ruby Client.

Version-Release number of selected component (if applicable): MRG 1.1

Additional info from Hugh Brock:

* If MRG Dev does not put it in 1.1, we will need to get it in the errata
  release in which they are going to do the GSSAPI encryption work
  that they also will need to provide us.

* I don't believe we are using their productized 
  code for the Ruby Client. In any case, if the client and the encryption work      that the MRG Dev team is doing are in their end-of-December errata, oVoirt should be OK.
Comment 1 Gordon Sim 2008-11-19 05:20:06 EST
Rafi has already committed the code upstream and started on the packaging. Andrew is going to complete this and get the packages brewed.
Comment 2 Chris Pelland 2008-11-20 13:13:49 EST
Support for GSSAPI in qpid (authorization, authentication and encryption of all traffic) is needed by 12/15 (as agreed by MRG Dev).
Comment 3 Chris Pelland 2008-11-20 13:34:26 EST
Both of these items are needed by oVirt's feature freeze which is: Dec 19th.
Comment 4 Chris Pelland 2008-11-21 08:39:41 EST
Since the Ruby Client Packaging and the GSSAPI are two different tasks
(more than likely assigned to different developers), I will create a new bugzilla for the GSSAPI dependency.
Comment 5 Andrew Stitcher 2008-12-02 10:41:30 EST
Created package for RHEL5, RHEL4 package will be a little more painful so left for now
Comment 7 Frantisek Reznicek 2008-12-05 08:26:49 EST
Ruby client packaged as ruby-qpid for both RHEL4 and RHEL5.

RHEL5 ruby-qpid package installable (in "MRG Messaging" yum group)

RHEL4 ruby-qpid package missing in "MRG Messaging" yum group, 
moreover package is not installable on RHEL4 machines (tested RHTS machines i386 and x86_64):

[root@nec-em15 bz473496_manual]# rpm -q ruby ruby-libs
[root@nec-em15 bz473496_manual]# rpm -ivh http://porkchop.devel.redhat.com/brewroot/packages/ruby-qpid/0.3.722126/2.el4/noarch/ruby-qpid-0.3.722126-2.el4.noarch.rpm
Retrieving http://porkchop.devel.redhat.com/brewroot/packages/ruby-qpid/0.3.722126/2.el4/noarch/ruby-qpid-0.3.722126-2.el4.noarch.rpm
error: Failed dependencies:
        ruby(abi) = 1.8 is needed by ruby-qpid-0.3.722126-2.el4.noarch


Additional Info:
I checked rpm dependencies for RHEL4 and RHEL5 and they are the same, but RHEL5 ruby-qpid installs OK:

[root@nec-em13 bz473496_manual]# rpm -q ruby ruby-libs
[root@nec-em13 bz473496_manual]# rpm -q ruby-qpid --requires
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
ruby(abi) = 1.8
[root@nec-em13 bz473496_manual]# rpm -qi ruby-qpid
Name        : ruby-qpid                    Relocations: (not relocatable)
Version     : 0.3.722126                        Vendor: Red Hat, Inc.
Release     : 2.el5                         Build Date: Mon 01 Dec 2008 12:57:17 PM EST
Install Date: Fri 05 Dec 2008 04:20:13 AM EST      Build Host: ls20-bc2-13.build.redhat.com
Group       : Development/Ruby              Source RPM: ruby-qpid-0.3.722126-2.el5.src.rpm
Size        : 174538                           License: ASL 2.0
Signature   : DSA/SHA1, Wed 03 Dec 2008 12:08:53 PM EST, Key ID fd372689897da07a
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://incubator.apache.org/qpid
Summary     : Ruby language client for AMQP
Description :
The Apache Qpid project's Ruby language client for AMQP.
Comment 8 Irina Boverman 2008-12-05 12:04:52 EST
Chris, I understand that oVirt only requires Rhel 5 client, please confirm.
Comment 9 Chris Pelland 2008-12-05 12:17:32 EST
Just spoke to Perry.  oVirt also requires Fedora 10 packaging as well.  

(Apparently this was discussed between both dev groups sometime back which
I was not aware of)
Comment 10 Andrew Stitcher 2009-01-05 15:20:18 EST
Both the RHEL5 and RHEL4 pkgs should be available now

I think the Fedora 10 pkg is also available
Comment 11 Nuno Santos 2009-01-05 15:22:32 EST
ruby-qpid-0.4.728142-1 is in F9 and F10 as of 12/24.

Since there's a separate bz for the gssapi issue, I'm closing this one.

Note You need to log in before you can comment on or make changes to this bug.