Bug 472148 - gnome-default-applications-properties won't make thunderbird default mail reader
gnome-default-applications-properties won't make thunderbird default mail reader
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 19:00 EST by Corentin Perard-Gayot
Modified: 2009-12-18 01:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:53:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corentin Perard-Gayot 2008-11-18 19:00:50 EST
Description of problem:

gnome-default-applications-properties won't make thunderbird default mail reader when I launch it from my gnome session by clicking System-> Preferences -> Personal -> preferred applications (I don't know how it's actually called in english, I run a french session).


Version-Release number of selected component (if applicable):
control-center-2.24.0.1-9.fc10.i386

How reproducible:
always

Steps to Reproduce:
1.install thunderbird and remove evolution
2.launch gnome-default-applications-properties
3.select thunderbird in the list, as the default mail reader
  
Actual results:
icon besides firefox on the top panel defaults back to the bluecurve icon,
named 'preferred mail reader' and a click on it gives an error message : 

Détails : L'exécution du processus fils « evolution » a échoué (Aucun fichier ou dossier de ce type)

approx. translation : 
Details : The child process "evolution" failed to execute (File or directory doesn't exist)

Expected results:
icon besides firefox on the top panel becomes thunderbird one, and a click on it launches thunderbird

Additional info:
if I type mailto:someone@somewhere.ext in the GNOME launch box (ALT+F2), it adds '///' before the recipient's name, so it becomes '///someone@somewhere.ext'
, but I don't know wether it's related to this bug
Comment 1 Bug Zapper 2008-11-26 00:35:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Christopher Tubbs 2009-02-13 16:20:25 EST
I've also noticed this bug. This bug did NOT occur for me with x86_64 architecture, but has happened with every install of i386. Essentially, one has to manually edit the shortcut icon to point to thunderbird.
Comment 3 Corentin Perard-Gayot 2009-02-13 20:15:34 EST
One interesting thing to do is : set the default mail reader to thunderbird, go to ~/.local/share/applications and remove 'default mail reader'.
Then log out and in : it works, icon besides firefox is now thunderbird, mailto: in gnome launch box still doesn't work.
Comment 4 Christopher Tubbs 2009-03-15 13:54:03 EDT
I think this bug should be bumped to a higher priority. It's been around for too long (since F10 was released), and should not be a problem still. This is ridiculous. It is also causing other side-effect bugs, as confused users try to come up with their own fixes, such as Bug 485519.
Comment 5 Bastien Nocera 2009-03-16 06:17:42 EDT
Works fine here. What's the content of:
~/.local/share/applications/preferred-mail-reader.desktop
after you change the setting in the preferred applications preferences?

Could just be a problem with the gnome-panel not monitoring the file properly.

The gnome-launch-box problem is a separate bug.
Comment 6 Corentin Perard-Gayot 2009-03-16 09:18:49 EDT
Bastien : I don't think this is a problem with the gnome panel, here attached is the content of ~/.local/share/applications/preferred-mail-reader.desktop AFTER having set thunderbird as the default mail reader :

[Desktop Entry]
Version=1.0
Encoding=UTF-8
Type=Application
Exec=evolution --component=mail %s //this shouldn't be here, am I right ?
Name=Preferred Mail Reader
GenericName=Mail Reader
Comment=Send email
Icon=redhat-email.png
Terminal=false
X-Panel-Monitor=true
NoDisplay=true

It seems every x86_64 install I did wasnt experiencing this issue...
Comment 7 Christopher Tubbs 2009-03-16 10:03:07 EDT
(In reply to comment #6)
> It seems every x86_64 install I did wasnt experiencing this issue...  

I concur. This seems to happen only with i386 versions, as my x86_64 machines work fine also.

Also, the contents of my ~/.local/share/applications/preferred-mail-reader.desktop currently shows thunderbird also because I've manually edited it. However, usually it shows the same as comment #6 before I change anything.
Comment 8 Bug Zapper 2009-11-18 03:54:05 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-12-18 01:53:02 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.