This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 485519 - Thunderbird won't check mail on startup
Thunderbird won't check mail on startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 16:32 EST by Christopher Tubbs
Modified: 2009-03-15 19:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-15 13:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Tubbs 2009-02-13 16:32:25 EST
Description of problem:
Thunderbird won't check mail on startup. I have all the proper preferences for checking mail on startup for all my IMAP accounts (the problem may extend to POP too, but unable to test that, as I don't have any POP accounts). I have also checked the advanced configuration to see if the proper booleans were set, and they were.

The problem persists whether the start pane is enabled or not. In fact, nothing shows in the right pane until something is clicked in the left pane. No mail is checked, and if the start pane is enabled, it doesn't appear until something is clicked in the left pane.

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.19-1.fc10.i386

How reproducible:
100% on my system

Steps to Reproduce:
1. Install thunderbird, delete .thunderbird folder (just in case)
2. Configure a new account (mine are IMAP, but POP may be similar)
3. Make sure at least one account is configured to check mail on startup
4. Restart thunderbird once properly configured.
  
Actual results:
Right pane is completely blank. No mail is checked, no new message counts are updated, and no start pane appears.

Expected results:
All "check on startup" accounts should be checked, new message counts updated, and inbox should be shown for default account in right pane. Also, start pane should show, if enabled.

Additional info:
I had no problem with the x86_64 version of Thunderbird on Fedora 10.
Comment 2 Christopher Tubbs 2009-03-14 22:12:03 EDT
After further review, I was able to determine that the problem does NOT occur if thunderbird is started with sudo.

I also noticed that the Error Console reports:

Error: startFolder has no properties
Source File: chrome://messenger/content/msgMail3PaneWindow.js
Line: 999

It does this at the beginning of startup.

A google search revealed that this error occurs occasionally with add-ons that have failed to install properly. However, I've uninstalled all the language packs that come installed by default with Fedora, changed the default theme, and uninstalled Enigmail, and the problem persists.

Since I've run out of add-ons to troubleshoot, it must be something else... something that works fine with sudo.

Note that this problem occurs even if I delete the entire .thunderbird directory and create any new profile.
Comment 3 Christopher Tubbs 2009-03-15 13:49:44 EDT
Some further debugging revealed that this bug is reduced to Bug 472148. In fact, it's not really a bug, it's an unfortunate side effect of the user attempting to hack a fix for Bug 472148.

An attempt to recreate the proper shortcut for thunderbird as the default mailreader resulted in a shortcut that called 'thunderbird %s'. This caused the bug reported here.

In short, this bug only occurs when the default mailreader shortcut is not created properly, so once Bug 472148 is fixed (not sure what is taking so long on that one though), this one won't be an issue.
Comment 4 Christopher Aillon 2009-03-15 19:15:27 EDT
Thanks for looking into this further and ruling out thunderbird as the cause.

Note You need to log in before you can comment on or make changes to this bug.