Bug 472420 - X server restarts on starting qt apps
X server restarts on starting qt apps
Status: CLOSED DUPLICATE of bug 446489
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
10
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 13:06 EST by Hassan Abdin
Modified: 2008-12-29 15:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-29 15:54:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hassan Abdin 2008-11-20 13:06:24 EST
Description of problem:
X.Org X server 1.5.3 crashing

Version-Release number of selected component (if applicable):
texmaker-1.7.1-1.fc10.i686.rpm

How reproducible:


Steps to Reproduce:
1. Install texmaker from the package manager.
2. Open it from the Applications/Office menu
3.
  
Actual results:
Application doesn't start and X server restarts

Expected results:
Texmaker to start normally.

Additional info:
Running kernel 2.6.27.5-117.fc10.i686 on Fedora 10 updated to rawhide.
Comment 1 Rex Dieter 2008-11-20 13:42:43 EST
works fine here for me.

imo, X crash -> X server/driver bug.

Fwiw, what video hardware/driver are you using?
Comment 2 Deji Akingunola 2008-11-20 23:41:09 EST
Also works fine for me. You can also check out the new 1.8 release in updates-testing [1] to see if it make a difference for you (although it's weird that texmaker is causing xserver crash)
Comment 3 Hassan Abdin 2008-11-25 08:28:10 EST
Peace be upon you all,

For the first question I use openchrome-0.903 driver.

I noticed the following when I tried to install and run KDE 4: NO QT-4 or KDE 4 based application runs and X crashes. What made me think about that it might be a QT based problem is that both texmaker and Lyx share the same problem, this was ensured by the fact that KDE 4 doesn't even initialize on my machine. Please help me with this.
Comment 4 Rex Dieter 2008-11-25 08:38:49 EST
OK, evidence points to X issue, reassigning.

In the meantime, you could try booting (at grub menu) with:
xdriver=vesa
to avoid using openchrome, to see if that helps.
Comment 5 Hassan Abdin 2008-11-25 10:53:47 EST
Peace be upon you all.

Before reading your last comment, I made the following change to xorg.conf.

#     Driver     "openchrome"
      Driver     "vesa"

I restarted X. Everything went fine concerning QT based issues. I wonder what is wrong with QT-based applications and the openchrome driver. If there is a problem how to solve it since working with the vesa driver makes things very much less speedy. I tried to add some options like the MigrationHeuristic and greedy options but those didn't make X even start. The openchrome man page doesn't show what are the Options in the openchrome driver used in any particular situation. I don't have to give every option a trial to make things work. Isn't there any detailed document that describes each option and its uses?

Thanks in advances.
Comment 6 Bug Zapper 2008-11-26 00:41:44 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Xavier Bachelot 2008-12-29 15:54:21 EST

*** This bug has been marked as a duplicate of bug 446489 ***

Note You need to log in before you can comment on or make changes to this bug.