Bug 472468 - uvcvideo OmniVision webcam 05a9:2640 not working
uvcvideo OmniVision webcam 05a9:2640 not working
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 19:39 EST by Paul W. Frields
Modified: 2008-11-21 14:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 14:43:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2008-11-20 19:39:34 EST
kernel-2.6.27.5-117.fc10.x86_64 (official)
libv4l-0.5.5-1.fc11.x86_64 (from koji as previously instructed)

Webcam provides no video stream under this kernel.

* Also tried 'quirks=64' under -117 kernel, no good
* Out-of-band kernels provided by Hans de Goede (based off -120 and -122 kernels) did work properly with stock F10 libv4l-0.5.3

Bus 002 Device 002: ID 05a9:2640 OmniVision Technologies, Inc. 

### dmesg output
Linux video capture interface: v2.00
uvcvideo: Found UVC 1.00 device Laptop Integrated Webcam (05a9:2640)
uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
input: Laptop Integrated Webcam as /devices/pci0000:00/0000:00:1d.7/usb2/2-6/2-6:1.0/input/input14
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)
######################

More information available upon request, willing to test.  The affected system must remain on F-10 after Rawhide splits to F-11.
Comment 1 Paul W. Frields 2008-11-20 19:40:38 EST
Hans -- done, see bug 472468.  Thank you for your time and patience.
Comment 2 Hans de Goede 2008-11-21 07:02:45 EST
Paul,

I think I know what the cause of your problem is. As the kernel update shows, this is really a kernel bug. But as quite a few people have similar cams (its a popular model) and as a kernel update is not likely to be released soon for F-10,
I've made a small change to libv4l to work around the issue (if it is what I think it is). I need to do a 0 day update for libv4l anyways to fix bug 472217

Can you please update to this libv4l:
http://koji.fedoraproject.org/koji/buildinfo?buildID=70523

And then test cheese with the normal F-10 kernel? Thanks!
Comment 3 Paul W. Frields 2008-11-21 07:55:59 EST
Done, tested under stock F-10 kernel (-117).  Unfortunately, it didn't work.  I did get this warning:

(cheese:7564): GStreamer-AWARNING **: pad source:src returned caps which are not a real subset of its template caps

However, gstreamer-properties does show a video stream as long as the source type 'v4l2' is selected.

What can I provide you to help?
Comment 4 Hans de Goede 2008-11-21 14:43:43 EST
Hmm, interesting, well the good news is that the uvcvideo fixes I've been doing in the kernel fix it. The bad news is I don't know why. The good news is the relevant kernel changes are scheduled to go into the first kernel update which will come out for F-10.

So thats 2-1 for the good guys :) All in all, the best I can do is close this as next release (next kernel update that is), in the mean time use the 2.6.27.5-120.bz472217.fc10 kernel, it is the same as the F-10 gold kernel, except that it contains an update to the latest upstream git (mercurial actually) for the uvcvideo driver + a patch by me to try and workaround 472217, which does not do anything on your cam as it is not from logitech.

Apparently the latest upstream contains a fix for your cam.

Note You need to log in before you can comment on or make changes to this bug.