Bug 472518 - kms degrades 2D performance significantly
kms degrades 2D performance significantly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 08:28 EST by Michal Schmidt
Modified: 2008-11-21 15:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 15:55:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gtkperf results with kms enabled (543 bytes, text/plain)
2008-11-21 08:29 EST, Michal Schmidt
no flags Details
gtkperf results with nomodeset (543 bytes, text/plain)
2008-11-21 08:29 EST, Michal Schmidt
no flags Details
Xorg.0.log with kms (60.87 KB, text/plain)
2008-11-21 08:30 EST, Michal Schmidt
no flags Details
Xorg.0.log with nomodeset (69.65 KB, text/plain)
2008-11-21 08:30 EST, Michal Schmidt
no flags Details
dmesg with kms (38.26 KB, text/plain)
2008-11-21 08:31 EST, Michal Schmidt
no flags Details
dmesg with nomodeset (36.81 KB, text/plain)
2008-11-21 08:31 EST, Michal Schmidt
no flags Details

  None (edit)
Description Michal Schmidt 2008-11-21 08:28:04 EST
Description of problem:
With kernel mode setting enabled (default) 2D performace is visibly lower than with nomodeset. The difference is clearly visible in gtkperf benchmark results. In my case gtkperf run takes 3 times longer (I'll attach detailed results).
I have an ATI Technologies Inc RS690M [Radeon X1200 Series].

Version-Release number of selected component (if applicable):
kernel-2.6.27.5-120.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-5.fc10.x86_64
xorg-x11-drv-ati-6.9.0-55.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Boot normally (with kernel modesetting by default)
2. run gtkperf
3. Repeat the test with 'nomodeset' boot parameter.
  
Actual results:
With 'nomodeset' it is significantly faster.

Expected results:
Kernel mode setting should not negatively affect performance.
Comment 1 Michal Schmidt 2008-11-21 08:29:16 EST
Created attachment 324297 [details]
gtkperf results with kms enabled
Comment 2 Michal Schmidt 2008-11-21 08:29:49 EST
Created attachment 324298 [details]
gtkperf results with nomodeset
Comment 3 Michal Schmidt 2008-11-21 08:30:26 EST
Created attachment 324299 [details]
Xorg.0.log with kms
Comment 4 Michal Schmidt 2008-11-21 08:30:54 EST
Created attachment 324300 [details]
Xorg.0.log with nomodeset
Comment 5 Michal Schmidt 2008-11-21 08:31:24 EST
Created attachment 324301 [details]
dmesg with kms
Comment 6 Michal Schmidt 2008-11-21 08:31:52 EST
Created attachment 324302 [details]
dmesg with nomodeset
Comment 7 Michal Schmidt 2008-11-21 08:36:26 EST
I noticed that both /proc/mtrr contents and contents of /sys/kernel/debug/x86/pat_memtype_list change when 'nomodeset' is added. I suspected it might explain the performance difference, but neither adding 'nopat' nor modifying /proc/mtrr manually had any measurable effect on performance.
Comment 8 Matěj Cepl 2008-11-21 11:31:17 EST
Possibly duplicate of bug 467506 ?
Comment 9 Dave Airlie 2008-11-21 15:55:59 EST
really gtkperf hasn't gotten any slower except for the lines test. Nobody draws lines like the lines test in normal desktop use cases. I can probably spend the time making lines go faster but it doesn't provide any gains to the apps we normally use.

So unless you have real feedback on what apps are acting slower and how slow they are I'll probably not be able to do anything with this.

please reopen if you have a real use case that is noticably slower, or not on bug 467506.

Note You need to log in before you can comment on or make changes to this bug.