Bug 472545 - untranslated strings
untranslated strings
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: i18n (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shannon Hughes
John Matthews
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2008-11-21 12:06 EST by Jesus M. Rodriguez
Modified: 2009-09-10 16:30 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:30:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
missing strings report (240.68 KB, text/plain)
2009-02-11 15:34 EST, Jesus M. Rodriguez
no flags Details
Missing Translation Strings from ISO: 20090605.1 (14.36 KB, text/plain)
2009-06-09 16:12 EDT, John Matthews
no flags Details
translated strings are missing for the keys reported here as of Satellite-5.3.0-RHEL5-re20090724.0 (42.55 KB, text/plain)
2009-08-13 16:45 EDT, John Sefler
no flags Details

  None (edit)
Description Jesus M. Rodriguez 2008-11-21 12:06:59 EST
Description of problem:

There are strings that haven't been translated. See the attached report.
Comment 1 Clifford Perry 2008-12-04 11:23:37 EST
Jesus - no report. Still need/want this bug open to be tracked for Sat 530?

Cliff
Comment 2 Shannon Hughes 2008-12-11 12:02:55 EST
updated all strings with translation 11.28.08 version
Comment 3 Steve Salevan 2009-01-21 15:50:04 EST
No report attached; thus, moving to NEEDINFO on Jesus.
Comment 4 Jesus M. Rodriguez 2009-02-11 15:34:20 EST
Created attachment 331617 [details]
missing strings report
Comment 5 Steve Salevan 2009-03-10 13:59:52 EDT
On Shannon's advice, I'm pushing this back to MODIFIED, as 530-specific translated strings are not currently in the build and will not be present until April.
Comment 6 Shannon Hughes 2009-04-22 10:19:26 EDT
webui strings sent to translation on 4/20/2009. waiting on translation tarballs to apply to repo.
Comment 7 Shannon Hughes 2009-05-11 05:53:19 EDT
webui strings updated in git repo, 

48e380262ffe73d7b06b40638b463e2de3565322
Comment 8 Shannon Hughes 2009-05-20 12:02:39 EDT
mass move to onqa
Comment 9 Steve Salevan 2009-06-03 11:11:48 EDT
Moving QA Contact to John Matthews, as he has greater experience with this issue than I.
Comment 10 John Matthews 2009-06-08 16:03:04 EDT
See below commit to generate missingstrings.txt


Author: jmatthew
Date: 2009-06-08 15:53:53 -0400 (Mon, 08 Jun 2009)
New Revision: 184776
Log:
QA scripts to check translation strings on a Satellite's rhn.jar and see what keys are missing.
NOTE:  These scripts are essentially the same as the development ant task "ant missingstrings", see the build.xml for Satellite.
Main difference is that these scripts grab the rhn.jar, uncompress it, then do the directory lookups in python.
The logic for determining a missing string is identical.
Comment 11 John Matthews 2009-06-09 16:12:17 EDT
Created attachment 347083 [details]
Missing Translation Strings from ISO: 20090605.1

Missing strings report from ISO: 
Satellite-5.3.0-RHEL5-re20090605.1-i386-embedded-oracle.iso
Comment 12 John Matthews 2009-06-09 16:19:17 EDT
Some translation strings are still outstanding, example is below (full report in comment #11).

	login.jsp.satbody4
	packagesearch.jsp.specificchannel
	packagesearch.jsp.specificarch
	kickstart.jsp.virt-type.none
	package.jsp.menu.patches
	header.jsp.errata.sync
	channel.jsp.errata.sync.message
	channel.jsp.errata.sync.note
	channel.jsp.errata.sync.listempty
	header.jsp.errata.sync.packagepush
	channel.jsp.errata.sync.packages.message
	channel.jsp.errata.sync.complete

This can be tested from a dev environment with "ant missingstrings"

Or from a QA ISO by copying the files from rhn-svn/qa/automation/translations/ to a sat install and running "missingstringsQA.sh".
Comment 13 Shannon Hughes 2009-06-10 09:09:41 EDT
not a bug. any strings added after the cut off date a couple weeks ago will float into 540. moving back to onqa
Comment 14 John Matthews 2009-06-10 12:52:08 EDT
Marking this bug as VERIFIED, since missing strings are new additions.

Created new bug 505107, to track the newly added strings which are not translated.


Also, ran missingstrings script against ISO 520, list of missing strings from 520 are:
	header.jsp.my_organization
	header.jsp.satellite_wide
	orgsoftwaresubs.jsp.nochannelfams
	errata.publish.packagepush.nopackages_pushed
	errata.publish.packagepush.packages_pushed
	kickstartdetails.jsp.virtTypeChangeWarning
	yourrhn.jsp.task.manage_subscriptions
	virtualization.provision.first.jsp.storage.tip1
	login.jsp.error.header
	login.jsp.error.message
	login.jsp.error.currentlyLoggedInAs
	entitlementorgs.update

These strings do not show as problems in 530, so marking as VERIFIED.
Comment 15 John Sefler 2009-08-13 16:43:21 EDT
Using the tools as described in bug 505107, the list of untranslated strings from sat520 (listed in comment#14) have been resolved in sat530. (Satellite-5.3.0-RHEL5-re20090724.0)

moving to RELEASE_PENDING

However, there are numerous newly introduced untranslated strings in sat530.  These issues are being tracked in bug 505107.  I am also attaching a report of the untranslated strings as of Satellite-5.3.0-RHEL5-re20090724.0 for completeness.
Comment 16 John Sefler 2009-08-13 16:45:39 EDT
Created attachment 357370 [details]
translated strings are missing for the keys reported here as of Satellite-5.3.0-RHEL5-re20090724.0
Comment 17 Brandon Perkins 2009-09-10 16:30:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.