Bug 472602 - RFE: would like an API for determining if an intercepted request is an internal one
RFE: would like an API for determining if an intercepted request is an intern...
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Server - Plugins (Show other bugs)
1.1.3
All Linux
high Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
:
Depends On:
Blocks: 249650 FDS1.2.0
  Show dependency treegraph
 
Reported: 2008-11-21 17:38 EST by Nalin Dahyabhai
Modified: 2015-01-04 18:35 EST (History)
3 users (show)

See Also:
Fixed In Version: 8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 19:08:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CVS Diffs (2.31 KB, patch)
2009-01-09 17:42 EST, Nathan Kinder
no flags Details | Diff

  None (edit)
Description Nalin Dahyabhai 2008-11-21 17:38:45 EST
In order to avoid mutual recursion-triggered problems, it would be useful to be able to tell whether or not a particular request was done on behalf of a connected client or another plugin.  Currently, I don't think we have a way that a plugin can do that as part of the public SLAPI.
Comment 1 Nathan Kinder 2009-01-09 17:42:03 EST
Created attachment 328598 [details]
CVS Diffs

This exposes the internal operation flag publicly as SLAPI_OP_FLAG_INTERNAL.  The existing slapi_operation_is_flag_set() can be used to check an operation for this new flag.  This flag and the old function will both need to be added to the Plug-In Programmer's Guide.
Comment 2 Nathan Kinder 2009-01-09 18:10:58 EST
Checked into ldapserver (HEAD).  Thanks to Noriko for her review!

Checking in ldap/servers/slapd/slapi-plugin.h;
/cvs/dirsec/ldapserver/ldap/servers/slapd/slapi-plugin.h,v  <--  slapi-plugin.h
new revision: 1.38; previous revision: 1.37
done
Checking in ldap/servers/slapd/slapi-private.h;
/cvs/dirsec/ldapserver/ldap/servers/slapd/slapi-private.h,v  <--  slapi-private.h
new revision: 1.33; previous revision: 1.32
done
Comment 3 Jenny Galipeau 2009-03-19 09:01:51 EDT
Not sure QE can verify this bug - also is it a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=439907?
Comment 4 Nathan Kinder 2009-03-19 11:17:42 EDT
This can not be verified by QE, as it is an API addition.  Marking as verified.
Comment 5 Chandrasekar Kannan 2009-04-29 19:08:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0455.html

Note You need to log in before you can comment on or make changes to this bug.