Bug 472697 - sdptool browse and rfcomm0 timed out in kernel 2.6.27.5-41.fc9.i686
sdptool browse and rfcomm0 timed out in kernel 2.6.27.5-41.fc9.i686
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-23 13:09 EST by Juhani Jaakola
Modified: 2009-07-14 17:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:06:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
WIth and older kernel sdptool browse works (2.33 KB, text/plain)
2008-11-23 13:09 EST, Juhani Jaakola
no flags Details
Errors in sdptool browse and rfcomm with the current kernel (1.83 KB, text/plain)
2008-11-23 13:10 EST, Juhani Jaakola
no flags Details
Works with kernel 2.6.25-14.fc9.i686 on another PC (2.13 KB, text/plain)
2008-11-25 08:10 EST, Juhani Jaakola
no flags Details
Does not work with 2.6.27.5-37.fc9.i686 (1.58 KB, text/plain)
2008-11-25 08:18 EST, Juhani Jaakola
no flags Details
Also Fedora 10 fails (1.12 KB, text/plain)
2008-12-09 13:23 EST, Juhani Jaakola
no flags Details
"hcidump -w /tmp/browse.dmp" while browsing Nokia 9500 (137 bytes, application/octet-stream)
2008-12-12 08:47 EST, Juhani Jaakola
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 268502 None None None Never

  None (edit)
Description Juhani Jaakola 2008-11-23 13:09:36 EST
Created attachment 324437 [details]
WIth and older kernel sdptool browse works

Description of problem:
With kernel 2.6.27.5-41.fc9.i686 sdptool browse and using rfcomm0 give error "Connection timed out". With kernel 2.6.26.6-79.fc9.i686 sdptool browse works, but using rfcomm gives error "Connection refused".

With kernel 2.6.27.5-41.fc9.i686 I get the same error (Connection timed out) with sdptool browse and using rfcomm0 with both Nokia 9500 and Nokia E60.

I can send files from Nokia 9500 to Linux with OBEX. I can pair my phone with Linux.

I'm using an USB Bluetooth dongle.

I have recently upgraded from fc7 to fc9. With fc7 using rfcomm with pppd worked fine.

Version-Release number of selected component (if applicable):
See the attached logs.

How reproducible:
I have rebooted several times, always I get the same errors.

Steps to Reproduce:
1. See the attached logs.
  
Actual results:
Error mesages, see the attachments.

Expected results:
No errors.

Additional info:
Comment 1 Juhani Jaakola 2008-11-23 13:10:51 EST
Created attachment 324438 [details]
Errors in sdptool browse and rfcomm with the current kernel
Comment 2 Bastien Nocera 2008-11-23 13:26:42 EST
There's no bluez package in Fedora 9, and this seems to be a kernel problem anyway, reassigning.
Comment 3 Juhani Jaakola 2008-11-25 08:10:22 EST
Created attachment 324604 [details]
Works with kernel 2.6.25-14.fc9.i686 on another PC

I tested this on another PC with another USB Bluetooth dongle. Sdptool browse and rfcomm work with kernel 2.6.25-14.fc9.i686
Comment 4 Juhani Jaakola 2008-11-25 08:18:31 EST
Created attachment 324610 [details]
Does not work with 2.6.27.5-37.fc9.i686

Sdptool browse and rfcomm do not work with kernel 2.6.27.5-37.fc9.i686 either.

So to summarize:
- With the following kernels sdptool browse and rfcomm do not work:
2.6.27.5-37.fc9.i686
2.6.27.5-41.fc9.i686
- With the following kernels they work:
2.6.25-14.fc9.i686
2.6.26.6-70.fc9.i686
- I have tested this on two different PCs and two different USB Bluetooth dongles
Comment 5 Juhani Jaakola 2008-12-09 13:23:24 EST
Created attachment 326375 [details]
Also Fedora 10 fails
Comment 6 Juhani Jaakola 2008-12-09 13:26:01 EST
I tested on the first machine with Fedora 10 Live CD, and it has the same problem with sdptool browse. See the attachment.

I have now tested on three machines and no one can do "sdptool browse" with recent kernels, but it succeeds with an older kernel such as 2.6.25-14.fc9.i686.
Comment 7 Juhani Jaakola 2008-12-11 10:47:01 EST
I updated my system with "yum update" and now I've got kernel kernel-2.6.27.7-53.fc9.i686. It's getting even worse: The new kernel still has all the same problems as before and now even the Gnome Bluetooth applet crashes!

Thank god I still have kernel 2.6.25-14.fc9.i686 available!
Comment 8 Juhani Jaakola 2008-12-12 08:47:42 EST
Created attachment 326729 [details]
"hcidump -w /tmp/browse.dmp" while browsing Nokia 9500

This is what happens when I right-click the Bluetooth applet and then choose Browse Device..., select my Nokia 9500 and click [Connect]:

I get a dialog box with the following text:

Couldn't display "obex://[00:0E:ED:B2:4D:E6]/".
Error: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Please select another viewer and try again.

At the same time, I get this in /var/log/messages:

Dec 12 10:38:14 acer hcid[2012]: connect(): Connection timed out (110)
Dec 12 10:38:15 acer kernel: hci_cmd_task: hci0 command tx timeout

The next time I try the same thing I get this in /var/log/messages:

Dec 12 10:48:48 acer hcid[2012]: connect(): Connection timed out (110)

I performed this test on Fedora 9 which I have updated to the most recent versions. Now I have kernel 2.6.27.7-53.fc9.i686.

I have attached the result of "hcidump -w /tmp/browse.dmp"
Comment 9 Juhani Jaakola 2008-12-27 14:23:22 EST
The same bug exists in kernel 2.6.27.9-73.fc9.i686
Comment 10 Juhani Jaakola 2008-12-30 17:39:13 EST
In https://wiki.ubuntu.com/IntrepidReleaseNotes#Kubuntu%20Bluetooth%20support it reads:

--- begin of quote ---
Bluetooth is not supported in Kubuntu 8.10 because KDE does not yet support the bluez 4.x stack required for compatibility with the kernel used in 8.10.
--- end of quote ---

In my up-to-date Fedora 9 I have bluez-libs-3.36-1.fc9.i386.

I hope somebody will port bluez 4.x and a new Gnome Bluetooth Applet to Fedora 9 so that I can use Bluetooth again...
Comment 11 Bastien Nocera 2009-01-05 07:03:54 EST
What does this have to do with bluez-libs? It's a kernel bug, and has nothing to do with the version of the library in use.

Bluez 4.x won't be added to Fedora 9, but it's already in Fedora 10.
Comment 12 Juhani Jaakola 2009-01-06 05:33:35 EST
I raised the severity of this bug to "High" because now Bluetooth is completely unusable in Fedora 9:
- I can't receive files from my Nokia 9500
- I can't browse Nokia 9500 nor Nokia E60
- I can't use GPRS networking via Bluetooth (via rfcomm)
- I can't use my Bluetooth GPS device via Bluetooth (via rfcomm and gpsd)

All of this worked with kernel 2.6.25-14.fc9.i686.

I can reproduce this problem with three different PCs and three different USB Bluetooth dongles (of two different models) and four different phones.

Could somebody please share any thoughts what really is the problem? If this is a kernel problem, can anybody tell which module is broken? Or can anybody describe in detail how things work now in kernel and how it should work?
Comment 13 Kamil Stawirej 2009-02-15 16:34:47 EST
*** Bug 484524 has been marked as a duplicate of this bug. ***
Comment 14 Juhani Jaakola 2009-04-06 16:12:09 EDT
Ubuntu Launchpad bug #268502 has the same symptoms as I do here. They claim that the bug is in the new btusb driver which replaced usb_hci, and that this is fixed in 2.6.29-rc3.

Anybody care to backport the btusb to the kernel that Fedora 10 uses? Launchpad claims that the changes are local to btusb driver.
Comment 15 Juhani Jaakola 2009-04-10 09:36:55 EDT
With Fedora 11 Beta Live CD, which has kernel kernel-2.6.29-0.258.2.3.rc8.git2.fc11.i586 I can browse my Nokia 9500 (choose "Browse files on device..." from Bluetooth applet). And command "sdptool browse 00:0E:ED:B2:4D:E6" works too!

Any hope to get the fix into Fedora 10 as well? Please read the Launchpad bug #268502, it mentions some patches to the btusb driver.
Comment 16 Juhani Jaakola 2009-04-13 13:21:47 EDT
I downloaded Fedora 11 Snap1 Live CD and I was pleased to note that I can browse my Nokia 9500 from my laptop with my USB Bluetooth dongle with this Live CD too! And "sdptool browse" works too! The Live CD has versions

kernel-2.6.29.1-54.fc11.i586
bluez-4.34-3.fc11.i586

Please fix this in Fedora 10 as well!
Comment 17 Juhani Jaakola 2009-04-15 05:50:22 EDT
This works now with Fedora 10 with kernel-2.6.29.1-30.fc10.i686 which I got from Koji. I have Bluetooth dongle (ID 1131:1001) and I can browse files (right-click Bluetooth Applet and choose "Browse files on device...") on my Nokia 9500 and I can use my Nokia 9500 as a GPRS modem via RFCOMM!

Finally!!!!!!!!
Comment 18 Chuck Ebbert 2009-04-16 22:19:22 EDT
Fedora 9 is never going to get a 2.6.29 kernel. Do you want to close this bug anyway when the F10 2.6.29 kernel gets released?
Comment 19 Juhani Jaakola 2009-04-17 01:44:00 EDT
I do not have Fedora 9 any more, so for me it is enough to fix this in F10 and F11.
Comment 20 Bug Zapper 2009-06-09 23:20:51 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Bug Zapper 2009-07-14 13:06:54 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 22 Juhani Jaakola 2009-07-14 17:23:51 EDT
This works in Fedora 11.

Note You need to log in before you can comment on or make changes to this bug.