Bug 484524 - Bluetooth -- DBus error: message did not receive a reply
Bluetooth -- DBus error: message did not receive a reply
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
10
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-07 16:36 EST by Kamil Stawirej
Modified: 2009-03-19 07:52 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.4.3-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-15 16:34:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of commands to test bluetooth (971 bytes, text/plain)
2009-02-15 16:30 EST, Kamil Stawirej
no flags Details

  None (edit)
Description Kamil Stawirej 2009-02-07 16:36:25 EST
Description of problem: Bluetooth is broken. I have a nokia 2006c mobile and a USB bluetooth dongle. I can pair the phone with the computer (but the pairing procedure must be started from the phone, because the conection cannot be established from the computer -- pairing always fails). Whenever I try to browse files on the phone or send a file to it I get the following error:

'Error: DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
Please select another viewer and try again.'


Version-Release number of selected component (if applicable):
4.22 (on fedora 10)

How reproducible: always


Steps to Reproduce:
1. pair the mobile with the computer
2. choose the 'browse files on device' option in the gnome bluetooth applet
3. press 'connect'
  
Actual results: 

'Error: DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
Please select another viewer and try again.'


Expected results:

I should see the filesystem on the phone.

Additional info:
Comment 1 Juhani Jaakola 2009-02-15 05:18:43 EST
Please check whether this is duplicate of Bug 472697.
Comment 2 Kamil Stawirej 2009-02-15 07:12:36 EST
(In reply to comment #1)
> Please check whether this is duplicate of Bug 472697.

I am not sure, but I think it is not necessarily the same bug since sending files to my nokia phone over bluetooth does not work either. 

Also, this message:

":Couldn't display "obex://[00:0E:ED:B2:4D:E6]/".
Error: Did not receive a reply. Possible causes include: the remote application
did not send a reply, the message bus security policy blocked the reply, the
reply timeout expired, or the network connection was broken.
Please select another viewer and try again."

has never been displayed in my case.
Comment 3 Kamil Stawirej 2009-02-15 16:30:45 EST
Created attachment 331989 [details]
Output of commands to test bluetooth

This is the output of the commands issued to see if my bug is the same as Bug 472697.
Comment 4 Kamil Stawirej 2009-02-15 16:34:47 EST
I run the same same test procedure as Juhani Jaakola. Then, we compared the results and concluded that my bug is the same as Bug 472697, which Juhani reported. This is why I mark this one as a duplicate of Bug 472697.

*** This bug has been marked as a duplicate of bug 472697 ***
Comment 5 Fedora Update System 2009-03-18 15:06:13 EDT
obex-data-server-0.4.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Kamil Stawirej 2009-03-19 07:52:30 EDT
I've just updated obex-data-server and rebooted my computer. Unfortunately, the problem still persists. I'm getting the very same error message:

[root@localhost kamil]# sdptool browse 00:1E:A4:ED:88:B2
Failed to connect to SDP server on 00:1E:A4:ED:88:B2: Connection timed out

Note You need to log in before you can comment on or make changes to this bug.