Bug 472876 - gnome-packagekit shows only the latest version of an installed package
gnome-packagekit shows only the latest version of an installed package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 05:59 EST by Julian Sikorski
Modified: 2009-08-21 21:01 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.4.9-1.fc11
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 14:05:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2008-11-25 05:59:00 EST
Description of problem:
This is particularly annoying when trying to remove some unused kernels. There can be a few of these installed, yum limits the number to 3 by default. In my case:
$ rpm -q kernel | sort
kernel-2.6.25.11-97.fc9.x86_64
kernel-2.6.26.6-79.fc9.x86_64
kernel-2.6.27.5-37.fc9.x86_64
kernel-2.6.27.5-41.fc9.x86_64
Yet, upon searching for “kernel” in g-p-k, only 2.6.27-5-41 is shown, giving no easy way of removing some of the others.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.3.10-2.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. install a few kernels at once
2. start gnome-packagekit
3. search for kernel
  
Actual results:
only the latest version is shown among the results

Expected results:
all installed kernels show up

Additional info:
Comment 1 Richard Hughes 2008-11-25 08:34:12 EST
Have you tried the version in updates or updates-testing?
Comment 2 Julian Sikorski 2008-11-25 13:34:55 EST
0.3.10-2.fc9 is what dwells in testing.
Comment 3 Julian Sikorski 2008-12-12 10:44:10 EST
This is still the case with gnome-packagekit-0.3.12-1.fc10.x86_64.
Comment 4 Richard Hughes 2008-12-16 04:13:00 EST
Does unchecking "Filters->Only newest packages" fix things?
Comment 5 Julian Sikorski 2008-12-16 04:20:33 EST
Yes, it does. Shouldn't the said filter apply to packages in repos (not installed) only? Hiding installed packages from the user is not nice.
Comment 6 TK009 2009-03-03 20:29:45 EST
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Richard Hughes 2009-04-15 12:58:33 EDT
commit 8883089d5f33bfd91491d1e60e87eb7534e703b3
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Apr 15 17:57:32 2009 +0100

    yum: consider the installed state when we do newest filtering. Fixes rh#472876
Comment 8 Tomasz Chrzczonowicz 2009-07-10 05:58:32 EDT
Actually, this produced a bug where there was none.

https://bugzilla.redhat.com/show_bug.cgi?id=476827

Now when you have some package installed in latest version, the non-installed earlier versions are shown as well even if "latest packages only" filter is used. This is quite annoying.

Please revert the filter to how it worked before for the sake of consistency in user experience, i.e. filter working according to its name and stated purpose regardless of whether package is installed or not (there is a separate filter for that).

It's self-explanatory that if one wants to view the earlier versions of a package then (s)he has to uncheck the "latest packages only". And if one wants to view earlier versions of an installed package (like the kernel) then (s)he should uncheck "latest packages only" and check "only installed".

The filter _wasn't broken at all_ in the first place and now there is an unnecessary exception for the installed packages and if earlier non-installed packages are to be hidden by fixing bug 476827, then there will be an exception to an exception - this is confusing and inconsistent user experience.
Comment 9 Julian Sikorski 2009-07-23 05:59:03 EDT
with gnome-packagekit-2.27.3-1.fc11.x86_64 a regression was introduced. It seems that the newest filter considers x86_64 packages newer than i586, and thus only the former are displayed in case:
- both packages are installed
- both packages are not installed
In case one arch is installed and the other is not, both architectures are shown in the list.
Comment 10 Richard Hughes 2009-07-23 11:15:54 EDT
commit 52dccfbfa6218cc82c47d682761f36f745e3d0ca
Author: Richard Hughes <hughsie@hughsie-dell.(none)>
Date:   Thu Jul 23 17:15:33 2009 +0100

    Package arch should be taken into account for newest filtering. Fixes rh#472876
Comment 11 Richard Hughes 2009-07-23 14:05:02 EDT
commit 65565b071251bc4f3bb33003884278e2e735735e
Author: Richard Hughes <richard@hughsie.com>
Date:   Thu Jul 23 17:43:47 2009 +0100

    yum: add arch filtering support. This was easier than I thought...

:100644 100644 ef0680c... 3ff4d1e... M  backends/yum/pk-backend-yum.c
:100644 100644 84baddc... 7a20cd8... M  backends/yum/yumFilter.py
Comment 12 Fedora Update System 2009-08-03 10:33:19 EDT
PackageKit-0.4.9-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/PackageKit-0.4.9-1.fc11
Comment 13 Fedora Update System 2009-08-21 21:01:15 EDT
PackageKit-0.4.9-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.