Bug 476827 - gnome-packagekit always displays old versions of installed packages
gnome-packagekit always displays old versions of installed packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 06:46 EST by Pavel Rosenboim
Modified: 2009-08-15 14:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-15 14:56:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-packagekit bug (135.90 KB, image/png)
2009-07-10 08:43 EDT, Tomasz Chrzczonowicz
no flags Details

  None (edit)
Description Pavel Rosenboim 2008-12-17 06:46:58 EST
Description of problem:
gnome-packagekit displays old versions of installed packages even when filters "available only" and "only newest version" are selected.
It makes it impossible to tell whether a package isn't installed or a newer version of the package is already installed. 

Version-Release number of selected component (if applicable):
gnome-packagekit-0.3.12-1.fc10.i386

How reproducible:
Always
Comment 1 Tomasz Chrzczonowicz 2009-07-10 05:28:32 EDT
The bug is still here on Fedora 11 with gnome-packagekit 2.27.2-1.fc11.
Comment 2 Tomasz Chrzczonowicz 2009-07-10 05:37:30 EDT
And if some package is installed, its earlier versions have installed icons (but not checkboxes) as well...
Comment 3 Tomasz Chrzczonowicz 2009-07-10 06:03:50 EDT
It seems this bug was introduced by fixing bug 472876, which was not even a bug in the first place.
Comment 4 Richard Hughes 2009-07-10 06:17:47 EDT
Have you tried using:

https://admin.fedoraproject.org/updates/gnome-packagekit-2.27.3-1.fc11

and

https://admin.fedoraproject.org/updates/PackageKit-0.4.8-2.fc11

This should fix things to work according to the spec.
Comment 5 Tomasz Chrzczonowicz 2009-07-10 08:43:03 EDT
Created attachment 351252 [details]
gnome-packagekit bug

It is still not fixed
Comment 6 Richard Hughes 2009-07-10 10:40:01 EDT
(In reply to comment #5)
> It is still not fixed  

Did you reboot after installing the new PackageKit?
Comment 7 Tomasz Chrzczonowicz 2009-07-10 10:50:04 EDT
Yes
Comment 8 Tomasz Chrzczonowicz 2009-08-15 13:40:43 EDT
This bug seems to be fixed now.

Note You need to log in before you can comment on or make changes to this bug.