Bug 472915 - mkdumprd hates new mdadm.conf layout, then hangs even once its fixed
mkdumprd hates new mdadm.conf layout, then hangs even once its fixed
Status: CLOSED DUPLICATE of bug 479211
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 11:10 EST by Jarod Wilson
Modified: 2009-01-10 09:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 09:40:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to get raid modules more easily (738 bytes, patch)
2008-12-17 10:52 EST, Neil Horman
no flags Details | Diff

  None (edit)
Description Jarod Wilson 2008-11-25 11:10:56 EST
Description of problem:
Seems something changed in the way mdadm.conf gets written out in 5.3, as I have a cleanly installed 5.3-ish system with the following mdadm.conf contents:

# mdadm.conf written out by anaconda
DEVICE partitions
MAILADDR root
ARRAY /dev/md1 level=raid1 num-devices=2 uuid=4da5c52a:...:64b31684
ARRAY /dev/md2 level=raid1 num-devices=2 uuid=a023103c:...:22ca919f
ARRAY /dev/md0 super-minor=0

(uuids shortened to prevent line-wrapping)

The last entry causes mkdumprd to puke, like so:
# mkdumprd -v ...
[...]
Looking for deps of module ARRAY
No module ARRAY found for kernel 2.6.18-124.el5, aborting.

Altering the md0 entry to look more like the others (ARRAY /dev/md0 level=raid1 num-devices=2 super-minor=0), I no longer hit that problem, but mkdumprd still encounters an indefinite hang.


# mkdumprd -v -f /boot/initrd-2.6.18-124.el5kdump.img 2.6.18-124.el5
Creating initramfs
Looking for deps of module ata_piix: libata scsi_mod
Looking for deps of module libata: scsi_mod
Looking for deps of module scsi_mod
Looking for deps of module sd_mod: scsi_mod
Looking for deps of module ahci: libata scsi_mod
Looking for deps of module ide-disk
Looking for deps of module ext3: jbd
Looking for deps of module jbd
Found RAID component md1
Looking for deps of module raid1
Looking for driver for device sdb2
Looking for driver for device sda2
Using modules: /lib/modules/2.6.18-124.el5/kernel/drivers/scsi/scsi_mod.ko /lib/modules/2.6.18-124.el5/kernel/drivers/scsi/sd_mod.ko /lib/modules/2.6.18-124.el5/kernel/drivers/ata/libata.ko /lib/modules/2.6.18-124.el5/kernel/drivers/ata/ata_piix.ko /lib/modules/2.6.18-124.el5/kernel/drivers/ata/ahci.ko /lib/modules/2.6.18-124.el5/kernel/fs/jbd/jbd.ko /lib/modules/2.6.18-124.el5/kernel/fs/ext3/ext3.ko /lib/modules/2.6.18-124.el5/kernel/drivers/md/raid1.ko
copy from `/lib/modules/2.6.18-124.el5/kernel/drivers/scsi/scsi_mod.ko' [elf64-x86-64] to `/tmp/initrd.TP7904/lib/scsi_mod.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.18-124.el5/kernel/drivers/scsi/sd_mod.ko' [elf64-x86-64] to `/tmp/initrd.TP7904/lib/sd_mod.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.18-124.el5/kernel/drivers/ata/libata.ko' [elf64-x86-64] to `/tmp/initrd.TP7904/lib/libata.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.18-124.el5/kernel/drivers/ata/ata_piix.ko' [elf64-x86-64] to `/tmp/initrd.TP7904/lib/ata_piix.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.18-124.el5/kernel/drivers/ata/ahci.ko' [elf64-x86-64] to `/tmp/initrd.TP7904/lib/ahci.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.18-124.el5/kernel/fs/jbd/jbd.ko' [elf64-x86-64] to `/tmp/initrd.TP7904/lib/jbd.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.18-124.el5/kernel/fs/ext3/ext3.ko' [elf64-x86-64] to `/tmp/initrd.TP7904/lib/ext3.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.18-124.el5/kernel/drivers/md/raid1.ko' [elf64-x86-64] to `/tmp/initrd.TP7904/lib/raid1.ko' [elf64-x86-64]
<hangs indefinitely here>


Version-Release number of selected component (if applicable):
kernel-2.6.18-124.el5
mdadm-2.6.4-1.el5
kexec-tools-1.102pre-50.el5
Comment 1 Neil Horman 2008-12-17 09:29:24 EST
Jarod, could you please run the following command on this system:
mdadm --examine --scan
for me please nad post the output in this bug. Thanks!
Comment 2 Jarod Wilson 2008-12-17 09:37:10 EST
Sure, here it is:

# mdadm --examine --scan
ARRAY /dev/md0 level=raid1 num-devices=2 UUID=29e76d93:105cd385:a143a3e6:bd3dc982
ARRAY /dev/md1 level=raid1 num-devices=2 UUID=4da5c52a:0c6392c6:b4c85bb1:64b31684
ARRAY /dev/md2 level=raid1 num-devices=2 UUID=a023103c:a09bf8ca:a30ff734:22ca919f
Comment 3 Neil Horman 2008-12-17 10:52:04 EST
Created attachment 327263 [details]
patch to get raid modules more easily

copy that, thank s jarod.  This patch should fix you.  Please test and confirm, and I'll get it in for 5.4
Comment 4 Jarod Wilson 2008-12-17 21:00:58 EST
Golden. Ship it!
Comment 5 Jarod Wilson 2008-12-17 21:03:29 EST
nb: the earlier hang is also somewhat inexplicably gone now too, but hey, I'll take it. Was hitting the hang even after twiddling mdadm.conf to give me more or less the exact same thing this change does, so *shrug*.
Comment 6 Neil Horman 2009-01-10 09:40:36 EST
closing this as a dup of 479211 as there is a merged patch for both of these issues there

*** This bug has been marked as a duplicate of bug 479211 ***

Note You need to log in before you can comment on or make changes to this bug.