Bug 479211 - [PATCH] mkdumprd does not work for raid[456]-rooted installations
[PATCH] mkdumprd does not work for raid[456]-rooted installations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Neil Horman
Martin Jenner
:
: 472915 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 19:30 EST by Lubomir Rintel
Modified: 2010-10-23 02:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 600589 (view as bug list)
Environment:
Last Closed: 2009-09-02 05:13:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch that fixes mkdumprd with raid[456] (1.36 KB, text/plain)
2009-01-07 19:30 EST, Lubomir Rintel
no flags Details
A patch that fixes mkdumprd with raid[456] (merged with fix for #472915) (1.48 KB, text/plain)
2009-01-09 16:38 EST, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2009-01-07 19:30:13 EST
Created attachment 328425 [details]
A patch that fixes mkdumprd with raid[456]

Description of problem:

$subj

Version-Release number of selected component (if applicable):

kexec-tools-1.102pre-21.el5

How reproducible:

100%

Steps to Reproduce:
1. ARRAY /dev/md0 level=raid5 ... in /etc/mdadm.conf
2. /sbin/mkdumprd -v -d -f /boot/initrd-2.6.18-116.el5kdump.img 2.6.18-116.el5
  
Actual results:

Module raid5 can not be found

Expected results:

Initrd built with module raid456.ko included
Comment 1 Neil Horman 2009-01-09 07:18:43 EST
I think this is a duplicate of bz 472915.  please try the patch there and let me know thanks.
Comment 2 Lubomir Rintel 2009-01-09 16:38:43 EST
Created attachment 328595 [details]
A patch that fixes mkdumprd with raid[456] (merged with fix for #472915)

(In reply to comment #1)
> I think this is a duplicate of bz 472915.  please try the patch there and let
> me know thanks.

It doesn't seem like such. A side effect of my patch would be that it would also fix the bug #472915 problem (since sed -n .../p construct is used which makes the matching of ARRAY lines more robust) though. I merged the two patches, attaching the result.
Comment 3 Neil Horman 2009-01-10 09:40:36 EST
*** Bug 472915 has been marked as a duplicate of this bug. ***
Comment 4 Neil Horman 2009-01-30 14:07:39 EST
fixed in 1.102pre-59.el5.  Thanks!
Comment 5 Lubomir Rintel 2009-03-23 08:43:58 EDT
I'm wondering if this is to be fixed in Fedora as well? Looking at the Fedora mkdumprd it seems to have the same problem, I'm unable to verify that though, since I don't have a raid installation.
Comment 8 Chris Ward 2009-07-03 14:19:24 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 11 errata-xmlrpc 2009-09-02 05:13:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1258.html

Note You need to log in before you can comment on or make changes to this bug.