Bug 472919 - Listing languages for release notes
Listing languages for release notes
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
: 473323 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 11:27 EST by scmuser
Modified: 2008-12-16 14:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 14:45:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scmuser 2008-11-25 11:27:03 EST
Description of problem:
The release notes available in various languages are listed in abbrevation instead of full language names here,
http://docs.fedoraproject.org/release-notes/f10/

For a novice, no techy user, these abbrevations is very very confusing and barely helpful. 

I'd suggest a list like,
Italian (it)
Spanish (es)
US English (en_US)
...
...


Version-Release number of selected component (if applicable):
Fedora 10 Release notes

How reproducible:
Always

Steps to Reproduce:
1. Click on the link http://docs.fedoraproject.org/release-notes/f10/
2.
3.
  
Actual results:
Abbrevations that don't make any sense to non techy users.

Expected results:
Language name and it's abbrevation


Additional info:
Comment 1 Paul W. Frields 2008-11-29 13:26:21 EST
I used to spell these language names out in their native language and, if I recall correctly, it was criticized as a bug because the names would generate erroneous "missing character" boxes for people without the required fonts installed.  It would be wrong, in my opinion, to either spell these out in English only, or to spell out only those names we can represent with a Latin character set.
Comment 2 Paul W. Frields 2008-11-29 13:30:41 EST
*** Bug 473323 has been marked as a duplicate of this bug. ***
Comment 3 Karsten Wade 2008-12-01 14:17:31 EST
So ... is there a good solution?  What about:

Native_lang (English_ver, short_code)

For example:

Español (Spanish, es)

Of course, now the hard part is getting the native language characters and spelling all worked out.  Perhaps we can have a single wiki page that has all of this for reference and future use?
Comment 4 Bill Nottingham 2008-12-04 21:53:57 EST
Pulling the list from gdm should be simple enough. By default on the desktop, we install fonts for most character sets.
Comment 5 Karsten Wade 2008-12-06 01:02:49 EST
Sorry, I've been crawling through the gdm files and cannot find one that specifically has the language name in the native character set and language.  The closest I've seen is 'Login Window' in all languages:

/usr/share/gdm/autostart/LoginWindow/gdm-simple-greeter.desktop
Comment 6 Bill Nottingham 2008-12-08 10:36:07 EST
Oh, fun. It generates them on the fly now. In F-8 and earlier, it was in gui/gdmlanguages.c
Comment 7 Jason Taylor 2008-12-16 09:34:35 EST
Can we just reference a wiki page with the information?
Comment 8 Karsten Wade 2008-12-16 14:45:55 EST
Sorry, I haven't been updating the bug with the status.  I got most of this done, it is live here:

http://docs.fedoraproject.org/release-notes/f10/
http://docs.fedoraproject.org/release-notes/

I was leaving this open while discussing (via f-websites-l) how to present that information better.  But the essence of this bug is finished, what's there is good enough, time to move on. :)

Note You need to log in before you can comment on or make changes to this bug.