This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 472958 - anaconda tries to do install, but then fails while installing due to "file conflicts"
anaconda tries to do install, but then fails while installing due to "file co...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 492629 558808 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 15:04 EST by James Antill
Modified: 2013-01-09 23:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-24 11:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-11-25 15:04:20 EST
Description of problem:
 Installing Fedora 10, via. anaconda CD1 + http, everything seemed to be going fine but then after an hour or so it had stopped due to the file conflict between the new Fedora gstreamer-plugins-good and my old Livna gstreamer-plugins-bad.
 The install seemed to have half happened, I have the new kernel and plymouth etc. ... but Xorg is an old version as is gdm (and so logging in crashes instantly).
Comment 1 Panu Matilainen 2008-12-01 05:49:46 EST
Rpm determines file conflicts at the beginning of transaction, not in mid-flight. So anaconda appears to be calling ts.run() again while install is in progress.
Comment 2 Jeremy Katz 2008-12-01 12:01:30 EST
With CD installs, we have to split into a transaction for each individual CD
Comment 3 James Antill 2008-12-01 12:34:33 EST
Ahh, interesting ... one minor point is that this install was:

 . download install CDs
 . unpack CDs to local network
 . insert first CD and use askmethod

...so _in theory_ anaconda could have worked it out. But it'd be nice to "fix" it
 in the general case (so it doesn't abort the install half way through).
Comment 4 Chris Lumens 2008-12-02 11:26:22 EST
Well we could always break the RPM headers out into separate files on the first disc...
Comment 5 Jeremy Katz 2008-12-02 11:34:53 EST
(In reply to comment #4)
> Well we could always break the RPM headers out into separate files on the first
> disc...

And call the file an "hdlist"? ;-)   *sigh*

More seriously, didn't we talk about in this case having to just pull the packages to the local hard drive early and install from there?  It sucks from a disk space perspective (and might require some "fun" to ensure there's sufficient space), but I can't really think of a way to handle this otherwise in the case of multiple media.
Comment 6 James Antill 2008-12-02 11:39:46 EST
Yeh, I have > 100 GB free, so pulling all the files locally works for me(tm).

That probably means the install will be slightly slower, but I don't think it'll be a significant regression in that regard.

 Oh, and I'll remind Seth to stab Chris at FudCon for comment #4 ;).
Comment 7 Chris Lumens 2008-12-02 15:49:17 EST
Yes, we did talk about doing just that.  I think it's even on my TODO list but I got distracted by something else and never got around to doing it.
Comment 8 Chris Lumens 2009-06-08 15:32:52 EDT
*** Bug 492629 has been marked as a duplicate of this bug. ***
Comment 9 Bug Zapper 2009-11-16 04:38:40 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Chris Lumens 2010-03-16 14:09:14 EDT
*** Bug 558808 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.